Formules Excel : utiliser les fonctions de base
Chargement de votre vidéo
"Formules Excel : utiliser les fonctions de base"

Formules Excel : utiliser les fonctions de base

Formules Excel : utiliser les fonctions de base

Vous débutez avec Excel ? Voici quelques fonctions et astuces pour écrire vos premières formules et laisser le tableur effectuer les calculs pour vous ! Ne vous lassez pas impressionner par les symboles : c'est très simple.

Dans cette fiche pratique, nous vous proposons une initiation express aux formules de base d'Excel. Elles vous permettront de réaliser des calculs simples en faisant référence au contenu d'autres cellules. 

Une formule commence toujours par le signe = et contient des données fixes (2020 ; "Oui") ou variables, des références de cellules ou des résultats de calculs, des opérateurs (+ - * /) et, souvent, des fonctions dont les valeurs à traiter sont inscrites dans un couple de parenthèses.   

Les formules de base dans Excel

Apprenez à calculer un total, une moyenne, ou à détecter la valeur la plus petite ou la plus élevée d'un groupe de cellules. Pour effectuer des additions simples ou plus complexes, reportez-vous aussi à notre fiche pratique, nettement plus détaillée, Additionner des nombres dans Excel.  

  • ADDITION des cellules A1 à A10.....  =SOMME(A1:A10)
  • MOYENNE des cellules A1 à A10.....  =MOYENNE(A1:A10)
  • MAXIMUM des cellules A1 à A10.....  =MAX(A1:A10)
  • MINIMUM des cellules A1 à A10.....  =MIN(A1:A10)
  • Ce sont les formules les plus simples à réaliser. Si les cellules à utiliser sont éparpillées dans la feuille, on peut les sélectionner par exemple de cette manière :
    =SOMME(A1; A3 ; C4) ou =MOYENNE(A2:A5;C7;F3:F10)

Comment utiliser la fonction SI dans Excel ?

La fonction SI est particulièrement intéressante pour vérifier si une condition est réalisée ou pas. Vous devez lui indiquer trois arguments, séparés par des points-virgules dans la version française d'Excel.

  • La fonction SI demande que vous indiquiez d'abord une condition ; puis la valeur à afficher si cette condition est vraie ; puis éventuellement la valeur à afficher si la condition n'est pas réalisée (ce troisième argument est facultatif)
    =SI(condition ; valeur "si vrai" ; valeur "sinon")
  • En voici un exemple :
    =SI(A1<=0 ; " à commander " ; " en stock ")
  • Ce qui donnerait en langage courant : si le contenu de la cellule A1 est inférieur ou égal à zéro, alors on affiche "à commander", sinon (donc si le contenu de A1 est supérieur à zéro) on affiche "en stock".
  • Si la condition n'est pas réalisée et que vous n'avez pas précisé le troisième argument, la formule renvoie la valeur FAUX, qui s'affiche dans la cellule.  

Comment copier une formule d'une cellule à l'autre dans Excel ?

Une des capacités remarquables d'Excel est de savoir adapter les formules lorsqu'on les duplique. Démonstration.

  • Pour copier la valeur ou la formule contenue dans une cellule, vous pouvez par exemple presser la combinaison de touches Ctrl+C sur PC ou Cmd+C sur Mac. Le contenu de la cellule se retrouve dans le Presse-papiers de Windows ou de macOS.
  • Pour dupliquer la valeur ou la formule, sélectionnez la ou les cellules qui doivent la recevoir et pressez par exemple la combinaison de touches Ctrl+V sur PC ou Cmd+V sur Mac pour y coller le contenu du Presse-papiers.
  • Si on copie par exemple le contenu de la cellule B10, qui contient la formule =A1+A2-A3 
  • Quand on recopie cette formule en B12, on obtient =A3+A4-A5
  • Et si on la recopie en D10 on obtient =C1+C2-C3

Comment figer l'adresse d'une cellule dans une formule Excel ?

Quand on écrit une formule faisant appel à une cellule, une fois l'adresse de la cellule saisie au clavier, appuyez sur la touche F4 pour ajouter le caractère $ aux références de cellule, afin d'obtenir des adresses relatives ou absolues.

  • En B10, saisir =A1*15 ; copier-coller en C11 : on obtient =B2*15. Dans la formule on dit que A1 une adresse relative, qu'Excel adapte en cas de copie.
  • En B10, saisir =A1 et presser la touche F4 de votre clavier ; cela devient =$A$1 ; compléter la formule =$A$1*15 et valider ; copier-coller en C11 : on obtient la même chose =$A$1*15. On appelle $A$1 une adresse absolue, qui ne change pas en cas de copie.
  • En B10, saisir =A1 et presser 2 fois la touche F4 ; cela devient =A$1 ; compléter la formule =A$1*15 et la copier en C11 : on obtient =B$1*15 car seule la référence de colonne s'est adaptée (A devient B), la ligne 1 est bloquée grâce au signe $. C'est une adresse mixte.
  • En B10, saisir =A1 et presser 3 fois la touche F4 ; cela devient =$A1 ; compléter la formule =$A1*15 et la copier en C11 : on obtient =$A2*15 car seule la référence de ligne s'est adaptée (1 devient 2), la colonne A est bloquée grâce au signe $. C'est aussi une adresse mixte.