SI, ET, OU, NON : utiliser les opérateurs logiques d'Excel
"SI, ET, OU, NON : utiliser les opérateurs logiques d'Excel"

SI, ET, OU, NON : utiliser les opérateurs logiques d'Excel

SI, ET, OU, NON : utiliser les opérateurs logiques d'Excel

Quand vous écrivez des formules dans Excel, les fonctions logiques SI, ET, OU, NON servent à tester le contenu d'une ou plusieurs cellules et à agir selon le résultat. Des fonctions à connaître absolument !

Comment afficher un résultat plutôt qu'un autre dans une cellule en fonction du contenu d'autres cellules ? D'innombrables fonctions d'Excel vous serviront à parvenir au but. Et parmi elles, les incontournables fonctions logiques SI, ET, OU et NON, que rencontre tôt ou tard l'utilisateur d'Excel qui souhaite écrire ses propres formules. Ces fonctions logiques sont si importantes qu'on les retrouve d'ailleurs dans tous les langages informatiques. Excel vous réserve, bien sûr, des versions mieux adaptées aux feuilles de calcul. Cette fiche pratique vous explique comment les utiliser, quel que soit votre tableur, Excel ou autre, dans une version récente ou même très ancienne, y compris dans LibreOffice ou OpenOffice. 

Il existe d'autres fonctions logiques, plus récentes ou spécifiques à Excel : vous trouverez des explications sur ces fonctions logiques dans l'aide en ligne de Microsoft

Comment utiliser la fonction SI dans Excel ?

La fonction SI est l'une des plus populaires d'Excel. Pour la découvrir, le mieux est encore de prendre un exemple.

  • L'objectif : si la note en A1 est supérieure ou égale à 19, alors afficher 20, sinon afficher A1.
  • Voici la formule dans Excel et les autres tableurs :
    =SI(A1>=19;20;A1)
  • Pour une vision plus détaillée, consultez l'aide en ligne de la fonction SI.  

Comment utiliser des fonctions SI imbriquées dans Excel ?

C'est ce qui fait toute la puissance d'Excel. Dans une même formule, vous pouvez utiliser le résultat d'une fonction comme une valeur à utiliser dans une autre fonction : autrement dit, vous imbriquez des fonctions dans d'autres fonctions. Exemple avec la fonction SI.

  • Premier objectif : si la note en A1 est supérieure à 12, alors afficher "continue, " ; si A1>18, alors ajouter "c'est très bien", sinon afficher "satisfaisant". Mais si A1<=12, alors afficher "à améliorer"
  • Voici la formule Excel :
    =SI(A1>12;"continuez, " & SI(A1>18;"très bien";"satisfaisant");"à améliorer")
    qui pourrait aussi s'écrire :
    =SI(A1<12;"à améliorer";SI(A1<18;"continuez, satisfaisant";"continuez, très bien")
  • Deuxième objectif : si la note en A1 est inférieure à 4, alors afficher "nul" ; si A1 compris entre 4 et 8, alors afficher "insuffisant" ; si A1 compris entre 8 et 12, alors afficher "moyen" ; si A1 compris entre 12 et 16, alors afficher "bien" ; sinon afficher "très bien"
  • Voici la formule :
    =SI(A1<4;"nul"; SI(A1<8;"insuffisant";SI(A1<12;"moyen"; SI(A1<16;"bien";"très bien"))))
  • Important : on peut écrire indifféremment
    =SI(A1="H";"Mr";SI(A2>18 ans;"Mme";"Mlle"))
    et
    =SI(A1="F";SI(A2>18 ans;"Mme";"Mlle");"Mr")

Comment utiliser la fonction ET dans Excel ?

Voici un exemple d'utilisation de la fonction ET, qui sert à vérifier si une première condition d'un test est vérifiée, et une suivante, et une suivante, etc. La fonction ET renvoie VRAI uniquement si toutes les conditions du test sont vérifiées, sinon elle renvoie FAUX.

  • L'objectif : afficher "Madame la comtesse !" si toutes ces conditions sont réalisées. A2 (sexe)=femme, B2 (statut)=mariée, C2 (époux)=comte et D2 (pointage)=présent ; sinon afficher "Bonjour"
  • La formule est :
    =SI(ET(A2="femme";B2="mariée"; C2="comte"; D2="présent");"Madame la comtesse !"; "Bonjour")
  • Pour des explications plus détaillées, consultez l'aide en ligne sur la fonction ET

Comment utiliser la fonction OU d'Excel ?

Voici un exemple de la fonction logique OU, qui renvoie VRAI si l'une au moins des conditions testées est vérifiée, sinon la fonction renvoie FAUX.

  • L'objectif : afficher "Pilote" si A3 contient l'une des données suivantes : avion, formule 1, moto ; afficher "Conducteur" si A3 contient car ou travaux ; sinon afficher "?"
  • Voici la formule Excel :
    =SI(OU(A3="avion";A3="formule 1"; A3="moto");"Pilote";SI(OU(A3="car"; A3="travaux");"Conducteur";"?"))
  • Pour des explications plus détaillées, consultez l'aide en ligne sur la fonction OU

Comment utiliser la fonction NON d'Excel ?

La fonction NON inverse la logique d'une condition : si la condition est vraie, alors la fonction NON renvoie FAUX, et inversement. En voici deux exemples.

  • La formule =SI(ENT(A3)=A3;"entier";"décimal")
    peut aussi s'écrire =SI(NON(ENT(A3)=A3);"décimal";"entier")
  • La formule =SI(A4<>"français";"étranger";"européen")
    est équivalent à =SI(NON(A4="français");"étranger";"européen")
  • Pour plus d'informations, consultez l'aide en ligne sur la fonction NON.

Comment combiner les fonctions SI, ET, OU, NON dans Excel ?

Les fonctions ET, OU, NON s'utilisent le plus souvent associées avec la fonction SI. Tout l'intérêt (et le plaisir), pour celui qui utilise un tableur, est de définir une "table de vérité" et de dessiner un organigramme représentant l'algorithme du problème à résoudre, en combinant les 4 fonctions, et en veillant à respecter les parenthèses et les points-virgules pour que la formule fonctionne.
Il faut systématiquement tester une telle formule, en essayant tous les cas de figure et les valeurs limites des variables.

Merci à Raymond Pentier à l'origine de cette fiche pratique.