Planning Excel : comment faire un planning de congés
"Planning Excel : comment faire un planning de congés"

Planning Excel : comment faire un planning de congés

Planning Excel : comment faire un planning de congés

Vous devez réaliser un planning ? Voici comment en créer un très simplement avec Excel. Pour l'exemple, vous établirez un planning de congés pour vous et vos collègues.

Si vous devez réaliser régulièrement des plannings de toutes sortes, votre premier réflexe devrait être de lancer la commande Fichier > Nouveau dans Excel, puis de taper planning dans le champ de recherche. Vous profiterez ainsi de dizaines de modèles d'allure très professionnelle et en français proposés par Microsoft. Emploi du temps, calendrier scolaire ou universitaire, planning hebdo ou semestriel, planning des salariés... les situations envisagées sont nombreuses, tant dans un cadre professionnel que scolaire ou personnel.

Tous ces modèles sont bien sûr adaptables pour se conformer à vos exigences. Mais si vous voulez faire des progrès dans Excel, vous pouvez aussi partir d'une feuille de calcul vierge et de réaliser votre propre planning ! C'est ce que nous vous proposons de faire pas à pas dans cette fiche pratique. L'exemple date de 2009, mais il vous suffira de taper les bonnes dates pour obtenir un planning de l'année en cours. Et bien entendu, cet exemple fonctionne avec toutes les versions d'Excel, même celles datant de plus de dix ans.

Comment réaliser un planning de base avec Excel ?

Dans la feuille de calcul, commencez par définir la structure de votre calendrier. Vous pourrez ensuite peaufiner la mise en forme.

  • A1 : Saisir "Congés 2009" (ou l'année en cours)
  • A2 : Saisir "NOM Prénom"
  • A3 à Ax : Saisir le nom des x personnes à gérer
  • B1 : Saisir 01/05/09 (ou par exemple 01/05/22 pour le 1er mai 2022) ; Format/Cellule/Nombre/ Personnalisé/Type jjj
  • B2 : Saisir =B1 ; Format/ Cellule/Nombre/Personnalisé/Type jj mmm
  • Incrémenter B1:B2 à droite sur 184 colonnes (jusqu'au 31/10) ; pour cela, sélectionner B1 et B2, tirer la poignée (en bas à droite), puis dans l'icône d'options de recopie incrémentée choisir Incrémenter une série
  • Sélectionner la feuille complète et activer la Mise en forme conditionnelle avec Valeur de la cellule ="c" et Format police bleu foncé + motif de remplissage bleu clair
  • Si besoin, saisir cette légende en fin de tableau : c = jour de congé (affiché en bleu)
  • Le travail de base est terminée. Saisissez pour chaque personnel la lettre "c" dans les cases correspondant à ses jours de congés : elles apparaissent en bleu !
  • Le document Excel tel qu'il devrait être après ces étapes : https://www.cjoint.com/c/DEowHH2ikpo

Comment personnaliser la présentation d'un planning avec Excel ?

Maintenant que la structure est en place, fignolez la présentation à votre guise. Vous pourriez par exemple miser sur un quadrillage en pointillés pour éviter la triste grille toute simple, genre grille de mots croisés.

  •  Lignes 1 et 2 en police taille 8 ; ligne 2 en orient° vertic.
  • Réduire la largeur de colonne (4,00 environ soit 33 pixels)
  • Ajouter dans les cellules une règle de validation avec message (au lieu d'une légende figée en bas de tableau)
  • Ajouter une condition de MFC pour les samedis et dimanches.

Gérer les jours ouvrés

En plus, on peut signaler les jours ouvrés (depuis la version d'Excel 2007). Cette option est même recommandée !
Si vous souhaitez utiliser ce planning pour décompter le nombre de jours ouvrés/ouvrables consommés par chaque agent, il faut ajouter un marquage des samedis, dimanches, jours fériés et autres ponts. Voici la procédure :

  • Insérez une ligne 3.
  • Saisissez la formule =SI(JOURSEM(1:1;2)>5;"f";"") dans toute la ligne.
  • Tapez F pour chaque autre jour non-travaillé (pont, fête).
  • En GD4, saisissez la formule =NB.SI.ENS(B4:GC4; "c";B$3:GC$3;"") et copiez vers le bas.
  • Document obtenu : https://www.cjoint.com/c/DEowKo4UVW1

Assurer le remplissage automatisé

Ajoutons à présent des colonnes pour préciser les dates de début et de fin des congés d'une personne...

  • Après la colonne A, insérer 3 colonnes nouvelles : Début, Fin, Jours ouvrés.
  • Les colonnes B et C sont à mettre au format date jj/mm ; saisir les dates de congés de chaque agent.
  • Donner à la colonne B le nom début, à la colonne C le nom fin, à la ligne 2 le nom date et à la ligne 3 le nom F.
  • Dans la cellule E4 (première case de la grille-planning) saisir la formule =SI(ET(date>=début; date<=fin;NON(F="F"));"C";"") à recopier dans toutes les cases. C'est cette formule qui inscrira C dans les cases concernant les jours non ouvrés de la période de congés.
  • Dans la cellule D4, saisir la formule =NB.SI(E4:GF4;"C"), à recopier vers le bas. La colonne GG étant devenue inutile, la supprimer.
  • Pour agrémenter la présentation du planning, depuis E4 appliquer une Mise en forme conditionnelle avec La formule est =E$3="F" et un remplissage de couleur, puis étendre cette MFC à toutes les autres cases du planning, à droite comme en bas.
  • Fichier-exemple : le résultat final au format 2007 est téléchargeable ici : https://www.cjoint.com/c/DEowMzruvxu

Comment ajouter des données au planning ?

Vous souhaitez ajouter des salariés à votre planning ? Ou créer un planning différent pour un autre service de votre entreprise ? Suivez nos conseils. 

Ajouter des personnes au planning

  • S'il faut ajouter quatre lignes, pour quatre nouveaux agents, sélectionner par exemple la ligne 6, faire Copier, sélectionner les lignes 2 à 5 et faire Insérer les cellules copiées.
  • On obtient 4 "clones" de la ligne 6, et il ne reste qu'à modifier les données ; les formats et les formules sont déjà disponibles...
  • Il ne faut surtout pas ajouter ces lignes après les lignes existantes.

Ajout une feuille pour créer un autre planning

S'il faut ajouter une autre feuille dans le fichier (pour une autre période ou un autre groupe de personnes), procéder ainsi...

  • Clic du bouton droit sur l'onglet de la feuille
  • Sélectionner Déplacer ou copier/Créer une copie/OK
  • Pour changer de personnes, modifier la colonne A.
  • Pour changer de période, changer les dates en E1 et F1, sélectionner ces deux cellules et incrémenter en tirant la poignée vers la droite.
  • Renommer la feuille
  • Les noms de plage sont conservés, mais affectés chacun à la feuille concernée.

Modifier le remplissage automatique

Nous vous proposons ci-dessous une autre manière d'assurer le remplissage automatique. Pour obtenir le remplissage automatisé en violet des cellules pour une période d'arrêt maladie, il faut recommencer la manip 6 :

  • En s'assurant que la mise en forme conditionnelle pour le remplissage des cellules contient bien la règle du violet pour la lettre-code "M".
  • En insérant 3 autres colonnes début, fin, JO.
  • En définissant les noms [débutm] pour la plage E2:E11 et [finm] pour la plage F2:F11.
  • En complétant ainsi la formule en H4:GI11 =SI(ET(date>=début; date<=fin;NON(F="F"));"C"; SI(ET(date>=débutm; date<=finm;NON(F="F"));"M"; ""))
  • Document obtenu : https://www.cjoint.com/c/GDznRW60kvy

Merci à Raymond Pentier qui a réalisé cette fiche pratique à l'origine.