Posez votre question »

Faire rapidement un planning de congés avec Excel

Juin 2015


Dessiner facilement un planning



Objectif


On a chaque année besoin de réaliser des plannings : formation, programmation, suivi, affectation ...
Voici comment afficher simplement des congés, par exemple, sur Excel.

Planning de base


  • A1 : Saisir Congés 2009
  • A2 : Saisir NOM Prénom
  • A3 à Ax : Saisir le nom des x personnes à gérer
  • B1 : Saisir 01/05/09 ; Format/ Cellule/Nombre/ Personnalisé/ Type jjj
  • B2 : Saisir =B1 ; Format/ Cellule/Nombre/Personnalisé/ Type jj mmm
  • Incrémenter B1:B2 à droite sur 184 colonnes (jusqu'au 31/10) ; pour cela sélectionner B1 et B2, tirer la poignée (en bas à droite), puis dans l'icône d'options de recopie incrémentée choisir Incrémenter une série
  • Sélectionner la feuille complète et activer la Mise en forme conditionnelle avec Valeur de la cellule ="c" et Format police bleu foncé + motif de remplissage bleu clair
  • Si nécessaire, saisir cette légende en fin de tableau : c = jour de congé (affiché en bleu)

Le travail de base est terminé. Saisissez pour chaque personnel la lettre "c" dans les cases correspondant à ses jours de congés : Elles apparaissent en bleu !
Le document Excel 2003 tel qu'il devrait être après ces étapes : http://cjoint.com/?DEowHH2ikpo

Fignolez la présentation à votre gré


... par exemple :
- bordures (quadrillage en pointillés de préférence, pour éviter l'effet "grille de prison")
- lignes 1 et 2 en police Arial Narrow ou Agency FB, taille 8 ou 9 ; ligne 2 en orient° vertic.
- réduire la largeur de colonne (4,00 environ soit 33 pixels)
- ajouter dans les cellules une règle de validation assortie d'un message de saisie (à la place d'une légende figée en bas de tableau)
- ajouter une seconde condition de mise en forme conditionnelle pour les samedis et dimanches.

En plus, détermination des jours ouvrés (à partir de la version 2007)


Si vous souhaitez utiliser ce planning pour décompter le nombre de jours ouvrés/ouvrables consommés par chaque agent, il faut ajouter un marquage des samedis, dimanches, jours fériés et autres ponts.
- insérer une ligne 3
- saisir la formule =SI(JOURSEM(1:1;2)>5;"f";"") dans toute la ligne
- taper "F" pour chaque autre jour non-travaillé (pont, fête)
- en GD4 saisir =NB.SI.ENS(B4:GC4;"c";B$3:GC$3;"") et recopier vers le bas.
Voici la feuille Excel 2007 ainsi complétée : http://cjoint.com/?DEowKo4UVW1

Remplissage automatisé


Après la colonne A insérer 3 colonnes nouvelles : Début, Fin, Jours ouvrés.
  • les colonnes B et C sont à mettre au format date jj/mm/aa, saisir les dates de congés pour chaque agent.
  • donner à la colonne B le nom début, à la colonne C le nom fin, à la ligne 2 le nom date et à la ligne 3 le nom F.
  • dans la cellule E4 (première case de la grille-planning) saisir la formule =SI(ET(date>=début; date<=fin;NON(F="F"));"C";"") à recopier dans toutes les cases. C'est cette formule qui inscrira C dans les cases concernant les jours non ouvrés de la période de congés.
  • dans la cellule D4 on aura la formule =NB.SI(E4:GF4;"C"), à recopier vers le bas. La colonne GG étant devenue inutile, la supprimer.
  • pour agrémenter la présentation du planning, depuis E4 appliquer une Mise en forme conditionnelle avec La formule est =E$3="F" et un remplissage de couleur, puis étendre cette MFC à toutes les autres cases du planning, à droite comme en bas.

Fichier-exemple


Le résultat final au format 2007 est à votre disposition ici => http://cjoint.com/?DEowMzruvxu
Pour toute erreur constatée, toute amélioration à suggérer, n'hésitez pas à contacter l'auteur :

Ajouter des lignes


Réponse à une question du 24/05/2012

S'il faut ajouter quatre lignes, pour quatre nouveaux agents, sélectionner par exemple la ligne 6, faire copier, sélectionner les lignes 2 à 5 et faire "Insérer les cellules copiées".
On obtient 4 "clones" de la ligne 6, et il ne reste qu'à modifier les données ; les formats et les formules sont déjà disponibles ...

Ajouter des feuilles


Réponse à la question de bsmsadok le 15/08/2012

S'il faut ajouter une autre feuille dans le fichier (pour une autre période ou un autre groupe de personnes), procéder ainsi :
  • Clic-droit sur l'onglet de la feuille
  • Sélectionner Déplacer ou copier/Créer une copie/OK
  • Pour changer de personnes, modifier la colonne A
  • Pour changer de période, changer les dates en E1 et F1, sélectionner ces deux cellules et incrémenter en tirant la poignée vers la droite.
  • Renommer la feuille

>>> Les noms de plage sont conservés, mais affectés chacun à la feuille concernée : pas de problème !

Observations


Mise à jour de l'accès aux 3 fichiers-exemples le 14 mai 2014 (sur alerte d'aquarelle, que je remercie).

Vous êtes tous invités à faire part de vos remarques et suggestions pour améliorer cette fiche. Merci !

Pour une lecture illimitée hors ligne, vous avez la possibilité de télécharger gratuitement cet article au format PDF :
Faire-rapidement-un-planning-de-conges-avec-excel.pdf

Réalisé sous la direction de , fondateur de CommentCaMarche.net.

A voir également

Dans la même catégorie

Publié par Raymond PENTIER.
Ce document intitulé «  Faire rapidement un planning de congés avec Excel  » issu de CommentCaMarche (www.commentcamarche.net) est mis à disposition sous les termes de la licence Creative Commons. Vous pouvez copier, modifier des copies de cette page, dans les conditions fixées par la licence, tant que cette note apparaît clairement.