CommentCaMarche
Recherche
Posez votre question »

Liste déroulante avec saisie semi automatique pour EXCEL

Février 2015

Cette procédure demande un investissement personnel et n'est pas nécessairement facile à comprendre et à réaliser dès la première fois.

Problématique


Afin de rendre cette astuce simple à utiliser, nous allons employer les plages et les formules nommées car ainsi elles sont indépendantes de la structure du classeur.
Pour l'illustrer, nous allons prendre par exemple la saisie des départements français, des cantons suisses ou des provinces canadiennes.

Méthodologie

  • 1) La liste va être saisie sur une colonne pour les noms utilisables mais il est bien sûr possible de rajouter d'autres colonnes pour le numéro ou autre bien évidemment. Il peut y avoir une ligne de titre pour identifier les données mais elle n'est pas utile pour l'utilisation.
    • Pour identifier la première valeur de la liste, nous allons lui donner un nom
      • Pour cela nous sélectionnons la première cellule de la liste.
      • Puis dans la zone noms nous saisissons son appellation "d_noms" en validant par Entrée.
    • Pour identifier la colonne de la liste, nous allons lui donner un nom
      • Nous sélectionnons la colonne complète (ici en cliquant sur B)
      • Puis dans la "zone noms" nous saisissons son appellation "c_noms" en validant par Entrée.
  • 2) La liste doit être triée sinon l'utilisation ne peut pas fonctionner de façon efficace.
    • Ainsi il ne faut pas avoir
      • 04 Alpes-de-Haute-Provence
      • 05 Hautes-Alpes
      • 06 Alpes-Maritimes
    • mais plutôt
      • 04 Alpes-de-Haute-Provence
      • 05 Alpes-Hautes
      • 06 Alpes-Maritimes
  • 3) Nous allons créer une formule nommée, afin de délimiter la zone renseignée de la liste qui pourra ensuite s'agrandir et évoluer sans souci.
    • Nous utilisons le menu "insertion" puis "Nom" puis "Définir"
    • Dans la fenêtre qui s'ouvre nous saisissons :
      • le nom de la formule "l_noms" dans la zone "Noms dans le classeur"
      • la formule =DECALER(d_noms;0;0;NBVAL(c_noms)-1;1) dans la zone "Fait référence à :"
      • Nous cliquons sur "Ajouter" pour valider la nomination.
      • Nous cliquons sur "OK" pour sortir de la fenêtre.
  • 4) Notre structure de liste étant créée, nous pourrons l'utiliser sur n'importe quelle feuille du classeur
    • Nous sélectionnons la plage de cellules où nous voulons l'utiliser, une colonne éventuellement.
    • Nous utilisons le menu "Données" puis "Validation" et sur la fenêtre de l'onglet "Options"
      • Nous choisissons "liste" dans la zone "Autoriser"
      • Nous saisissons "=l_noms" dans la zone "Source :"
      • Pour aider le choix de l'utilisateur, nous pouvons renseigner
        • un titre et un message dans l'onglet "Message de saisie"
        • un titre et un message dans l'onglet "Alerte d'erreur" avec le niveau du blocage.
      • Nous cliquons sur "OK" pour valider et sortir de la fenêtre.
  • 5) Nous pouvons maintenant cliquer sur la flèche et faire notre choix du libellé voulu.
    • Pour les provinces et territoires canadiens ainsi que pour les cantons suisses cela devrait se passer sans soucis.
    • Par contre, pour saisir l'Yonne dans les départements français, cela demande de dérouler une liste conséquente.
  • 6) Lorsque la liste est longue, il est souhaitable de pouvoir la scinder en fragments en saisissant le début du nom souhaité. Pour cela nous allons reprendre le menu de "validation"
    • Dans l'onglet "Alerte d'erreur" nous allons décocher "Quand les données..."
    • Dans l'onglet "Options" dans la zone "Source :" nous allons saisir la formule suivante :
      =SI(A1<>"";DECALER(d_noms;EQUIV(A1&"*";l_noms;0)-1;;SOMMEPROD((STXT(l_noms;1;NBCAR(A1))=TEXTE(A1;"0"))*1));l_noms)
      en remplaçant A1 par l'identification de la première cellule sélectionnée (c'est-à-dire la 1ère cellule ayant une validation par liste).
    • Nous cliquons sur "OK" pour valider et sortir de la fenêtre.

Utilisation

  • Maintenant, si avant de cliquer sur la flèche nous saisissons "t", seuls les noms commençant par "T" nous sont proposés.
  • Lorsque la liste est conséquente, l'on peut saisir plusieurs caractères et seuls les éléments de la liste commençant par la saisie seront proposés.
  • Bien sûr les noms de liste proposés peuvent être modifiés à votre guise et vous pouvez avoir plusieurs listes dans le même classeur. L'utilisation de la nomenclature est surtout faite pour faciliter la compréhension d'une technique que beaucoup ont du mal à intégrer.

-------------------------------------
Nous vous souhaitons une bonne utilisation de cette procédure, et si vous avez des soucis de prise en main, faites-le savoir pour pouvoir améliorer le texte.
-------------------------------------
Pour une lecture illimitée hors ligne, vous avez la possibilité de télécharger gratuitement cet article au format PDF :
Liste-deroulante-avec-saisie-semi-automatique-pour-excel.pdf

A voir également

Dans la même catégorie

Réalisé sous la direction de , fondateur de CommentCaMarche.net.

Publié par gbinforme - Dernière mise à jour par Raymond PENTIER
Ce document intitulé «  Liste déroulante avec saisie semi automatique pour EXCEL  » issu de CommentCaMarche (www.commentcamarche.net) est mis à disposition sous les termes de la licence Creative Commons. Vous pouvez copier, modifier des copies de cette page, dans les conditions fixées par la licence, tant que cette note apparaît clairement.