Menu

Comptabiliser le nombre d'entreprises sous Excel

Messages postés
20
Date d'inscription
lundi 11 février 2019
Dernière intervention
20 février 2019
- - Dernière réponse : Mary_6316
Messages postés
20
Date d'inscription
lundi 11 février 2019
Dernière intervention
20 février 2019
- 12 févr. 2019 à 17:34
Bonjour,
J'ai un fichier de plus de 5000 lignes.
Chaque ligne est composée d'un numéro SIREN, d'un numéro SIRET, ainsi que toutes les coordonnées de la société.

Je souhaiterais connaître le nombre d'entreprises en comptabilisant donc le nombre de SIREN en sachant qu'un SIREN peut apparaître 15 fois mais je souhaiterais qu'Excel me le compte qu'une fois. J'ai essayé la fonction NB.Si mais cela ne fonctionne pas j'arrive à avoir un résultat égale à 0 ou 1 dans chaque ligne, ce qui fausse complètement les résultats je ne comprends même pas le résultat d' Excel.
L'idée serait de réussir à obtenir par exemple 5 SIREN car ceux ci vont apparaître plusieurs.
j'espère avoir été clair. Vous remerciant pour votre aide.
Afficher la suite 

Votre réponse

1 réponse

Meilleure réponse
Messages postés
10273
Date d'inscription
mercredi 16 janvier 2013
Dernière intervention
22 février 2019
1318
1
Merci
Bonjour

Pour compter les occurrences uniques d'un champ, par ex sur la plage A2:A5000 :
=SOMMEPROD(1/NB.SI(A2:A5000;A2:A5000))
Le 1/NB.SI attribue à chaque occurrence une valeur en divisant 1 parle nombre de fois où l'on retrouve cette occurrence, par ex si elle revient 4 fois chacune aura comme valeur 0,25
Ensuite SOMMEPROD fait la somme de toutes les valeurs donc 0.25 + 0.25 +.=0.25 +0.25 donnera 1
On obtient ainsi le nombre d’occurrences différentes

Cdlmnt
Via

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 56264 internautes nous ont dit merci ce mois-ci

Mary_6316
Messages postés
20
Date d'inscription
lundi 11 février 2019
Dernière intervention
20 février 2019
-
Bonjour via55,
Merci de votre aide, cela fonctionne :))
Commenter la réponse de via55