Menu

Division

- - Dernière réponse :  Carolaro - 11 févr. 2019 à 22:52
Bonjour,

Voici ma problématique.

A1= nombre de passagers
B1= facteur d'émission
C1= nombre de km

Je souhaite appliquer cette formation =B1*C1/A1 , sauf si A1 est égal à 0
En bref, j'aimerais que dans un long formulaire, si des lignes restent vide, le résultat total donne 0 et non pas un code d'erreur (puisque la formule divise par 0).

Est-ce possible de spécifier de faire la division seulement s'il y a une donnée d'écrite dans la colonne A?

Merci!




Configuration: Windows / Chrome 71.0.3578.98
Afficher la suite 

Votre réponse

1 réponse

Messages postés
10236
Date d'inscription
mercredi 16 janvier 2013
Dernière intervention
15 février 2019
1310
0
Merci
Bonsoir

Oui 2 possibilités

Ne faire la division que si A>0 sinon rendre 0
=SI(A1>0;B1*C1/A1;0)

Ou faire la division dans tous les cas mais gérer l'erreur pour renvoyer 0 au lieu du code erreur
=SIERREUR(B1*C1/A1;0)

Cdlmnt
Via
Merci beaucoup, ça fonctionne!
Commenter la réponse de via55