Menu

Sommer sur des cellules espacées périodiquement [Résolu]

Messages postés
6
Date d'inscription
lundi 16 avril 2018
Statut
Membre
Dernière intervention
16 mai 2019
- - Dernière réponse : MonsieurPou
Messages postés
6
Date d'inscription
lundi 16 avril 2018
Statut
Membre
Dernière intervention
16 mai 2019
- 16 mai 2019 à 08:47
Bonjour,

Existe-t-il une façon de définir rapidement une plage de cellules espacées de façon périodique ?
Exemple, dans une colonne, définir une plage de cellules qui contient toutes les lignes paires (exemple sur l'image ci-dessous).


Si oui, peut-on passer cette plage de cellule en argument de fonctions de base comme SOMME ?

Mon graal serait quelque chose du genre :

 =SOMME(PLAGECELLULEPERIOD([matrice];[cellule initiale];[période]))


Ainsi,

=SOMME(PLAGECELLULEPERIOD(B2:B14;B2;2))


donnerait la somme des cellules entourées dans mon exemple.

Si quelque chose de ce genre existe, ce sera merveilleux !

Bonne soirée,

Monsieur Pou
Afficher la suite 

Votre réponse

1 réponse

Meilleure réponse
Messages postés
23959
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
18 mai 2019
5788
1
Merci
Bonjour
pour les lignes paires:
champ de B1 )à B100
=SOMMEPROD((LIGNE(B1:B100)/2-ENT(LIGNE(B1:B100)/2)=0)*(B1:B100))
et bien sur pour les lignes impaires, idem avec >0 au lieu de =>0


et vous pouvez faire la même chose avec les N° d'années en A avec:
=SOMMEPROD((A1:A100)/2-ENT(A1:A100/2)=0)*(B1:B100))
pour les années paires

crdlmnt

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 38836 internautes nous ont dit merci ce mois-ci

MonsieurPou
Messages postés
6
Date d'inscription
lundi 16 avril 2018
Statut
Membre
Dernière intervention
16 mai 2019
-
Génial, c'est exactement ce qu'il me fallait !

Décidément, j'ai encore beaucoup de choses à apprendre sur cette fameuse fonction SOMMEPROD !

Merci beaucoup !
Commenter la réponse de Vaucluse