Menu

Fonction SI [Résolu]

- - Dernière réponse :  Michel - 20 mai 2019 à 13:05
Bonjour,

Cette formule comporte une erreur mais je trouve pas, pouvez-vous m’aider ?

Merci


=SI(D34=Feuil3!F120;Feuil4!A1;SI(D34=Feuil3!F82;Feuil4!A1;SI(D34=Feuil3!F83;Feuil4!A2;SI(D34=Feuil3!F84;Feuil4!A3;SI(D34=Feuil3!F85;Feuil4!A3;SI(D34=Feuil3!F86;Feuil4!A4;SI(D34=Feuil3!F87;Feuil4!A5;0)))))))+SI(D34=Feuil3!F88;Feuil4!B1;SI(D34=Feuil3!F89;Feuil4!B1))


Configuration: iPhone / Safari 12.1
Afficher la suite 

Votre réponse

6 réponses

Messages postés
23967
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
23 mai 2019
4591
0
Merci
Bonjour
quelle est l'erreur signalée? Collée chez moi, cette formule est acceptée sans problème?
à vous lire
crdlmnt
Merci je teste demain

Cordialement
Commenter la réponse de Vaucluse
0
Merci
Merci pour votre réponse, l’erreur est #valeur quand je rajoute les 2 derniers arguments, avant elle fonctionne, merci bien
Vaucluse
Messages postés
23967
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
23 mai 2019
4591 -
Alors l'erreur ne vient pas de la formule, mais la valeur définie par les dernières conditions (soit doncFeuil4!B1), car ce défaut vient du fait que vous sommer (via le signe +) des valeurs qui ne sont pas numériques.
Si c'est une addition que vous voulez faire, il faut que la valeur sélectionnée soit n numérique
Si par contre vous écrivez ceci pour contourner la limite des 7 SI des anciens Excel (qui n'existe plus à partir de 2007) ce n'est pas le signe + qu'il faut utiliser, mais le signe &

Mais vous pouvez à partir de 2007 écrire cette formule comme suit:
=SI(OU(D34=Feuil3!F120;D34=Feuil3!F82);Feuil4!A1;SI(D34=Feuil3!F83;Feuil4!A2;SI(OU(D34=Feuil3!F84;D34=Feuil3!F85);Feuil4!A3;SI(D34=Feuil3!F86;Feuil4!A4;SI(D34=Feuil3!F87;Feuil4!A5;0)))))+SI(OU(D34=Feuil3!F88;D34=Feuil3!F89);Feuil4!B1)

crdlmnt
Commenter la réponse de Michel
0
Merci
Bonjour j’ai utilisé le signe & et curieusement ça marche (bien que j’a utilisé ET sur tous les autres champs du même formulaire, mais mon résultat est précédé de Faux, donc il y a encore un ajustement à faire, qu’en pensez-vous ?

Cordialement
Vaucluse
Messages postés
23967
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
23 mai 2019
4591 -
et quelle est la formule exacte que vous avez écrite
si le résultat est précédé de FAUX, c'est que c'est la partie après le & qui est active, mais qu'il manque l'option 0 ou "" en fin de la première partie, avant la série de parenthèses avant le &
soit.....;"")))))&SI(...
ou.....;0)))))&SI(...
par contre pour éviter un FAUX dans la seconde partie, il faut aussi p^révoir la fin:
........&SI(OU(D34=Feuil3!F88;D34=Feuil3!F89);Feuil4!B1;""')

crtdlmnt
.
Commenter la réponse de Michel
0
Merci
=SI(H33=Feuil3!F120;Feuil4!A2;SI(H33=Feuil3!F82;Feuil4!A4;SI(H33=Feuil3!F83;Feuil4!A4;SI(H33=Feuil3!F84;Feuil4!A6;SI(H33=Feuil3!F85;Feuil4!A6;SI(H33=Feuil3!F86;Feuil4!A8))))))&SI(H33=Feuil3!F87;Feuil4!A10;SI(H33=Feuil3!F88;Feuil4!B2;SI(H33=Feuil3!F89;Feuil4!B2;SI(H33=Feuil3!F90;Feuil4!B4))))
Vaucluse
Messages postés
23967
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
23 mai 2019
4591 -
voir la réponse précédente que j'ai complétée (elle était partie bien avant la fin)
avec les éléments à rajouter en fin de formule dans les deux parties
=SI(H33=Feuil3!F120;Feuil4!A2;SI(H33=Feuil3!F82;Feuil4!A4;SI(H33=Feuil3!F83;Feuil4!A4;SI(H33=Feuil3!F84;Feuil4!A6;SI(H33=Feuil3!F85;Feuil4!A6;SI(H33=Feuil3!F86;Feuil4!A8;""))))))&SI(H33=Feuil3!F87;Feuil4!A10;SI(H33=Feuil3!F88;Feuil4!B2;SI(H33=Feuil3!F89;Feuil4!B2;SI(H33=Feuil3!F90;Feuil4!B4;""))))
Commenter la réponse de Michel
0
Merci
J’ ai rajouté le 0 et un 0 apparaît avant le texte de résultat mais je n’a plus « faux »
Commenter la réponse de Michel
0
Merci
=SI(H33=Feuil3!F120;Feuil4!A2;SI(H33=Feuil3!F82;Feuil4!A4;SI(H33=Feuil3!F83;Feuil4!A6;SI(H33=Feuil3!F84;Feuil4!A9;SI(H33=Feuil3!F85;Feuil4!A10;SI(H33=Feuil3!F86;Feuil4!A13;""))))))&SI(H33=Feuil3!F87;Feuil4!A16;SI(H33=Feuil3!F88;Feuil4!B2;SI(H33=Feuil3!F89;Feuil4!B4;SI(H33=Feuil3!F90;Feuil4!B5;SI(H33=Feuil3!F91;Feuil4!B7;SI(H33=Feuil3!F92;Feuil4!B10;SI(H33=Feuil3!F93;Feuil4!B12;"")))))))&SI(H33=Feuil3!F94;Feuil4!B14)

Maintenant Faux apparaît après le résultat obtenu, je ne comprends pas pourquoi
Vaucluse
Messages postés
23967
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
23 mai 2019
4591 -
Je recommence:
chaque ensemble de SI (un avant le & et un après) renvoie FAUX si vous ne lui donnez pas une option au cas où aucune conditions n'est réalisée
Il faut donc sur chaque ensemble rajouter cette option, comme je l'ai écrit dans mon message ici, une fois
;"" 
derrière le Feuil4!A13 et une fois derrière le dernier Feuil4!B14
https://www.commentcamarche.net/forum/affich-36025150-fonction-si#8
et pour ne pas avoir le 0 remplacez le comme proposé par ""
Merci beaucoup, ça fonctionne, il reste pour moi incompréhensible que ma formule initiale de type SI.....0 + SI fonctionne parfaitement dans tous les champs de mon formulaire et que j’a du la changer dans un seul champ

Cordialement
Commenter la réponse de Michel