Menu

Excel : remplir cellules depuis autre feuille [Résolu/Fermé]

- - Dernière réponse : ccm3
Messages postés
1
Date d'inscription
jeudi 19 janvier 2017
Statut
Membre
Dernière intervention
20 janvier 2017
- 20 janv. 2017 à 00:24
Bonjour,

J'ai une petite question sur Excel.

Dans une feuille, j'ai une liste de références, la désignation d'un produit et le prix. Voici un exemple :

Réf.     Désignation      Prix
258561   Machin           10
334723   Bidule           25
477856   Truc             99


Je souhaiterais, dans une autre feuille, en entrant simplement la référence, avoir automatiquement la désignation et le prix dans des autres cellules.

Je ne sais pas si je suis très clair...

Par exemple, en entrant simplement la référence "334723" dans la cellule A3, la cellule A4 devrait être automatiquement remplie avec la valeur "Bidule" et la cellule A6 avec la valeur "25".

Je sais qu'il est possible de passer par une condition (IF...), mais cette solution me paraît pas vraiment appropriée quand la liste des références est importante.

Merci pour votre aide !



Afficher la suite 

2 réponses

Meilleure réponse
approuvée par Jean-François Pillou le 31 janv. 2019
Messages postés
4429
Date d'inscription
lundi 20 avril 2009
Statut
Contributeur
Dernière intervention
12 septembre 2014
1125
12
Merci
Bonjour,

il te faut utiliser la formule RECHERCHEV(valeur_cherchée;table_matrice;no_index_col;[valeur proche]) avec :
valeur cherchée : la valeur que tu recherches
table_matrice : la table sur laquelle tu rechercheras la valeur (sachant que la recherche se fait toujours sur la première colonne de la matrice)
no_index_col : le numéro de la colonne correspondant à la valeur que tu veux afficher :
[valeur_proche] : les crochets indiquent que cette valeur n'est pas obligatoire dans la formule. Ce paramètre prend pour valeur VRAI (ou 1) si les données de la matrice sont triés par ordre croissant, FAUX (ou 0) sinon.


Dans ton cas, si tu écris 334723 en A3, pour avoir "Bidule" en A4 tu peux écrire la formule :
=RECHERCHEV(A3;'Feuil1'!$A:$C;2;0)
Cordialement.

Dire « Merci » 12

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 51352 internautes nous ont dit merci ce mois-ci

Super, merci beaucoup !
ccm3
Messages postés
1
Date d'inscription
jeudi 19 janvier 2017
Statut
Membre
Dernière intervention
20 janvier 2017
1 -
Petite précision, il faut que la valeur cherchée soit en colonne A de la feuille table matrice (feuille1), sinon ça marche pas. La valeur à afficher peut au contraire se situer dans toutes les cellules de la feuille 2. Avec l'ex, pour étirer proprement la formule en A4 (feuille2) sur environ 100 lignes (A5,A6..), je vous conseille, =RECHERCHEV(A3;FEUILLE1!$A$1:$C$100;2;0)

Bonne nuit
Messages postés
12246
Date d'inscription
jeudi 15 mai 2008
Statut
Modérateur
Dernière intervention
2 juillet 2019
2074
11
Merci
Bonjour,
Vos données en feuil1!A2:C5000, la colonne A triée.
En Feuil2!A3 inscrire une référence,
En A4 =RECHERCHEV(A3;Feuil1!A1:C5000;2;FAUX)
En A5 =RECHERCHEV(A3;Feuil1!A1:C5000;3;FAUX)