Excel 2010 Liste et saisie semi automatique

tintin - 16 févr. 2017 à 18:08 - Dernière réponse : gbinforme 14411 Messages postés lundi 18 octobre 2004Date d'inscriptionContributeurStatut 11 décembre 2017 Dernière intervention
- 16 févr. 2017 à 21:34
Bonjour,

J'ai créé une liste avec la fonction décaler afin d'utiliser la saisie semi automatique. Toutefois excel semble faire un distinction entre les minuscules et les majuscules. Comme la liste source est en majuscule, la saisie semi automatique ne fonctionne pas lorsque je saisie des minuscules.

Avez-vous une solution?

Merci!
Afficher la suite 

1 réponse

Répondre au sujet
gbinforme 14411 Messages postés lundi 18 octobre 2004Date d'inscriptionContributeurStatut 11 décembre 2017 Dernière intervention - 16 févr. 2017 à 21:34
0
Utile
Bonjour,

Je suppose que tu as cette formule en remplaçant A1 par ta cellule
=SI(A1<>"";DECALER(d_noms;EQUIV(A1&"*";l_noms;0)-1;;SOMMEPROD((STXT(l_noms;1;NBCAR(A1))=TEXTE(A1;"0"))*1));l_noms)

Tu la modifies ainsi et elle fonctionnera
=SI(A1<>"";DECALER(d_noms;EQUIV(MAJUSCULE(A1&"*");l_noms;0)-1;;SOMMEPROD((STXT(l_noms;1;NBCAR(A1))=TEXTE(MAJUSCULE(A1);"0"))*1));l_noms)

--
Toujours zen
La perfection est atteinte, non pas lorsqu'il n'y a plus rien à ajouter, mais lorsqu'il n'y a plus rien à retirer.  Antoine de Saint-Exupéry
Commenter la réponse de gbinforme