Signaler

Excel 2010 Liste et saisie semi automatique

Posez votre question tintin - Dernière réponse le 16 févr. 2017 à 21:34 par gbinforme
Bonjour,

J'ai créé une liste avec la fonction décaler afin d'utiliser la saisie semi automatique. Toutefois excel semble faire un distinction entre les minuscules et les majuscules. Comme la liste source est en majuscule, la saisie semi automatique ne fonctionne pas lorsque je saisie des minuscules.

Avez-vous une solution?

Merci!
Afficher la suite 
Utile
+0
moins plus
Bonjour,

Je suppose que tu as cette formule en remplaçant A1 par ta cellule
=SI(A1<>"";DECALER(d_noms;EQUIV(A1&"*";l_noms;0)-1;;SOMMEPROD((STXT(l_noms;1;NBCAR(A1))=TEXTE(A1;"0"))*1));l_noms)

Tu la modifies ainsi et elle fonctionnera
=SI(A1<>"";DECALER(d_noms;EQUIV(MAJUSCULE(A1&"*");l_noms;0)-1;;SOMMEPROD((STXT(l_noms;1;NBCAR(A1))=TEXTE(MAJUSCULE(A1);"0"))*1));l_noms)

--
Toujours zen
La perfection est atteinte, non pas lorsqu'il n'y a plus rien à ajouter, mais lorsqu'il n'y a plus rien à retirer.  Antoine de Saint-Exupéry
Donnez votre avis

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !