Signaler

Recherche de syntaxe sous Excel [Résolu]

Posez votre question SAMAJESTE - Dernière réponse le 14 nov. 2016 à 18:33
Je voudrais saisir la syntaxe suivante dans une salle

La Cellule prend les valeurs suivantes si aux conditions cumulées suivantes :
- S : si D15 supérieur à 50% et D16= BONNE ou MOYENNE
- MS : si D15=50% et D16=MOYENNE
- MI : si D15 inférieur à 50% et D16= MOYENNE
- I : si D15 inférieur à 50% et D16 = MAUVAISE
Afficher la suite 
Utile
+0
moins plus
Dans une salle, je ne sais pas.
Mais dans une feuille Excel, ton exposé se traduit par
=SI(ET(D15>50%;OU(D16="BONNE";D16="MOYENNE"));"S";
SI(D16="MOYENNE";SI(D15=50%;"MS";
SI(D15<50%;"MI";"indéterminé"));
SI(ET(D15<50%;D16="MAUVAISE");"I";"indéterminé")))

et tu remarqueras que tu as mal étudié ton problème, puisque tu n'indiques pas ce qu'il faut afficher dans la cellule
si D16= "BONNE" mais si D15 ni égal ni inférieur à 50%
si D16= "MAUVAISE" mais D15 ni égal ni supérieur à 50% !
Raymond PENTIER 39722Messages postés lundi 13 août 2007Date d'inscription ContributeurStatut 2 décembre 2016 Dernière intervention - 14 nov. 2016 à 18:33
Si ces deux conditions ne peuvent jamais se produire, c'est-à-dire que "BONNE" n'est possible que si D15>50% et "MAUVAISE" n'est possible que si D15<50%, alors tout devient beaucoup plus simple :
=SI(D15>50%;"S";SI(D15<50%;SI(D16="MOYENNE";"MI";"I");"MS"))

... et ton explication de départ aurait dû être :
- S : si D15 supérieur à 50% (donc avec D16= BONNE ou MOYENNE )
- MS : si D15=50% et D16=MOYENNE
- MI : si D15 inférieur à 50% et D16= MOYENNE
- I : si D16 = MAUVAISE (donc avec D15 inférieur à 50%)
Répondre
Ajouter un commentaire

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !