Comment changer ma variable PATH sur linux [Résolu/Fermé]

Messages postés
63
Date d'inscription
dimanche 18 novembre 2007
Statut
Membre
Dernière intervention
16 février 2009
- - Dernière réponse : jipicy
Messages postés
43479
Date d'inscription
jeudi 28 août 2003
Statut
Modérateur
Dernière intervention
9 octobre 2019
- 22 nov. 2007 à 20:07
Bonjour,
je suis debutant sur linux. Je viens d'installer un compilateur GNUARM dans mon dossier personnel Home et je voudrais savoir comment inclure le bin de mon compilateur en permance dans ma variable d'environnement PATH. J'ai essayé avec export PATH=/home/user/mes_prog/bin/:$PATH dans une fenetre console et ca marche. Mon probleme est que je dois le faire a chaque fois que je recommence une session Konsole i.e quand je ferme ma fenetre la variable PATH redevient comme avant.

Ma question est comment changer cette variable PATH pour qu'elle soit reconnue pour de bon.

En vous remerciant d'avance, bonne soirée
Afficher la suite 

4 réponses

Meilleure réponse
Messages postés
43479
Date d'inscription
jeudi 28 août 2003
Statut
Modérateur
Dernière intervention
9 octobre 2019
4609
5
Merci
Salut,

Tu dois le mettre en dur dans ton fichier de configuration propre à ton shell de connexion qui se trouve dans ton répertoire personnel $HOME, à savoir en fonction des différents shell de connexion :
Shell Bash (Bourne Again SHell)
.bashrc ou .bash_profile

Shell Bourne(sh)
.shrc

Korn shell
.kshrc ou .profile

Shell Zsh
.zshrc

C-Shell(csh)
.cshrc

Shell tcsh
.tcshrc ou .cshrc
;-))

Dire « Merci » 5

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 71126 internautes nous ont dit merci ce mois-ci

Messages postés
8214
Date d'inscription
samedi 7 août 2004
Statut
Membre
Dernière intervention
1 septembre 2014
455
2
Merci
Bonjour,

voir fichier .bash_profile

:-))
Messages postés
43479
Date d'inscription
jeudi 28 août 2003
Statut
Modérateur
Dernière intervention
9 octobre 2019
4609
1
Merci
Re-

Essaie comme ça plutôt :
# set PATH so it includes user's private bin if it exists
if [ -d ~/mon_rep/bin/bin ] ; then
PATH=~/mon_rep/bin/bin:"${PATH}"
fi 
ensuite il faut prendre en compte ce changement en rechargeant le fichier, donc depuis ton répertoire personnel, tapes :
source ~/.profile
PS. T'es sûr qu'il y a 2 répertoire "/bin" ? (mon_rep/bin/bin)
Messages postés
63
Date d'inscription
dimanche 18 novembre 2007
Statut
Membre
Dernière intervention
16 février 2009
6
0
Merci
resalut,


j'ai suivi vos conseils et me j'ai cherché les fichiers dans mon dossier personnel HOME.J'ai trouvé les fichiers suivant.

.bashrc

# ~/.bashrc: executed by bash(1) for non-login shells.
# see /usr/share/doc/bash/examples/startup-files (in the package bash-doc)
# for examples

# If not running interactively, don't do anything
[ -z "$PS1" ] && return

# don't put duplicate lines in the history. See bash(1) for more options
export HISTCONTROL=ignoredups
# ... and ignore same sucessive entries.
export HISTCONTROL=ignoreboth

# check the window size after each command and, if necessary,
# update the values of LINES and COLUMNS.
shopt -s checkwinsize

# make less more friendly for non-text input files, see lesspipe(1)
[ -x /usr/bin/lesspipe ] && eval "$(lesspipe)"

# set variable identifying the chroot you work in (used in the prompt below)
if [ -z "$debian_chroot" ] && [ -r /etc/debian_chroot ]; then
debian_chroot=$(cat /etc/debian_chroot)
fi

# set a fancy prompt (non-color, unless we know we "want" color)
case "$TERM" in
xterm-color)
PS1='${debian_chroot:+($debian_chroot)}\[\033[01;32m\]\u@\h\[\033[00m\]:\[\033[01;34m\]\w\[\033[00m\]\$ '
;;
*)
PS1='${debian_chroot:+($debian_chroot)}\u@\h:\w\$ '
;;
esac

# Comment in the above and uncomment this below for a color prompt
#PS1='${debian_chroot:+($debian_chroot)}\[\033[01;32m\]\u@\h\[\033[00m\]:\[\033[01;34m\]\w\[\033[00m\]\$ '

# If this is an xterm set the title to user@host:dir
case "$TERM" in
xterm*|rxvt*)
PROMPT_COMMAND='echo -ne "\033]0;${USER}@${HOSTNAME}: ${PWD/$HOME/~}\007"'
;;
*)
;;
esac

# Alias definitions.
# You may want to put all your additions into a separate file like
# ~/.bash_aliases, instead of adding them here directly.
# See /usr/share/doc/bash-doc/examples in the bash-doc package.

#if [ -f ~/.bash_aliases ]; then
# . ~/.bash_aliases
#fi

# enable color support of ls and also add handy aliases
if [ "$TERM" != "dumb" ]; then
eval "`dircolors -b`"
alias ls='ls --color=auto'
#alias dir='ls --color=auto --format=vertical'
#alias vdir='ls --color=auto --format=long'
fi

# some more ls aliases
#alias ll='ls -l'
#alias la='ls -A'
#alias l='ls -CF'

# enable programmable completion features (you don't need to enable
# this, if it's already enabled in /etc/bash.bashrc and /etc/profile
# sources /etc/bash.bashrc).
if [ -f /etc/bash_completion ]; then
. /etc/bash_completion
fi


et .profile


# ~/.profile: executed by the command interpreter for login shells.
# This file is not read by bash(1), if ~/.bash_profile or ~/.bash_login
# exists.
# see /usr/share/doc/bash/examples/startup-files for examples.
# the files are located in the bash-doc package.

# the default umask is set in /etc/profile
#umask 022

# if running bash
if [ -n "$BASH_VERSION" ]; then
# include .bashrc if it exists
if [ -f ~/.bashrc ]; then
. ~/.bashrc
fi
fi

# set PATH so it includes user's private bin if it exists
if [ -d ~/bin ] ; then
PATH=~/bin:"${PATH}"
fi


J'ai essayé d'nclure mon repertoire personelle /home/yovan/mon_rep/bin dans .profile comme suit :
# set PATH so it includes user's private bin if it exists
if [ -d ~/bin ] ; then
PATH=~/home/yovan/mon_rep/bin/bin:"${PATH}"
fi


J'ai sauvegarder mes changements mais les changements n'ont pas été pris en compte.

Si vous pouriez m'aider svp. Je vous rapelle que je suis sur Kubuntu.

Merci