Multiplication Excel

Signaler
-
eriiic
Messages postés
23116
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
12 décembre 2019
-
Bonjour,

Comment je peux faire svp:
Je rentre des heures dans B2 (somme)
Et je souhaite que ces heures soit tout le temps multiplié par 70 euros
Et le résultat de ce produit soit également dans B2.

Merci de votre aide.
Configuration: Windows Phone / Edge 13.10586
Messages postés
2029
Date d'inscription
lundi 6 mai 2013
Statut
Membre
Dernière intervention
12 décembre 2019
239
Bonjour,

Recopiez ceci dans le module de la feuille
Private Sub Worksheet_Change(ByVal target As Range)
    Application.EnableEvents = False
    If target.Address = "$B$2" Then
        target.Value = target.Value * 70
    End If
    Application.EnableEvents = True
End Sub


Pour accéder au module de la feuille, faire ALT + F11
Dans la colonne de gauche, double-clic sur le nom de la feuille, et coller dans la partie droite.

Cdlt
Messages postés
23116
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
12 décembre 2019
5791
Bonjour,

avec tes heures au format excel hh:mm :
=SOMME(C2:E2)*24*70 

eric

PS : Frenchie, une formule ne déclenche pas l'événement Change. De toute façon une macro parait inutile ;-)

En essayant continuellement, on finit par réussir. 
Donc plus ça rate, plus on a de chances que ça marche.(les Shadoks)
En plus du merci (si si, ça se fait !!!), penser à mettre en résolu. Merci
Messages postés
2029
Date d'inscription
lundi 6 mai 2013
Statut
Membre
Dernière intervention
12 décembre 2019
239
Bonsoir Eric,

Vous avez sûrement raison, mais de mon côté, j'ai peut-être mal interprété la demande.
manustrur dit :
"Je rentre des heures dans B2 (somme)"
ce qui sous-entend à mon sens une saisie manuelle, (entre parenthèse, il parle d'une somme, cette somme est-elle le résultat d'une formule ou bien d'une saisie manuelle?)
puis il ajoute
"Et le résultat de ce produit soit également dans B2."
D'où mon raisonnement, si la saisie est manuelle, il ne peut y avoir une formule en B2 puisqu'elle serait écrasée par la prochaine saisie en B2.

Bonne soirée

Cordialement
eriiic
Messages postés
23116
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
12 décembre 2019
5791
Ca se défend ;-)
Interprétation qui ne m'était pas venue mais possible oui