Menu

Test sur excel

Messages postés
5
Date d'inscription
lundi 6 mai 2019
Statut
Membre
Dernière intervention
21 mai 2019
- - Dernière réponse : Raymond PENTIER
Messages postés
49110
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
18 juin 2019
- 21 mai 2019 à 19:03
test 1 test2 test3 resultat


je n'arrive pas à faire une formule qui me donne un resultat si..

si case test 1 est pleine et case test 2 vide.. alors forcement on n a rien en test 3.. et donc le resultat est le contenu de la case test1
si case test 2 est pleine (donc test 1 pleine aussi..), et que test 3 vide.. alors resultat est contenu de la case test 2
sinon resultat test 3.. cela veux dire que les 3 cases sont remplies..

je ne saispas si je me suis bien fait comprendre.

je vous remercie par avance pour votre reponse.
Afficher la suite 

4 réponses

Messages postés
2399
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
10 juin 2019
260
0
Merci
Bonjour à tous,

=SI(ET(A1<>"";B1="");A1;SI(ET(B1<>"";C1="");B1;SI(ET(A1=0;B1=0);0;C1)))

Et si a1 et b1 sont vide ?


Crdlmt
Commenter la réponse de DjiDji59430
Messages postés
1972
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
17 juin 2019
373
0
Merci
Bonjour

Ma proposition en espérant avoir compris

Les 3 tests en A1, B1 et C1 ; résultat en D1

=SI(ET(A1="";B1="";C1="");"";SI(ET(A1<>"";B1="";C1="");A1;SI(ET(A1<>"";B1<>"";C1="");B1;C1)))

Cordialement
Commenter la réponse de PapyLuc51
Messages postés
418
Date d'inscription
vendredi 18 juillet 2008
Statut
Membre
Dernière intervention
21 mai 2019
45
0
Merci
Bonjour,
Les 3 tests en A1, B1 et C1 ; résultat en D1
=SI(ESTVIDE(C1);SI(ESTVIDE(B1);A1;B1);C1)
Commenter la réponse de didibonf
Messages postés
49110
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
18 juin 2019
10039
0
Merci
Bonjour johnaz.

Mes 3 camarades n'ont pas voulu te vexer ; mais en réalité tu ne t'es pas bien fait comprendre du tout !
Alors essaie de reprendre tes explications.
Commenter la réponse de Raymond PENTIER