Menu

Copier une valeur si 2 données sont égales [Résolu]

Messages postés
7
Date d'inscription
mardi 5 février 2019
Statut
Membre
Dernière intervention
7 mai 2019
- - Dernière réponse : Vaucluse
Messages postés
23963
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
20 mai 2019
- 7 mai 2019 à 15:13
Bonjour

Voilà je vous remercie d'avance pour le coup de main éventuel.

Je souhaiterai créer une formule qui remplirait ces conditions.

Si la valeur dans la case A déterminé (ex : B43) est égale à une valeur dans la colonne B d'une autre onglet (l'onglet NUMEROTATION 2019) alors copier la valeur de la Colonne C de l'onglet NUMEROTATION 2019 sur la même ligne que la valeur correspondante.

Désolé difficile de clarifier mon idée.


=si.conditions(B43='NUMEROTATION 2019'!A:A;"NUMEROTATION 2019'!H:H")


Merci de votre aide encore
Afficher la suite 

Votre réponse

1 réponse

Meilleure réponse
1
Merci
Bonjour,

Essaye avec :
=SIERREUR(RECHERCHEV(B43;'NUMEROTATION 2019'!B1:H1000;7;FAUX);"NON TROUVE")


Cordialement.

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 39199 internautes nous ont dit merci ce mois-ci

CS-PRUNE
Messages postés
7
Date d'inscription
mardi 5 février 2019
Statut
Membre
Dernière intervention
7 mai 2019
-
Merci de votre retour désole ca ne fonctionne pas, voici le fichier

https://www.cjoint.com/c/IEhiPPp3JW3
CS-PRUNE
Messages postés
7
Date d'inscription
mardi 5 février 2019
Statut
Membre
Dernière intervention
7 mai 2019
-
LA Colonne AP
Vaucluse
Messages postés
23963
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
20 mai 2019
5788 -
Bonjour
et pourtant l'ami girus (salut) a raison
en AF4 et pas en AP qui est vide (?)

=SI(C4="";"";SIERREUR(RECHERCHEV(C4;'NUMEROTATION 2019'!A:H;7;0);"non trouvé"))

toutefois il ne semble pas y avoir beaucoup de références de cette colonne C présentes dans la feuille de recherche
crdlmnt
CS-PRUNE
Messages postés
7
Date d'inscription
mardi 5 février 2019
Statut
Membre
Dernière intervention
7 mai 2019
-
Merci de votre retour, et oui cela fonctionne le souci était de ma faute, la donnée avait été mal rentrée je vais modifier cela.
Par contre il me copie la donnée dans la colonne F ou G mais pas la valeur numérique dans la colonne H, comment dois je procéder ?
Vaucluse
Messages postés
23963
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
20 mai 2019
5788 -
la formule que j'ai écrite cherche la valeur dans la colonne A vous ressort la valeur dans la colonne de la plage dont le N° est indiqué derrière l'adresse de la plage
soit dans celle de mon message: la 7° colonne de la plage A:H et donc la colonne G
soit vous chercher dans la colonne A pour ressortir H et donc pour avoir la colonne H remplacer le 7 par 8
=SI(C4="";"";SIERREUR(RECHERCHEV(C4;'NUMEROTATION 2019'!A:H;8;0);"non trouvé"))
soit vous cherchez dans la colonne B et donc la formule devient:
=SI(C4="";"";SIERREUR(RECHERCHEV(C4;'NUMEROTATION 2019'!B:H;7;0);"non trouvé"))

crdlmnt
Commenter la réponse de gyrus