Menu

Recherche N° semaine [Résolu]

Messages postés
45
Date d'inscription
samedi 17 janvier 2015
Statut
Membre
Dernière intervention
7 mai 2019
- - Dernière réponse : jujuokl
Messages postés
45
Date d'inscription
samedi 17 janvier 2015
Statut
Membre
Dernière intervention
7 mai 2019
- 7 mai 2019 à 14:51
Bonjour,

J'ai un tableau excel avec une feuille par mois. Pour chaque mois, j'ai une colonne avec les jours, et une avec le n° de semaine. Dans un second tableau, j'utilise une formule afin de me marquer les numéros de semaines du mois en cours, pour faire un total/semaine.
Par exemple en G8 j'ai "=SI(ESTVIDE(D5)=VRAI;0;NO.SEMAINE(D5;2))", puis G9 "=SI(ESTVIDE(D12)=VRAI;0;NO.SEMAINE(D12;2))".. ainsi de suite en espaçant mes cellules de 7 jours.



Pour la plupart des mois ça fonctionne bien, sauf quand une 6ème semaine commence en fin de mois, car mon tableau récapitulatif va chercher la valeur en D40.

Exemple avec le mois de septembre


Je recherche donc une formule, qui fonctionnerai malgré les changements de mois.

Merci d'avance

Le fichier excel si ça peut aider https://www.cjoint.com/c/IEhiTHKhUUP
Afficher la suite 

Votre réponse

2 réponses

Meilleure réponse
Messages postés
539
Date d'inscription
lundi 22 septembre 2008
Statut
Membre
Dernière intervention
7 mai 2019
77
1
Merci
Bonjour

A tester avec une formule matricielle
https://mon-partage.fr/f/93PVJ94Q/

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 39126 internautes nous ont dit merci ce mois-ci

jujuokl
Messages postés
45
Date d'inscription
samedi 17 janvier 2015
Statut
Membre
Dernière intervention
7 mai 2019
5 -
Merci beaucoup ! Je comprends absolument pas la formule mais ça fonctionne pour tous les mois on dirait, merci !
Commenter la réponse de M-12
1
Merci
Bonjour,
Ton tableau modifié, sans formules trop compliquées
https://mon-partage.fr/f/eSCUYHwu/
Bonne continuation

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 39126 internautes nous ont dit merci ce mois-ci

jujuokl
Messages postés
45
Date d'inscription
samedi 17 janvier 2015
Statut
Membre
Dernière intervention
7 mai 2019
5 -
Merci mais je préfère la formule de M-12. Si jamais il y a que 4 semaines dans 1 mois (02/2021 par exemple), la sienne m'affiche bien que 4 semaines dans la tableau, alors que la tienne m'affiche quand même la 5eme
Bonjour,
Pas de soucis
Ci-joint une modification quand même
https://mon-partage.fr/f/cyUE7tLv/
Et regarde bien le mois de février 2021 dans les deux cas
jujuokl
Messages postés
45
Date d'inscription
samedi 17 janvier 2015
Statut
Membre
Dernière intervention
7 mai 2019
5 -
Avec la modif, ça marche comme il faut, je vais l'utiliser du coup, elle me parait plus simple et je l'a comprends. Merci !
Commenter la réponse de ALS35