Menu

Formule si

Messages postés
52
Date d'inscription
mercredi 2 janvier 2019
Statut
Membre
Dernière intervention
18 mai 2019
- - Dernière réponse : Raymond PENTIER
Messages postés
48874
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
20 mai 2019
- 8 mai 2019 à 18:37
Bonjour
j'ai deux lignes qui contiennent des formules
C1 et F1
mon souci c'est que dans la case "C20" reste vide quand:
si C1 est vide ne m'envois pas le résultat et si F1 et vide ne m'envois pas le résultat
ici la case ou j'ai fais la formule.
case "C20" =SIERREUR((C19*C1)+(C18*F1);"")
je veux un résultat dans la case "C20" et pas le vide
merci
Afficher la suite 

Votre réponse

3 réponses

Messages postés
48874
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
20 mai 2019
16142
0
Merci
Bonjour.

1) " je veux un résultat dans la case "C20" et pas le vide "
Il y a effectivement le résultat 0 (sauf si tu as enlevé l'option "Afficher un zéro dans les cellules qui ont une valeur nulle").

2) Ta formule n'est pas logique : les 2 multiplications donnent toujours un résultat ; donc il n'y a jamais d'impossibilité de calculer ; donc la fonction SIERREUR est inutile !
La formule en C20 doit s'écrire simplement =C19*C1+C18*F1
belba.yahya
Messages postés
52
Date d'inscription
mercredi 2 janvier 2019
Statut
Membre
Dernière intervention
18 mai 2019
-
merci Monsieur Raymond,j'ai essayé elle m’envoie le vide quand C19 =0 ou C18=0
Raymond PENTIER
Messages postés
48874
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
20 mai 2019
16142 -
Tu n'as pas lu (ou tu n'as pas compris) ma première réponse :
1) " je veux un résultat dans la case C20 et pas le vide " 
Il y a effectivement le résultat 0 (sauf si tu as enlevé l'option "Afficher un zéro dans les cellules qui ont une valeur nulle").
Commenter la réponse de Raymond PENTIER
Messages postés
16893
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
20 mai 2019
5130
0
Merci
Bonjour,

Pas très clair comme explication sauf erreur de compréhension si erreur tu renvois rien ""
si tu veux 0 remplace "" par 0
=SIERREUR((C19*C1)+(C18*F1);0)
belba.yahya
Messages postés
52
Date d'inscription
mercredi 2 janvier 2019
Statut
Membre
Dernière intervention
18 mai 2019
-
je vous remercie Monsieur pour votre aide. çi dessous le lien de mon classeur
vous allez trouver la case B18 et B19 comme liste déroulante, si vous choisissez une et vous lui donnez la quantité elle doit envoyé le nombre dans la case C20, mais pas les deux (B18 et B19)
https://www.cjoint.com/c/IEibLA7NYMs
Commenter la réponse de Mike-31
Messages postés
48874
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
20 mai 2019
16142
0
Merci
Désolé, mais je continue à ne pas tout comprendre !
Commenter la réponse de Raymond PENTIER