Menu

Extraire certains mots de plusieurs cellules Excel [Résolu]

Messages postés
8
Date d'inscription
vendredi 1 mars 2019
Statut
Membre
Dernière intervention
4 mars 2019
- - Dernière réponse : PHILOU10120
Messages postés
5326
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
11 juin 2019
- 4 mars 2019 à 11:54
Bonjour,

J’ai un tableau où deux cellules contiennent une liste différente de mots tels que : "Draps et linges compris – Espace Spa – Lit 90 cm – Lit 160 cm – Literie grand confort – Matériel Bébé – Wifi" etc.

Je ne veux garder que "Spa" et "Wifi".

Quelle formule appliquer pour que dans une autre colonne apparaisse seulement "Spa – Wifi" ?

Merci

Gunter


Configuration: iPhone / Safari 12.0
Afficher la suite 

4 réponses

Meilleure réponse
Messages postés
808
Date d'inscription
samedi 16 février 2019
Statut
Membre
Dernière intervention
14 juin 2019
58
1
Merci
Bonjour,

Un début à adapter =

Si données en colonne A

Colonne B
=SI(NB.SI(A1;"*wifi*");"wifi";"")

Colonne C
=SI(NB.SI(A1;"*spa*");"spa";"")

Et colonne D tu peut concaténer (="B1" & " - " & "C1") par exemple

Cdlt,

T3ch'

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 42547 internautes nous ont dit merci ce mois-ci

Gunter_3310
Messages postés
8
Date d'inscription
vendredi 1 mars 2019
Statut
Membre
Dernière intervention
4 mars 2019
-
Bonjour, Merci beaucoup ça fonctionne !
Comme dire OU dans la formule suivante pour rechercher "parking" ou "parking privé" :
…*Parking* OU *Parking privé*");" PARKING";…

voici le code qui fonctionne où j'aimerais rajouter OU :
=SI(NB.SI(M2:N2;"*climatisation*");" CLIM";"")&SI(NB.SI(M2:N2;"*Espace Spa*");" BIEN ETRE";"")&SI(NB.SI(M2:N2;"*Parking*");" PARKING";"")
Gunter_3310
Messages postés
8
Date d'inscription
vendredi 1 mars 2019
Statut
Membre
Dernière intervention
4 mars 2019
-
Je viens d'essayer ceci :
=SI(NB.SI(M4:N4;"*climatisation*");" CLIM";"")&SI(NB.SI(M4:N4;"*Espace Spa*");" BIEN ETRE";"")&SI(NB.SI(M4:N4;"*Parking*")
+NB.SI(M4:N4;"*Parking privé*");" PARKING";"")&SI(NB.SI(M4:N4;"*Wifi*");" WIFI";"")


Quelle est la différence entre le signe + ou * ? cela me renvoie le même résultat.
Commenter la réponse de T3chN0g3n
Messages postés
5326
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
11 juin 2019
317
1
Merci
Bonjour à vous deux

Essayer ceci

=SI(SIERREUR(TROUVE("Wifi";A1;1);0)>0;"wifi";"")

ou ceci

SI(SIERREUR(CHERCHE(" spa";A1;1);0)>0;"Spa";"") attention à l'espace devant " Spa"

Si vous ne mettez pas l'espace, il trouve Spa dans espace spa

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 42547 internautes nous ont dit merci ce mois-ci

Gunter_3310
Messages postés
8
Date d'inscription
vendredi 1 mars 2019
Statut
Membre
Dernière intervention
4 mars 2019
-
Bonjour et merci beaucoup pour votre réponse rapide.

Comme je n'ai pas trop "compris" cette formule, et que je n'ai pas pu la faire fonctionner, j'ai utilisé celle de T3chN0g3n répétée plusieurs fois à la suite dans la même cellule (ce qui m'évite trop de colonnes et de concaténer)

=SI(NB.SI(M2:N2;"*climatisation*");" CLIM";"")&SI(NB.SI(M2:N2;"*Espace Spa*");" BIEN ETRE";"")&SI(NB.SI(M2:N2;"*Parking*");" PARKING";"")


J'aimerai améliorer cette version, voir ma réponse qui va suivre.
Merci !
Commenter la réponse de PHILOU10120
Messages postés
5326
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
11 juin 2019
317
1
Merci
Bonjour

Essayer cette formule

=SUPPRESPACE(SUBSTITUE(SUBSTITUE(SUBSTITUE(SUBSTITUE(A1;"Terrain clos commun";);"Parking privé";"";1);CAR(150);"";3);CAR(150);"";3))

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 42547 internautes nous ont dit merci ce mois-ci

Gunter_3310
Messages postés
8
Date d'inscription
vendredi 1 mars 2019
Statut
Membre
Dernière intervention
4 mars 2019
-
Bonjour, super !
On doit répéter SUBSTITUE autant de fois que de mots à "substituer " ?
On ne peut pas dire :
SUBSTITUE "ce mot" et "celui-ci" et "celui-là" ?
à quoi correspond le …;1) ?
le caractère 150, c'est le tiret ?
et le …;3 ?

Si je veux chercher dans deux cellules, la plage A1:B1 ne fonctionne pas apparement ?
PHILOU10120
Messages postés
5326
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
11 juin 2019
317 -
non la fonction SUBSTITUE remplace le texte entre "" par celui que vous voulez entre ""
Si entre guillemets il n'y a rien, la fonction ne met rien

3 position du tiret CAR(150)
comme on supprime le premier à la position 3 celui de la position 4 devient 3 d'où la répétition
Gunter_3310
Messages postés
8
Date d'inscription
vendredi 1 mars 2019
Statut
Membre
Dernière intervention
4 mars 2019
-
OK, du coup j'ai un peu de mal à la mettre à jour avec de nouveaux mots car elle est pour le moment complexe pour moi.
Par ailleurs je n'ai pas forcément besoin des tirets, cela pourrait m'aider à simplifier la formule ?
Sans pour autant rajouter des espaces, mais je vois qu'il y en a avant et après les tirets, ce qui veut dire qu'ils sont là sans besoin de les rajouter ?
PHILOU10120
Messages postés
5326
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
11 juin 2019
317 -
La fonction "SUPPRESPACE(…) en début de formule supprime les espaces inutile dans le texte
Commenter la réponse de PHILOU10120
Messages postés
8
Date d'inscription
vendredi 1 mars 2019
Statut
Membre
Dernière intervention
4 mars 2019
0
Merci
Bonjour,
Merci pour vos réponses.

Pouvez-vous m'aider à améliorer cette méthode ?
J'aimerais désormais "supprimer" (masquer ou effacer) les mots qui ne me servent pas :

Dans cette liste par exemple : Climatisation – Espace Spa – Parking – Terrain clos commun – Parking privé

Pour l'instant j'utilise :
=SI(NB.SI(M2:N2;"*climatisation*");" CLIM";"")&SI(NB.SI(M2:N2;"*Espace Spa*");" BIEN ETRE";"")&SI(NB.SI(M2:N2;"*Parking*");" PARKING";"")


et j'aimerais plutôt supprimer : les mots inutiles tels que ceux soulignés pour ne garder que les gras :
Climatisation Espace SpaParkingTerrain clos communParking privé

Bonne journée,
Zoul67
Messages postés
1904
Date d'inscription
lundi 3 mai 2010
Statut
Membre
Dernière intervention
29 avril 2019
120 -
Bonjour,

Avec la fonction SUBSTITUE, mais uniquement si tu as la liste exhaustive des mentions à supprimer.

A+
Gunter_3310
Messages postés
8
Date d'inscription
vendredi 1 mars 2019
Statut
Membre
Dernière intervention
4 mars 2019
-
Merci ! maintenant j'essaye de raccourcir la formule sans répéter SUBSTITUE et rechercher dans A1:B1
=SUPPRESPACE(SUBSTITUE(SUBSTITUE(SUBSTITUE(SUBSTITUE(A1;"Terrain clos commun";);"Parking privé";"";1);CAR(150);"";3);CAR(150);"";3)) 

Je n'ai pas la liste exhaustive mais je la réactualise à la main à chaque fois que je vois un mot en trop dont je n'ai pas besoin… ça m'évite d'en oublier dans le cas où j'utiliserai la première formule (SI(NB.SI)…
Zoul67
Messages postés
1904
Date d'inscription
lundi 3 mai 2010
Statut
Membre
Dernière intervention
29 avril 2019
120 -
Je n'ai pas la liste exhaustive donc la méthode "additive" semble plus appropriée que la "soustractive"...
Commenter la réponse de Gunter_3310