Menu

Problème excel / Sexe Masculin / Féminin [Résolu]

Messages postés
13
Date d'inscription
mardi 16 octobre 2018
Dernière intervention
18 octobre 2018
- - Dernière réponse : Mike-31
Messages postés
16862
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
21 février 2019
- 16 oct. 2018 à 12:51
Bonjour,

J'ai un petit souci sur excel.

J'ai une liste de 4 prénoms / noms masculins et 5 prénoms / noms feminins :

par exemple :

Masculin : David Leman / Thomas Iger / Jean Luc / Samuel Esteban
Feminin : Jenny Del/ Sara Marine/ Alexia Degrand/ Louane Dange/ Lori Prescri

------

J'ai un tableau de données qui reprennent leurs prénoms avec d'autres statistiques. J'aimerai incorporer une colonne ayant comme titre "Sexe". Du coup j'aimerai savoir quel est la formule à utiliser pour qu'il définisse le sexe à chaque fois que je rajouter une ligne comportant l'un des noms cités au dessus.

J'ai un tableau vertical pour les deux sexes sur un onglet séparé dans excel.

J'ai essayé RECHERCHEV mais j'ai toujours un problème avec #NOM!


merci de votre aide !
Afficher la suite 

Votre réponse

7 réponses

Meilleure réponse
Messages postés
16862
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
21 février 2019
5037
1
Merci
Re,

la aussi comment sont saisi tes données, exemple pour Liridon Jan 01.18.2001
es ce que tu as dans une cellule exemple en A2 Liridon, en B2 Jan et en C2 01.18.2001

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 56682 internautes nous ont dit merci ce mois-ci

Commenter la réponse de Mike-31
Messages postés
16862
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
21 février 2019
5037
0
Merci
Bonjour,

comment est sont des listes, par exemple celle des prénoms Masculin : David Leman / Thomas Iger / Jean Luc / Samuel Esteban

le tout dans la même cellule, en ligne dans plusieurs cellules ou en colonne*
le principe
=SI(OU(NB.SI(A2;"*David*");NB.SI(A2;"*Thomas*");NB.SI(A2;"*Jean Luc*");NB.SI(A2;"*Samuel*")>0);"Masculin";"")
ou comme cela
=SI(A2="";"";SI(OU(NB.SI(A2;"*David*");NB.SI(A2;"*Thomas*");NB.SI(A2;"*Jean Luc*");NB.SI(A2;"*Samuel*")>0);"Masculin";"Féminin"))
A+
Mike-31

Je suis responsable de ce que je dis, pas de ce que tu comprends...
Commenter la réponse de Mike-31
Messages postés
13
Date d'inscription
mardi 16 octobre 2018
Dernière intervention
18 octobre 2018
0
Merci
Merci de cette réponse aussi rapide !

J'ai une dernière question :

J'ai une feuille avec un tableau comme ceci :

Liridon Jan 01.18.2001
Morgan Cressier 20.01.2001
Sara Han 15.06.2002
Tristan Param 02.09.2000
Valentin Lef 10.02.1990
Cyril Legrand 12.02.2004


J'aimerai qu'on puisse retrouver n'importe quel date de naissance lié au nom prénom de la personne. Je m'explique :

J'ai une colonne :

Nom Date de naissance
Liridon
Valentin
Tristan


En mettant une formule, celle-ci reconnaitra les noms et mettra la bonne date de naissance.

Voilà ma dernière question ! et merci encore pour votre dernière réponse!
Commenter la réponse de jodecimob
Messages postés
13
Date d'inscription
mardi 16 octobre 2018
Dernière intervention
18 octobre 2018
0
Merci
Alors j'ai une feuille séparée listé comme ceci par exemple:

A B
1 Nom Date de Naissance
2 Liridon
3 Jean
4 Michel

Une autre feuille où c'est listée pareil :

A B
1 Nom Date de Naissance
2 Liridon 19.10.2000
3 Jean 20.12.2003
4 Michel 26.11.2001

Sauf que la première liste elle contient plus de données que je n'ai pas mis ici. Donc quand j'ajouterai de nouveau LIRIDON dans la première liste j'aimerai sa date de naissance dans la colonne B.
jodecimob
Messages postés
13
Date d'inscription
mardi 16 octobre 2018
Dernière intervention
18 octobre 2018
-
donc A1 = Nom
B1 = date de naissance
Commenter la réponse de jodecimob
Messages postés
16862
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
21 février 2019
5037
0
Merci
Re,

exemple tes données sont sur la feuille nommée Feuil2
=RECHERCHEV(A2;Feuil2!A2:E20;2;0)

je te conseille d'inclure une détection d'erreur à ta formule comme cela
=SIERREUR(RECHERCHEV(A2;Feuil2!A2:E20;2;0);"")

tu pourrais également simplifier ta formule en nommant ta matrice ou sont stocké les données, exemple
la plage Feuil2!A2:E20 si tu la nommes par exemple List la formule devient
=SIERREUR(RECHERCHEV(A2;List;2;0);"")
Commenter la réponse de Mike-31
Messages postés
13
Date d'inscription
mardi 16 octobre 2018
Dernière intervention
18 octobre 2018
0
Merci
Votre formule me donne une réponse de 39740... Elle calcule je pense la date de naissance.
Mike-31
Messages postés
16862
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
21 février 2019
5037 -
Il faut formater ta cellule en format Date
39740 correspond au 19/10/2008
jodecimob
Messages postés
13
Date d'inscription
mardi 16 octobre 2018
Dernière intervention
18 octobre 2018
-
Ok merci énormément !
Commenter la réponse de jodecimob
Messages postés
16862
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
21 février 2019
5037
0
Merci
Re,

je passe le statut de la discussion en résolu, ce qui ne t’empêchera pas d'y revenir pour une information complémentaire si besoin
Commenter la réponse de Mike-31