Menu

Bonjour, sur excel 2000, je veux faire un calcul de case [Résolu]

didier28 - 11 mai 2017 à 20:45 - Dernière réponse :  didier28
- 12 mai 2017 à 09:11
Bonjour, dans la case AB11, je veux que s'affiche "X" si le montant de l'une des cases L11, N11, P11, R11, et T11 est supérieur à 0, sachant que chacune de ces cases est le résultat d'une formule, donc indique un chiffre ou rien.


par avance merci de votre réponse

cordialement didier



Afficher la suite 

6 réponses

Répondre au sujet
Vaucluse 21897 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 25 avril 2018 Dernière intervention - 11 mai 2017 à 20:57
0
Utile
Bonjour

=SI(OU(L11>0,N11>0;P11>0;R11>0;T11>0);"X";"")

ou encore:

=SI(MAX(L11;N11;P11;R11;T11)>0;"X";"")

crdlmnt
Commenter la réponse de Vaucluse
0
Utile
Merci, c'était le seconde formule qui était la bonne.


cordialement didier
Commenter la réponse de didier28
0
Utile
Désolé, j'ai répondu un peu trop vite, en fait cette formule ne convient pas vraiment, car il faut qu'elle comptabilise aussi le chiffre 0, en fait, il faut qu'elle comptabilise toutes les cases qui ne sont pas vides, ou le résultat n'est pas "rien". Voici un exemple des formules qui se trouvent dans ces cases :
=SI(ET(J11<$A$6;J11-H11>=reproduction!$A$9;F11="♂");J11-H11;"")


cordialement didier
Commenter la réponse de didier28
Mike-31 16102 Messages postés dimanche 17 février 2008Date d'inscriptionContributeurStatut 25 avril 2018 Dernière intervention - 11 mai 2017 à 21:59
0
Utile
Re,

Si j'ai bien compris
=SI(SOMMEPROD(--(L11&N11&P11&R11&T11<>""))>0;"x";"")
Commenter la réponse de Mike-31
0
Utile
merci de votre patience, et cette fois ci, ça marche


cordialement didier
Commenter la réponse de didier28
0
Utile
Bonjour, pourquoi cette formule "=SI(SOMMEPROD(--(L11&N11&P11&R11&T11<>""))>0;"x";"")"marche bien s'il y a des zéro, et ne marche pas s'il n'y en a pas, alors que celle ci "=SI(MAX(V11;X11;Z11)>0;"X";"")"marche bien quand il n'y a pas de zéro et ne marche pas quand il y en a ?
Hors dans les deux cas, il peut y avoir des zéros ou pas ... N'y a t'il pas une formule qui serait commune aux deux cas, avec ou sans zéro, sachant qu'il peut à tout moment y en avoir, et qu'ils peuvent apparaitre et disparaitre à tout moment selon les calculs automatiques ?

cordialement didier
Commenter la réponse de didier28