Menu

Excel: Afficher plusieurs fois un caractère [Résolu/Fermé]

-
Bonjour,

J'aimerai réaliser un truc qui parait simple mais je ne trouve pas la façon pour procéder....

J'ai créer un tableau qui ressemble a ceci:

A B C D E F
Produit Date Nbr Commandé STOCK Manque petits carrés
J'aimerai que ma dernière colonne (F) comportant des petits carrés se remplisse automatiquement selon le nombre de produit manquant (colonne E).

Ce qui revient a repéter X fois un nombre de caractère spécial selon la valeur d'une cellule.... et je ne connait pas la fonction ou macro permettant de réaliser ceci.

Merci d'avance
Afficher la suite 

5 réponses

Meilleure réponse
Messages postés
15893
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
28 juin 2019
2765
1
Merci
Je dois avoir un ordi spécial mais:
http://www.cijoint.fr/cjlink.php?file=cj201101/cijWULZPmb.xls
avec XL 2003
Michel

Dire « Merci » 1

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 54765 internautes nous ont dit merci ce mois-ci

tchernosplif
Messages postés
602
Date d'inscription
dimanche 8 novembre 2009
Statut
Membre
Dernière intervention
21 juin 2015
195 -
je confirme, rien n'apparaît chez moi .
michel_m
Messages postés
15893
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
28 juin 2019
2765 -
Comme j'ai l'air de te déranger, j'ai donc supprimé ma proposition
tchernosplif
Messages postés
602
Date d'inscription
dimanche 8 novembre 2009
Statut
Membre
Dernière intervention
21 juin 2015
195 -
Mais pas du tout,c'est dommage, je ne voulais pas te vexer.
Messages postés
22778
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
19 juillet 2019
5555
1
Merci
Bonsoir tout le monde,

il y a aussi la fonction REPT()
=REPT(CAR(161);7) avec la police wingdings2 met 7 carrés
eric

Dire « Merci » 1

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 54765 internautes nous ont dit merci ce mois-ci

Messages postés
602
Date d'inscription
dimanche 8 novembre 2009
Statut
Membre
Dernière intervention
21 juin 2015
195
0
Merci
Bonjour,

Est-ce que ça convient ?

http://www.cijoint.fr/cjlink.php?file=cj201101/cijC7S3k9r.xls
Messages postés
24210
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
19 juillet 2019
4681
0
Merci
Bonjour

une autre option peut être, directement liée aux nombre manquant:
en colonne F:
calibrer la police qui convient pour afficher le caractère que vous voulez voir
en F1:
entrez un nombre de caractères suffisants pour couvrir tous les risques de manque que vous prévoyez;
(vous pouvez aussi faire cette référence sur une cellule hors champ ou même sur une feuille masquée.)

votre premier calcul sur ligne 2
en D2 produit commandé
en E2 l'état du stoc
en F2:
=SI(E2>D2;"";STXT($F$1;1;D2-E2)
à tirer sur la hauteur du champ en bloquant bien le $F$1 qui doit rester sur toutes les lignes

crdlmnt
l



Demandons nous si nous ne sommes pas seuls à comprendre ce que l'on explique?
0
Merci
Bonjour à tous,

Merci pour votre aide.

J'ai finalement utiliser la fonction de répétion caractères donné par Eric et michel_M.

Cordialement