EXCEL Si 3 conditions, 3 résultats différents [Résolu/Fermé]

Messages postés
66
Date d'inscription
jeudi 6 mai 2010
Statut
Membre
Dernière intervention
9 mai 2017
- - Dernière réponse :  ghofran - 26 févr. 2015 à 17:11
Bonjour,

Je suis confronté à un problème sur excel.
J'aimerai trouver le moyen de remplir une cellule avec 3 possibilités de réponse ( "OUI" "NON" ou "N.A." ) , en fonction du texte que je vais écrire dans une autre cellule.

Dans mon cas je veux:
OUI si la cellule ne contient pas de texte (par défaut)
NON si elle contient le lettre N
N.A. si elle contient la lettre B


Dit comme ça cela parait bidon, mais je suis depuis une après midi la dessus!
Aidez moi SVP! =)

Merci d'avance!


Afficher la suite 

3 réponses

Meilleure réponse
approuvée par Jean-François Pillou le 25 janv. 2019
Messages postés
6197
Date d'inscription
jeudi 9 juillet 2009
Statut
Contributeur
Dernière intervention
20 mars 2017
1376
27
Merci
Bonjour,

=SI(A1="N";
"NON";
SI(A1="B";"NA";"OUI"))


"Trotti Trotta, Monsieur P, il y a des anges qui veulent un bisou..."
"Même les joujou de Monsieur P ont besoin de joujou"

Dire « Merci » 27

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 62798 internautes nous ont dit merci ce mois-ci

rnalextexmex
Messages postés
66
Date d'inscription
jeudi 6 mai 2010
Statut
Membre
Dernière intervention
9 mai 2017
59 -
Merci Neliel et chossette9 , grâce à vous j'ai réussi! c'était bien ça.

c'est fou comme les problèmes se résolvent vite grâce à ce forum! Merci à tous.

.... je vais quand même essayer de comprendre la formule, histoire de ne plus être confronté à ce problème par la suite.

thx!
Messages postés
4428
Date d'inscription
lundi 20 avril 2009
Statut
Contributeur
Dernière intervention
12 septembre 2014
1159
10
Merci
Bonjour,

en supposant que la cellule à tester est A1, on écrit en B1 :
=SI(A1="N";"Non";SI(A1="B";"N.A";SI(ESTVIDE(A1);"Oui";"")))


Cordialement.
Messages postés
6197
Date d'inscription
jeudi 9 juillet 2009
Statut
Contributeur
Dernière intervention
20 mars 2017
1376
4
Merci
Je vais t'aider à la comprendre, il s'agit en fait de 2 SI imbriqué (pour mon cas)

En français, cela donne:

=SI(A1="N";"NON";SI(A1="B";"NA";"OUI"))

SI la cellule A1 contient "N" alors écrire "NON" SINON SI la cellule A1 contient "B" alors écrire "NA" SINON écrire "OUI"
chossette9
Messages postés
4428
Date d'inscription
lundi 20 avril 2009
Statut
Contributeur
Dernière intervention
12 septembre 2014
1159 -
Oui mais dans ce cas là, tu ne prends pas en compte la demande OUI si la cellule ne contient pas de texte (par défaut) , c'est pourquoi j'ai imbriqué 3 SI :

SI A1 contient "N" alors écrire "Non", SINON si A1 contient "B" écrire "N.A", SINON si A1 est vide écrire "Oui", sinon ne rien écrire.

Cordialement.
Neliel
Messages postés
6197
Date d'inscription
jeudi 9 juillet 2009
Statut
Contributeur
Dernière intervention
20 mars 2017
1376 -
Tu as parfaitement raison... mais tu as fait du zèle! Il n'y avait que 3 possibilités selon son énoncé! ;-)
chossette9
Messages postés
4428
Date d'inscription
lundi 20 avril 2009
Statut
Contributeur
Dernière intervention
12 septembre 2014
1159 -
Ces 3 possibilités en appelle une quatrième par défaut : Si c'est différent des 3 conditions, alors on ne met rien.

De toutes façons, les deux solutions fonctionnent.
Merci Beaucoup ça maaaaaaarcheeeeeeeee