Menu

Formule Excel pour afficher les mois (chiffres) en lettre [Résolu/Fermé]

-
Bonjour,
J'ai crée un tableau ds EXCEL , ds la première collonne j'ais mis la date et dans la deuxième j'ai mis "mois" avec la formule: =SI(A4="";"";MOIS(A4))
Le résultat me donne le mois en chiffres, mais ce qui m'interresserais c'est de l'avoir en lettre.
Est ce possible ?
Merci de votre réponse
Configuration: Windows XP Internet Explorer 7.0
Afficher la suite 

4 réponses

Meilleure réponse
approuvée par Jean-François Pillou le 13 déc. 2018
86
Merci
Il faut mettre tout simplement cette fonction
=TEXTE(30*MOIS(A4);"mmmm")

Dire « Merci » 86

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 50691 internautes nous ont dit merci ce mois-ci

Raymond PENTIER
Messages postés
48331
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
13 mars 2019
15855 > Amazigh -
pour avoir une date avec le mois qui s'actualise : =TEXTE(AUJOURDHUI();"mmmm")
merci beaucoup !
oui c'est vrai mais il y'a beaucoup de methodes
13
Merci
plus simple qu'une fonction personnalisée :

Première solution : modifier le format de cellule
Entrer un format personnalisé "mmmm" qui affichera un champ date
sous forme de mois en lettres.
Clic droit sur la cellule > Format de cellule > Personnalisé > Taper "mmmm" dans le champ Type.
NB: La cellule conserve la même valeur, seul l'affichage a changé.

Deuxième solution: convertir le champ date en champ texte
La fonction TEXTE permet de convertir un champ chiffre en un champ texte en respectant un format indiqué.
On peut aussi convertir un champ date en un champ texte.
Dans ton cas tu peux écrire dans B4 par exemple:
=TEXTE(A4;"mmmm")
Cette fois-ci B4 contient bien un texte et plus une date.
J'ai essayé votre fonction =TEXTE(A4;"mmmm") mais le seul mois qui s'affiche est janvier.
J'ai modifié les formats de cellule, etc., etc. mais rien ne fonctionne.
Savez-vous ce que je peux faire pour résoudre mon problème ?
Mytå
Messages postés
2995
Date d'inscription
mardi 20 janvier 2009
Statut
Contributeur
Dernière intervention
20 décembre 2016
1041 -
Re le forum

Ta cellule A4 doit contenir une date valide.

Sinon utilise la fonction du Permalink (#5)

Mytå
@ cultissime : il faut paramétrer le premier jour de la semaine. Tu as 2 options, soit tu définis le 1er jour de la semaine comme étant le dimanche, auquel cas, ton 7ème jour est bien un samedi, soit tu définis le lundi comme étant le premier jour. L'option se trouve à la fin de ta formule.
Raymond PENTIER
Messages postés
48331
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
13 mars 2019
15855 -
Pourquoi tant de complications ?
Tu saisis la date 05/04/12 en A2 ; tu mets le format personnalisé jj : 5 s'affiche.
Tu saisis en B2 la formule =A2 ; tu mets le format personnalisé mmmm : avril s'affiche.
C'est tout, et il ne peut pas y avoir d'erreur.
Bonjour,
j'avais la même question... l'addage se vérifie: les problèmes les "plus" compliqués ont souvent les solutions les plus simples...Raymond...tout simplement génial, fallait y penser!!! Cela fonctionne parfaitement. Un tout grand merci à tous, vous m'avez fait gagner un temps dingue.
Merci
Messages postés
2995
Date d'inscription
mardi 20 janvier 2009
Statut
Contributeur
Dernière intervention
20 décembre 2016
1041
10
Merci
Salut le forum

Avec la fonction CHOISIR

=SI(A4="";"";CHOISIR(MOIS(A4);"Janvier";"Février";"Mars";"Avril";"Mai";"Juin";"Juillet";"Août";"Septembre";"Octobre";"Novembre";"Décembre"))

Mytå
1
Merci
=TEXTE(B9;"jj mmmm aaaa")
Raymond PENTIER
Messages postés
48331
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
13 mars 2019
15855 -
FAUX : on a demandé seulement le mois en toutes lettres ; pas la date complète !