Signaler

Compteur excel [Résolu]

Posez votre question BEEcas 4Messages postés mercredi 8 novembre 2017Date d'inscription 9 novembre 2017 Dernière intervention - Dernière réponse le 9 nov. 2017 à 09:43 par eriiic
Bonjour à tous,

J'ai besoin de votre aide svp.
j'ai des données dans une colonne qui se répètent. je souhaiterais créer une nouvelle colonne qui met des 1 uniquement la première fois qu'une valeur apparaît (si elle apparaît une seconde fois, que la cellule soit vide): ce serait une colonne compteur pour un tcd...
j'ai essayé la fonction frequence avec le si mais ca ne fonctionne pas... j'ai 5000 lignes je ne peux pas le faire manuellement.
je suis complètement bloquée...
Merci pour votre qide
Utile
+0
plus moins
Bonjour,

en b2
=si(a2<>a3;1;"")

Cdlmnt
Raymond PENTIER 44226Messages postés lundi 13 août 2007Date d'inscription ContributeurStatut 14 novembre 2017 Dernière intervention - 8 nov. 2017 à 14:46
... et si tes données ne sont pas triées dans la colonne A, utilise en B3 la formule
=SI(NB.SI(A$2:A3;A3)=1;1;"") à recopier vers le bas.
Répondre
BEEcas 4Messages postés mercredi 8 novembre 2017Date d'inscription 9 novembre 2017 Dernière intervention - 8 nov. 2017 à 16:20
Merci Djidji et Raymond pour vos réponses rapides! ça marche bien même si j'ai 2 ou 3 répétitions encore( sur 3000 lignes je peux pas me plaindre!). je re-verifie avec un tcd et je rectifie a la mano. je crois que le pb c'est que je peux avoir des données qui se suivent et se répètent jusqu'a 4 ou 5 fois....
Répondre
DjiDji59430 1728Messages postés samedi 19 avril 2008Date d'inscription 14 novembre 2017 Dernière intervention - 8 nov. 2017 à 17:35
Bonjour ,
bonjour Raymond

Joins un fichier-test, (avec TOUTES les explications et les résultats souhaités) ou mieux, si c'est possible, le fichier concerné.
1) Tu vas dans http://cjoint.com/
2) Tu cliques sur [Parcourir] pour sélectionner ton fichier
3) Tu descends en bas de la page pour cliquer sur [Créer le lien Cjoint]
4) Au bout de quelques secondes s'affiche le lien en bleu souligné ; tu le sélectionnes et tu fais "Copier"
5) Tu reviens dans la discussion, et, dans ton message de réponse, tu fais : "Coller".

Cordialement.
Répondre
Raymond PENTIER 44226Messages postés lundi 13 août 2007Date d'inscription ContributeurStatut 14 novembre 2017 Dernière intervention BEEcas - 9 nov. 2017 à 02:43
BEEcas,
Je te signale que la formule =SI(NB.SI(A$2:A3;A3)=1;1;"") fait exactement ça !
Il ne peut pas y avoir de répétition ...
Répondre
BEEcas 4Messages postés mercredi 8 novembre 2017Date d'inscription 9 novembre 2017 Dernière intervention - 8 nov. 2017 à 18:50
http://www.cjoint.com/c/GKirKHriZze

Le lien met du temps à se mettre en bleu j'espère que vous pourrez voir l'exemple.
Donc en A j'ai des familles de produits, en B des codes et en C des coloris (un code à plusieurs coloris d'où la repetition des codes).je souhaiterais avoir en D, des 1 uniquement lorsqu'un code apparaît pour la 1ere fois et rien pour les répétitions. Ce tableau va me servir pour avoir le tcd que j'ai schématisé à côté.le but est de déterminer le nombre de code par famille...
Désolée c'est brouillon mais je travaille de mon portable...
Merci encore.
Répondre
Donnez votre avis
Utile
+0
plus moins
Bonjour,

=SI(EQUIV(A3;A:A;0)=LIGNE();1;"") 

eric
BEEcas 4Messages postés mercredi 8 novembre 2017Date d'inscription 9 novembre 2017 Dernière intervention - 9 nov. 2017 à 08:50
Merci Éric ça marche!!!!
Et merci pour les citations !!!!je mets en résolu...
Merci à tous...
Répondre
eriiic 21165Messages postés mardi 11 septembre 2007Date d'inscription ContributeurStatut 14 novembre 2017 Dernière intervention - 9 nov. 2017 à 09:43
La proposition de raymond sans doute aussi. Tu aurais pu tester correctement avant
Répondre
Donnez votre avis

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !