Formule pour mettre des cellules verticales dans une ligne [Résolu]

Silana - 11 oct. 2017 à 11:51 - Dernière réponse :  Silana
- 11 oct. 2017 à 14:56
Bonjour,

Je suis en train de réaliser un tableau que je souhaiterais automatiser mais je ne parviens pas à trouver la formule adaptée :

Mes données sont dans le Feuillet 1 en colonne B sur une cinquantaine de lignes environ.

Je réalise mon tableau dans le Feuillet 2 et souhaite répartir les données de la colonne B du Feuillet 1 dans la ligne 1 de mon feuillet 2 (en horizontal donc), et les inclure dans la formule suivante :

SI('Feuillet1'!B1<0;'Feuillet1'!B1;0)

Ainsi, par exemple dans mon Feuillet 2, je voudrais aboutir au résultat suivant :

Cellule A1 : SI('Feuillet1'!B1<0;'Feuillet1'!B1;0)
Cellule B1 : SI('Feuillet1'!B2<0;'Feuillet1'!B2;0)
Cellule C1: SI('Feuillet1'!B3<0;'Feuillet1'!B3;0)
etc...

Sauf qu'évidemment, lorsque j'étire ma formule ça me donne les données horizontales de mon Feuillet 1 et non verticales.

Qqu aurait-il une formule que je pourrais intégrer dans ma formule SI afin que ce soit les données verticales du feuillet 1 qui se reportent de manière horizontale sur mon feuillet 2 ?

Merci beaucoup !!

Afficher la suite 

5 réponses

Répondre au sujet
Frenchie83 1711 Messages postés lundi 6 mai 2013Date d'inscription 11 décembre 2017 Dernière intervention - 11 oct. 2017 à 12:05
0
Utile
Bonjour,
En A1
=SI(INDIRECT("'Feuillet1'!B" & COLONNE())<0;INDIRECT("'Feuillet1'!B" & COLONNE());0)
à tirer sur la droite
Cdlt
Commenter la réponse de Frenchie83
Vaucluse 20835 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 10 décembre 2017 Dernière intervention - 11 oct. 2017 à 14:15
0
Utile
2
Bonjour
juste pour raccourcir un peu:

=MAX(0;INDIRECT("'feuillet1'!B"&COLONNE()))

ne fonctionne pour ressortir la ligne 1 que sur la colonne A
si la formule ne se trouve pas dans la 1° colonne pour ressortir la 1° ligne, écrire:

=MAX(0;INDIRECT("'feuillet1'!B"&COLONNE(A$1)))

qui renverra la ligne 1 de feuillet1 quelque soit sa position dans la page, en incrémentant la ligne vers la droite



crdlmnt


Frenchie83 1711 Messages postés lundi 6 mai 2013Date d'inscription 11 décembre 2017 Dernière intervention - 11 oct. 2017 à 14:32
Bonjour Vaucluse
Evidemment, c'est plus chic.
Juste une petite remarque par rapport à la question posée, "MIN" ne semble-t-il pas plus approprié que "MAX", vu que l'on cherche les valeurs négatives?
Cdlt
Vaucluse 20835 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 10 décembre 2017 Dernière intervention - 11 oct. 2017 à 14:48
Exact, tout à fait Frenchie,
Ce ne sera peut être pas plus chic, mais ce sera plus juste!!!
quant à dire plus chic, non, c'est simplement pour éviter de doubler les codes INDIRECT que j'ai fait cette proposition en surenchère sur la tienne qui était tout à fait correcte
Bien cordialement
Commenter la réponse de Vaucluse
0
Utile
Merci beaucoup pour vos réponses et votre aide !
Commenter la réponse de Silana