Signaler

Svchost.exe processeur 100% LA SOLUTION [Résolu/Fermé]

Posez votre question La loupiote 2549Messages postés dimanche 13 novembre 2005Date d'inscription 22 novembre 2014 Dernière intervention - Dernière réponse le 2 sept. 2017 à 18:47 par Nordine
J'ai trouver cette solution après bien des heures a chercher le pourquoi du comment.
En fait il s'agit d'un bug de Windows qui apparait généralement après une mise à jour d'un produit "Office".
Et qui provoque une corruption du dossier "softwaredistribution"


Voila une solution testée plusieurs fois et fonctionnelle

Dans un premier temps vous devez aller dans le panneau de configuration et désactiver le service de mise à jour automatique.
Ok, maintenant vous êtes tranquille , car le processus "svchost.exe" qui vous faisait ramer le processeur doit s'arrêter, ou se calmer.
(A noter que ce processus system peu être arrêter dans le gestionnaire de tâche.Mais il réapparait si vous ne désactivez pas le service de mise a jour automatique).



1. Cliquez sur "démarrer" puis "exécuter"
2. Tapez "REGSVR32 WUAPI.DLL" (sans les guillemets) et presser OK
3. Quand on reçois le message "DllRegisterServer in WUAPI.DLL succeeded" message, click OK.
4. En suite exécuter les commandes suivantes dans "exécuter":

REGSVR32 WUAUENG.DLL
REGSVR32 WUAUENG1.DLL
REGSVR32 ATL.DLL
REGSVR32 WUCLTUI.DLL
REGSVR32 WUPS.DLL
REGSVR32 WUPS2.DLL
REGSVR32 WUWEB.DLL



1. Cliquez sur "démarrer" puis "exécuter" et tappez " cmd "

Dans la fenêtre d'invite de commande qui s'ouvre tappez:

net stop WuAuServ



2. Cliquez sur "démarrer" puis "exécuter" et tapez " %windir% " cela ouvre le dossier system32

3. Recherchez le dossier "SoftwareDistribution" faire un clique droit dessus et renommez le en " SDold ".

4.Cliquez sur "démarrer" puis "exécuter" et tapez " cmd "

Dans la fenêtre d'invite de commande qui s'ouvre tapez:

net start WuAuServ


Et voila le problème est résolu, finis les formattage et réinstallations de XP.

P.S. Pour vos commentaires vous pouvez m'écrire à (supprimé par la modération)

Utile
+855
plus moins
Après avoir désactiver le service de mise à jour automatique, est ce qu'il est donc nécessaire de poursuivre à ces 4 étapes
, car le processus "svchost.exe" qui faisait ramer le processeur est déjà arrêter, et à quoi ça sert ces étapes

1. Cliquez sur "démarrer" puis "exécuter"
2. Tapez "REGSVR32 WUAPI.DLL" (sans les guillemets) et presser OK
3. Quand on reçois le message "DllRegisterServer in WUAPI.DLL succeeded" message, click OK.
4. En suite exécuter les commandes suivantes dans "exécuter": et ainsi de suite....
Cette réponse vous a-t-elle aidé ?  
Atome74 metronic - 25 juin 2016 à 22:09
il faut démarrer l'invitée de commandes en mode admin (clic droit), puis "net stop wuauserv" (avec ou sans majuscules, c'est pareil)
Lapache- 11 sept. 2016 à 00:14
Enfin... ca résolu ptete pas le problème définitivement mais ca stop tout de suite le proc..
Merci
Ytmag 130Messages postés lundi 1 juillet 2013Date d'inscription 14 août 2016 Dernière intervention - 15 août 2015 à 20:34
exécuter le cmd en administrateur c'est pour sa !
Jay- 29 août 2015 à 01:44
Bonjour à tous, voilà un correctif qui devrait résoudre votre problème de surconsommation de ram avec le processus svchost:

https://support.microsoft.com/fr-fr/kb/3065987
Nordine- 2 sept. 2017 à 18:47
C"est extra votre solution. J’espère qu'elle me facilitera après les redémarrages.
Merciiiiiiiiiiiiiiiii
Répondre
Utile
+39
plus moins
salut

alors il te faut faire toute la procédure (je sais c'est long )
mais au moins après tu sera tranquille

Car le but de cette opération consiste a rattraper un bug de windowsupdate


Haideur- 15 août 2014 à 23:35
Salut, puisque c'est un fichier dll tu peux le télécharger sur internet ! derien
salome17- 10 mai 2015 à 22:12
Je ne parviens pas à trouver comment charger cette dll
help
laucy79 9Messages postés samedi 31 janvier 2015Date d'inscription 2 février 2016 Dernière intervention - 2 févr. 2016 à 18:54
Bonsoir,

Je suis bloqué comme Piersees à l'étape 4. Pouvez vous m’aider s'il vous plait à trouver les Dll manquant
Par avance merci de votre aide,
JPC45200 113Messages postés dimanche 9 décembre 2007Date d'inscription 4 juin 2016 Dernière intervention - 6 mars 2016 à 16:00
Bonjour,

Je viens de télécharger trois DLL sur ce site :

http://www.telecharger-dll.fr/

J'espère que cela pourra vous aider à moins que cela ne soit déjà fait vu l'ancienneté du message.

Bonne journée

JPC45200
juliadt 1Messages postés mercredi 1 juin 2016Date d'inscription 1 juin 2016 Dernière intervention - 1 juin 2016 à 18:11
Bonjour à tous et merci la Loupiote.
Je suis sous Windows 10 et j'ai aussi différents problèmes à l'étape 4.
J'ai téléchargé les dll manquants sur le site indiqué http://www.telecharger-dll.fr/dll-wuweb.dll.html etc. et je les ai copiés dans System32.
(il y a juste un souci avec WUAUENG.DLL parce que quand je le copie dans System32 j'ai "Vous devez disposer d'une autorisation pour exécuter cette action" et échec... Mais il il y a déjà un fichier avec ce nom dans mon dossier System32, qui date peut-être d'une tentative précédente.)

1) Déjà, sous windows 10 on ne peut pas désactiver les màj automatiques mais seulement cocher "M'informer de planifier un redémarrage". J'ai fait ça.
2) Les problèmes dans "exécuter", dans l'ordre:
- WUAPI: ok.
- WUAUENG (j'ai dû le télécharger): Le module "WUAUENG.DLL" a été chargé, mais le point d'entrée DllRegisterServer est introuvable. Vérifiez que "WUAUENG.DLL" est un fichier DLL ou OCX valide."
- WUAUENG1 (j'ai dû le télécharger): "Le module "WUAUENG1.DLL" peut ne pas être compatible avec la version de Windows que vous utilisez. Vérifiez que le module est compatible avec une version x86 (32bits) ou x64 (64bits) de regsvr32.exe."
- ATL: ok.
- WUCLTUI (j'ai dû le télécharger) : "Le module "WUCLTUI.DLL" peut ne pas être compatible avec la version de Windows que vous utilisez. Vérifiez que le module est compatible avec une version x86 (32bits) ou x64 (64bits) de regsvr32.exe."
- WUPS: "WUPS a été chargé, mais l'appel à DllRegisterServer a échoué avec le code d'erreur 0x800x70005. Pour plus d'informations sur ce problème, effectuez une recherche en ligne en utilisant le code d'erreur comme terme à rechercher."
- WUPS2: "WUPS a été chargé, mais l'appel à DllRegisterServer a échoué avec le code d'erreur 0x800x70005. Pour plus d'informations sur ce problème, effectuez une recherche en ligne en utilisant le code d'erreur comme terme à rechercher."
- WUWEB (j'ai dû le télécharger) : "Le module "WUAUENG1.DLL" peut ne pas être compatible avec la version de Windows que vous utilisez. Vérifiez que le module est compatible avec une version x86 (32bits) ou x64 (64bits) de regsvr32.exe."

Il y a donc 3 types de pb (1) point d'entrée DllRegisterServer est introuvable/fichier DLL/OCX pas valide? - 2) module "peut-être pas compatible" avec ma version de Windows: comment on vérifie??? - 3) "l'appel à DllRegisterServer a échoué avec le code d'erreur 0x800x70005").

Pouvez-vous m'aider??
Je crois que c'est vraiment le bon diagnostic (bugs après une màj Office).

Pour info j'ai déjà eu ce genre de pb il y a un an, et c'est parti tout seul au bout d'un mois.
Et il y a 3 mois aussi, où j'ai trouvé ce topic et échoué, et essayé différents trucs... Ça a été un peu mieux depuis et puis ça a recommencé, et là mon ordi est quasi inutilisable.
HELP!!
Utile
+18
plus moins
salut a tous

je vien de faire la manip avec le panneau de configuration alor pour le CPU c'est ok

mais j'ai un autre probleme maintenant: comment se fait il que j'ai 7 processus svchost.exe? dont: 4 lancés par SYSTEM 2 par SERVICE RESEAU et 1 par SERVICE LOCAL ?

mais le probleme est aillieur: il est la ^^ comment se fait il que 6 de ces 7 processus utilisent moins de 8 000 ko de RAM et moins de 5 000 de memoire virtuelle; alors que le 7° utilise a lui tout seul 80 000 ko de RAM ainsi que 120 000 ko de memoire virtuelle?
FonWasH- 16 févr. 2012 à 15:37
parce que t'es un noobi, svchost regroupe plusieurs .dll.
En gros et en très simplifier svchost est un executable qui permet de lancer les .dll, chaque svchost regroupe plusieurs .dll d'une catégorie, donc il est tout à fait normale que tu es plusieurs svchost de différents services, avec des consommations différentes.
Utile
+14
plus moins
bonjour a tous j'ai trouvé la solution
en fait quand " la loupiote " dit dans sont tout premier message de marquer " %windir% " dans executer sa ouvre pas le dossier system32 mais windows donc il faut ensuite allé dans le dossier systeme 32 qui est parmis les nombreux dossier.
parce qu'il existe aussi un dossier " SoftwareDistribution " dans le dossier windows.
voila jespere vous apporter de l'aide
Nagushi- 18 avril 2011 à 11:11
exact !
Utile
+12
plus moins
Salut, moi je sais pas si c'est un problème mais bon je m'explique: lorsque je fais ctrl+alt+suppr, dans "processus" je compte 7 fois "svchost.exe"!! Est-ce normal?
=> The frustrated Guy <=- 29 juil. 2011 à 15:00
Pareil --'
louisccm 23Messages postés jeudi 12 février 2009Date d'inscription 8 septembre 2017 Dernière intervention - 15 sept. 2013 à 06:22
oui c'est normal
Pour savoir ce que contient SVCHOST il existe "Process explorer"
Utile
+10
plus moins
Merci beaucoup ! J'ai fait la manip hier et aujourd'hui l'UC tourne à 14% au lieu de 100%.
ccmpali 32Messages postés jeudi 24 mars 2016Date d'inscription 20 juillet 2016 Dernière intervention - 1 avril 2016 à 22:58
bjr laury9 quell manip parceque il ya 2 ou 3 dans ce discussion ??
Utile
+8
plus moins
Le processus svchost.exe (svchost signifiant Service Host Process) est un processus générique de Windows 2000/XP servant d'hôtes pour les autres processus dont le fonctionnement repose sur des librairies dynamiques (DLLs). Il existe ainsi autant d'entrées svchost qu'il y a de processus qui l'utilisent.

L'utilitaire tlist.exe fourni sur le CD-ROM de Windows 2000/XP permet de lister les applications utilisant ce service grâce à la commande suivante :

tlist -s

Le service svchost original possède une faille de sécurité qu'il est impératif de corriger en mettant à jour le système avec le service WindowsUpdate.

Il ne s'agit en aucun cas d'un Virus résident, d'un ver, d'un cheval de Troie, d'un spyware, ni d'un AdWare

De plus, il ne faut en aucun cas tout les supprimer pour la plupart il sont BON pour votre ordinateur !!
Utile
+8
plus moins
J'ai trouvé une solution assez simple à ce problème (qui semble être du à une anomalie dans IE8) :
- désactiver les mises à jour automatiques de XP
- télécharger les trois mises à jour d'IE8 : KB2879017 KB2888505 et KB2898785
- appliquer ces trois mises à jour (dans l'ordre)
et tout est rentré dans l'ordre sur les deux machines que j'ai intallées aujourd'hui.
Alain- 15 déc. 2013 à 22:58
Merci c'est votre solution qui a marché chez moi
phpccm 1Messages postés samedi 11 janvier 2014Date d'inscription 11 janvier 2014 Dernière intervention - 11 janv. 2014 à 20:26
grand merci ! les 2 premiers KB avaient déjà été installés sur mon pc (historique),
et il a suffi de télécharger/exécuter KB2898785 du centre de téléchargement de MS
pour que tout rentre dans l'ordre après re-validation des MAJ automatiques !
solution la plus courte, la moins risquée ! un sincère merci, jpciut !
Utile
+7
plus moins
Bonjour, désolé pour le harcèlement...j'ai toujours le même problème, pouvez-vous m'aider SVP ? Merci bien...
Utile
+5
plus moins
Bonjour,
alors voila j'ai fait toute la petite manip car a chaque fois que j'allumais mon PC, il se mettait a ramer a mort au bout de 5 min et quand je regardai l'UC utilisée j'avais 100%^^' donc maintenant je vien de le faire a l'instant (je sais donc pas encore si sa marche) mais j'ai toujours le tas de svchost.exe dans processus , c'est normal ?
Utile
+4
plus moins
j'ai fais tout ce que tu as décris et ca ne marche toujours pas. pourquoi?
Utile
+4
plus moins
salut borisnight, pour te repondre moi j'ai 8 fois "svchost. exe"!! je te pose aussi la question est-ce normal? lol
Utile
+4
plus moins
oui c'est normal ca correspond à en gros si je ne me trompe pas, a ce qui sert a lancer d'autre logiciel ou un truc ds le genre. te fais pas de souci c'est tout a fait normal
Utile
+4
plus moins
Bonjour,

Après recherche assidue sur le net, mon problème svchost 100% sous XP, ne trouvait pas réponse efficace,
mais à force de patience et de fouille dans les processus qui tournaient sur le PC en question,j'ai fini par trouver une solution suprenante: c'était Zonealarme qui me générais ce problème, après désinstallation au travers de ccleaner, tout est rentré dans l'ordre. J'en reste assez stupéfait, j'utilise zonelabs depuis très longtemps et avec une grande satisfaction, alors peut être une install qui s'est mal passée, toujours est il que j'ai trop cherché pour ne pas être satisfait de voir enfin mon problème résolu, alors je partage si cela peut aider.
Utile
+4
plus moins
Je viens de lire que : Le processus Svchost.exe fait parti du update de windows et s'ouvre à chaque logiciel nécessitant ou cherchant une mise à jour donc il est à priori normal d'avoir pas mal de svchost ouverts.
Je cherche le moyen de supprimer ce p***** de prog qui fait ramer mon pc :o)
Utile
+3
plus moins
moi j'ai autant de svchost.exe mais ils ne tournent pa. en fait moi j'ai le processus du nom de l'image "system" qui tourne a 99 ce qui fé ke j'ai l'UC a 100%. j'ai essayé tro plein de truc pour m'en débarasser mais ca n'a rien donné. ce kil y a c ke personne n'a apparement jamais vu le probleme ke j'ai.
Utile
+3
plus moins
essayer simplement de supprimer les fichiers qui sont dans C:/user/appdata/temp car moi il s'agissait d'une application malveillante qui à causé cela je tourne maintenant à 10 20 %
Utile
+2
plus moins
Désolé, c'est encore moi, j'ai toujours les mêmes problèmes avec en plus le processus msiexec.exe qui tourne à 100% l'UC, ce processus s'active quand j'ouvre Microsoft Picture IT ??
Ceci est-il du au bug de la mise à jour Office ?? Pourtant j'ai suivi ta manip la loupiote et pour l'instant svchost est calme...merci beaucoup pour votre aide...
Utile
+2
plus moins
Salut,
Pas mal !!
mAis j'ai toujours 7 application svchost.. C'est normal ?
Jean rené.- 2 juil. 2011 à 11:22
Oui!
Petoche- 23 oct. 2013 à 20:41
Merci beaucoup!
Siberial- 1 nov. 2013 à 17:11
méthode appliquée, problème résolu. merci, laloupiotte. :)
Utile
+2
plus moins
Si je pose la question c'est que j'en sais rien! lol. Non sérieu j'aimerai bien avoir une éponse car ça me bouffe pas mal de ressource quand même!

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !