Signaler

Vba excel afficher les jours du mois [Résolu]

Posez votre question ciocciu 42Messages postés jeudi 2 novembre 2006Date d'inscription 2 janvier 2009 Dernière intervention - Dernière réponse le 28 déc. 2008 à 13:35
Bonjour,
dans une macro je récupère une date (format dd/mm/yyyy) mise dans une cellule et je souhaiterais faire afficher sur les 29 ou 30 cellules du dessous les jours suivants du mois
j'arrive bien à un truc en enregistrant une macro (un truc du style
selection.AutoFill Destination:=Range("X134:X164"), Type:=xlFillDefaul)
mais idéalement si ma macro pouvait connaitre le nombre de jours de chaque mois (31 pour décembre , 30 pour janvier...) ce serait idéal
l'idée est de fournir une date et de me retrouver avec une colonne contenant les 30 ou 31 jours du mois
merci par avance
cordialement
Afficher la suite 
Utile
+1
moins plus
Voilà un petit bout de code pour te montrer l'idée, j'ai fait une forme avec une textbox (la date) et un bouton
je range de A1 à la fin du mois (en plus on peut commencer n'importe quel jour, magique !)

[code]
Private Sub CommandButton1_Click()
Dim jour, jfinmois As Date
jour = TextBox1.Text
jfmois = DateAdd("m", 1, jour) - Day(jour)
For j = 0 To DateDiff("d", jour, jfmois)
Sheets("Feuil1").Range("A1").Offset(j, 0).Value = DateAdd("d", j, jour)
Next j
End Sub
[\code]

A plus
Ajouter un commentaire
Utile
+0
moins plus
Il y a plusieurs soluces mais sans coder tu peux mettre une formule sur tes cellules du dessous
Tu mets ta colonne au format date et dans les cellules sous ta date du met un, truc du style
[code]
=SI(D2<>"";SI(MOIS(D2+1)=MOIS(D2);D2+1;"");"")
[\code]

Sinon tu code en vb, à toi de voir
Salut
Ajouter un commentaire
Utile
+0
moins plus
merci mike mais j'aimerais générer automatiquement ma colonne de dates donc vraisemblablement plus en vba
j'ai déjà une fonction qui me donne le nombre de jour du mois concerné disons n
maintenant j'ai plus qu'à faire afficher dans chaque cellule le jour d'après et cela n fois
j'y travaille ...mais je pensais que ça existait déjà peut être plus simple....( je suis un newbee du vba..lol)
Ajouter un commentaire
Utile
+0
moins plus
ok merci bcp
Ajouter un commentaire

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !