Excel : Si inférieur et supérieur ou egal [Résolu/Fermé]

Messages postés
99
Date d'inscription
vendredi 16 novembre 2007
Statut
Membre
Dernière intervention
6 mars 2008
-
Bonjour,

j'ai un petit souci sur une fonction:

j'ai SI(A11=1;2;SI(B11=12;5))

seulement je voudrais que 12<B11<=14 et je n'y arrive pas

Si quelqu'un peut m'aider
merci
Afficher la suite 

9 réponses

Meilleure réponse
approuvée par Jean-François Pillou le 28 mars 2017
Messages postés
7236
Date d'inscription
dimanche 8 avril 2007
Statut
Modérateur
Dernière intervention
9 juillet 2019
983
47
Merci
Bonsoir,
Voilà une formule qui pourrait t'aider, elle écrit 5 si 12<B11<=14 sinon elle écrit 0, à adapter en fonction de ce qu'elle doit faire si condition fausse :
=SI(ET(B11<=14;B11>12);5;0)

Bonne soirée

Dire « Merci » 47

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 58968 internautes nous ont dit merci ce mois-ci

lagodille
Messages postés
99
Date d'inscription
vendredi 16 novembre 2007
Statut
Membre
Dernière intervention
6 mars 2008
3 -
C'est bien ce que je pensais . j'avais pensé à cette fonction mais ca ne marchait pas Alors je pense que dans ma formule complète j'utilise 8 formules et que le fait de rajouter un ET me fait passer à 9 conditions et je me retrouve coincé.

y aurait il une parade pour 9 à 10 conditions
voilà se qu'il me faudrait :
dans la cellule B11
=SI(A1=0;0;SI(A1=1;0,25;SI(A1=2;0,5;SI(A1=3;0,75;SI(A1=9;1;SI(A1=10;1;SI(A1=11;1;SI(ET(A1<=14;A1>11);5;"NUL"))))))

merci aquarelle
gildautal
Messages postés
16
Date d'inscription
samedi 8 décembre 2007
Statut
Membre
Dernière intervention
9 janvier 2008
3 -
A première vue, ca fonctionne et ca me convient parfaitement j'essayerai de comprendre plus tard

encore merci Aquarelle pour ton aide precieuse

bonne soirée
25
Merci
Bonsoir,

=SI(A11=1;2;SI(ET(B11>12;B11<=14);5))


ça donne si A11=1 ---> en A1: 2

si A11 different de 1 et B11= 13 ---> en A1:5
Messages postés
7236
Date d'inscription
dimanche 8 avril 2007
Statut
Modérateur
Dernière intervention
9 juillet 2019
983
8
Merci
Essaie en l'écrivant de cette façon :
=SI(ET(A1<=14;A1>11);5;SI(A1=0;0;SI(A1=1;0,25;SI(A1=2;0,5;SI(A1=3;0,75;SI(A1=9;1;SI(A1=10;1;SI(A1=11;1;"NUL"))))))))

Cette formule dit qu'il sera écrit NUL dans la cellule B11, si aucune des conditions données n'est valable.
Est-ce que tu voulais ?
A+
lagodille
Messages postés
99
Date d'inscription
vendredi 16 novembre 2007
Statut
Membre
Dernière intervention
6 mars 2008
3 -
merci aquarelle pour ta réponse rapide et perspicace , toujours la quand il faut .........
cordialement

merci
aquarelle
Messages postés
7236
Date d'inscription
dimanche 8 avril 2007
Statut
Modérateur
Dernière intervention
9 juillet 2019
983 > lagodille
Messages postés
99
Date d'inscription
vendredi 16 novembre 2007
Statut
Membre
Dernière intervention
6 mars 2008
-
De rien et toujours ravie de pouvoir aider si je le peux.
Bonne nuit
-
bjrpouvez vous ai der voila jai fait une demande de mpdh et ce marquer mon taux et inferieur a80 veut dire ce bon ou pas pour avoir merci
Messages postés
607
Date d'inscription
mardi 25 septembre 2007
Statut
Membre
Dernière intervention
31 janvier 2008
173
3
Merci
IIF(Condition; TRUE statement; FALSE statement)

et que est-ce que veux avoir car ça veut rien dire "12<B11<=14 ", juste que b11 doit etre entre 12 et 14. mais pas que b11 doit prendre une valeur particulière

bref ça n'a rien à voir ? SI(A11=1;2;SI(B11=12;5))
car ça veut dire que si a11 = 1 alors résultat est 2, sinon si b11 égale à 12 alors résultat égal à 5 sinon pas de résultat
Messages postés
99
Date d'inscription
vendredi 16 novembre 2007
Statut
Membre
Dernière intervention
6 mars 2008
3
3
Merci
je reformule ma question j'ai une cellule A1 dans laquelle je mets =SI(A11=1;2;SI(B11=12;5))

ca veut dire que si j'ai A11=1 alors j'aurais 2 en A1
si j'ai B11 = 12 alors j'aurais 5 en A1


mais cela ne me convient pas car je voudrais qu'a a place de B11=12;5

J'ai si B11 est compris entre 12 et 14 alors A1 prend la valeur 5

ce n'ai pas du tout la meme chose mais c'est ce que je voudrais avoir

merci
Messages postés
7236
Date d'inscription
dimanche 8 avril 2007
Statut
Modérateur
Dernière intervention
9 juillet 2019
983
0
Merci
'lu,
De rien et bonne fin de soirée.
Messages postés
99
Date d'inscription
vendredi 16 novembre 2007
Statut
Membre
Dernière intervention
6 mars 2008
3
0
Merci
merci à toutes et à tous et à bientot
Messages postés
99
Date d'inscription
vendredi 16 novembre 2007
Statut
Membre
Dernière intervention
6 mars 2008
3
0
Merci
merci
0
Merci
Bonjour,

La même question qu'au début, mais en langage VBA, ex :
Prenons 4 possibiltés :
A1=100
A2=100
A3=100
A4=100

B1=0
B2=50
B3=100
B4=100

Z4="x"

La formule de la colonne C :
C1 = A1-B1 = 100
L2=50
L3=0
L4=0 (plus la croix de z)


-------
Je voudrais que :
- si C est égal à 0 et que Z est coché, alors cellule en blanc ;
- si C est égal (juste) à 0, alors en vert ;
- si C est inférieur à A, alors en orange ; et
- si C égal A, alors en rouge.

Donc :
-> C1 = rouge
-> C2 = orange
-> C3 = vert
-> C4 = blanc

------
Quelqu'un aurait il la gentillesse de répondre à cela ?? Sait il comment résoudre ce casse tête ??? :) s'il vous plaît