Formule excel condition si + soustraction

Signaler
-
Raymond PENTIER
Messages postés
50528
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
12 décembre 2019
-
Bonjour,

Je souhaiterai créer une formule excel avec une condition si.
Sur mon image je souhaiterai qu'en cellule BB5 il y ait ces 2 formules :
si les cellules de B5 à BA5 sont vides alors ne rien inscrire sinon inscrire le total de l'opération 30-somme(B5:BA5)

Pourriez-vous m'aider s'il vous plait.

Merci d'avance.

[url=https://www.noelshack.com/2019-48-1-1574692764-formule-excel-condition-si.jpg][img]https://image.noelshack.com/minis/2019/48/1/1574692764-formule-excel-condition-si.png[/img][/url]
Messages postés
160
Date d'inscription
jeudi 23 août 2012
Statut
Membre
Dernière intervention
9 décembre 2019
2
Bonjour,

L'image est illisible....

Question : Faut t'il que toutes les cellules ne soient pas vides pour effectuer la soustraction ?

Cordialement
PYGOS69
Messages postés
160
Date d'inscription
jeudi 23 août 2012
Statut
Membre
Dernière intervention
9 décembre 2019
2
=si(B5:BA5="";"";30 -somme(B5:BA5)) à valider avec Ctrl+ Shift+ Enter
PYGOS69
Messages postés
160
Date d'inscription
jeudi 23 août 2012
Statut
Membre
Dernière intervention
9 décembre 2019
2
Ce qui donne, une fois validée

{si(B5:BA5="";"";30 -somme(B5:BA5))}
Messages postés
50528
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
12 décembre 2019
11431
Bonjour.

Autres formules possibles en BB5 :
=SI(NBVAL(B5:BA5)=0;"";30-SOMME(B5:BA5))
ou encore :
=(NBVAL(B5:BA5)>0)*(30-SOMME(B5:BA5))
michel_m
Messages postés
16011
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
12 décembre 2019
2838
Bonjour

=(NBVAL(B5:BA5)>0)*(30-SOMME(B5:BA5))

si B5:BA5 est vide la formule renvoie 0 (ou faux) et non "" ....
Raymond PENTIER
Messages postés
50528
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
12 décembre 2019
11431
Tout-à-fait juste !
J'ai eu le tort de ne pas effectuer un dernier test ...
Je m'excuse auprès de Melo et des autres lecteurs.

Merci à Michel de sa vigilance et de son intervention.