Formule de calcul avec remise si client privilégié

Messages postés
10
Date d'inscription
jeudi 17 octobre 2019
Statut
Membre
Dernière intervention
29 octobre 2019
- - Dernière réponse : Raymond PENTIER
Messages postés
50337
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
15 novembre 2019
- 30 oct. 2019 à 01:13
Bonsoir à tous,
Je bloque sur une formule dans un tableau Excel. Pourriez-vous m'aider svp ?
Dans une cellule I13, j'ai un montant HT de 440 euros. Dans une autre cellule I16, j'ai un autre montant HT de 124 euros.
En dessous, j'ai une cellule I20 "remise de 5 % si client privilège" (à savoir que la distinction "client privilège" est indiquée dans la cellule G5 par O ou N selon le client que je choisis pour établir la facture).
J'ai réussi à trouver la formule de calcul pour I20. C'est =SI(G5="O";I22*0,05;0).
En-dessous je dois remplir la case I21qui est le total HT de I13 + I16 - la remise de 5 % selon si le client est privilège ou pas. Quelle formule dois-je insérer ? Merci de vos retour.
Afficher la suite 

2 réponses

Messages postés
24669
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
15 novembre 2019
4886
0
Merci
Bonjour
=(I13+I16)*SI(G5="O";0,95;1)
crdlmnt
Commenter la réponse de Vaucluse
Messages postés
10
Date d'inscription
jeudi 17 octobre 2019
Statut
Membre
Dernière intervention
29 octobre 2019
0
Merci
Bonsoir,
Merci beaucoup pour la formule que j'ai de suite insérée dans mon tableau et qui me fait apparaître le bon résultat ! Bravo !
Mais, de ce fait, ma ligne I20 dont la formule est =SI(G5="O";I22*0,05;0) s'est modifiée automatiquement et a affiché 27,66 euros au lieu de 29,12 euros. Je ne comprends pas pourquoi ?
Petite rectification : la valeur de I16 est de 142,40 euros.
Merci pour vos explications
Cdlt
Vaucluse
Messages postés
24669
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
15 novembre 2019
4886 -
n on car vous recalculez la remise surI22 qui est déjà le montant réduit!
si vous voulez le montant de la remise en I20:
soit
=(I13+I16)*SI(G5="O";0,05;0)
soit:
=I13+I16-I22
crdlmnt
NOCHE_1983
Messages postés
10
Date d'inscription
jeudi 17 octobre 2019
Statut
Membre
Dernière intervention
29 octobre 2019
-
Merciiiii infiniment c'est un peu plus clair….
Puis-je encore vous poser une question ? J'ai un "Montant dû" de 663,94 euros en I26.
En I28 j'ai "Caution versée" dont j'ai trouvé la formule =RECHERCHEV(C9;VEHICULES;6;0)
En I30 j'ai "Net à payer" et en I32 j'ai "A rembourser".
La consigne est : Lorsque le montant dû est supérieur à la caution versée alors il y a un net à payer. Dans le cas contraire, il faut rembourser le client.
Que dois-je mettre dans I30 et I32 ?
Raymond PENTIER
Messages postés
50337
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
15 novembre 2019
11183 -
En I30 : =SI(I26>I28;I26-I28;0)
En I32 : =SI(I26>I28;0;I28-I26)
NOCHE_1983
Messages postés
10
Date d'inscription
jeudi 17 octobre 2019
Statut
Membre
Dernière intervention
29 octobre 2019
-
Bonsoir et merci pour vos explications.
Je rencontre un problème que je me permets de vous exposer .
Dans une feuille "facture" je dois rentrer l'adresse des clients qui se trouve sur feuille "clients" et faire apparaître une formule au moyen de laquelle je dois juste rentrer le code postal et grâce à la feuille "Code_postaux", la cellule ville est remplie.
Quand je rentre :
=SI(D2<>"";RECHERCHEV(D2;Code_postaux!$A$2:$B$48;2FAUX);"")
ça affiche #NOM? dans la colonne E2 de la feuille "clients"
Je ne comprends plus...
Raymond PENTIER
Messages postés
50337
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
15 novembre 2019
11183 -
Si tu as oublié le
;
entre
2
et
FAUX
, c'est normal !
Commenter la réponse de NOCHE_1983