Formule de calcul de répétition d'une variable [Résolu]

Messages postés
582
Date d'inscription
lundi 29 décembre 2014
Statut
Membre
Dernière intervention
19 septembre 2019
-
Bonjour mes amis,

je demande votre aide pour savoir une formule de calcul:

exemple: j'ai une variable dans cellule A1="Paris"
et dans la plage de la feuille il se repete ce nom plusieurs fois.
exemple : Dans E15 et F15 = "Paris" et "oui"
Dans C10 et D10 = "Paris" et "oui"


la question est : si je cherche "Paris" combien le mot "oui" se repete???

Merci infiniment



Configuration: Windows / Firefox 52.0
Afficher la suite 

7 réponses

Meilleure réponse
Messages postés
11134
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
22 septembre 2019
1433
1
Merci
Bonjour

Pas très clair
Apparemment Paris peut se trouver dans diverses colonnes ?

Fournis ton fichier en le postant sur mon partage.fr, fais créer un lien que tu copies et reviens coller ici

Cdlmnt
Via

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 59712 internautes nous ont dit merci ce mois-ci

nonossov
Messages postés
582
Date d'inscription
lundi 29 décembre 2014
Statut
Membre
Dernière intervention
19 septembre 2019
-
Voila le fichier explicatif : https://www.cjoint.com/c/IGsoWcyCaHK

Merci infiniment
Commenter la réponse de via55
Messages postés
11134
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
22 septembre 2019
1433
1
Merci
Ok c'est succint comme tableau

Ici les Paris sont dispatchés sur 3 colonnes
Est ce toujours le cas où peut il y en avoir plus ou moins ?

Par formule simple ce ne sera peut être pas évident il faudra passer alors par une fonction personnalisée en VBA
J'attends ta réponse pour déterminer la marche à suivre

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 59712 internautes nous ont dit merci ce mois-ci

nonossov
Messages postés
582
Date d'inscription
lundi 29 décembre 2014
Statut
Membre
Dernière intervention
19 septembre 2019
-
c'est mieux une formule simple, est ce qu'il est possible de faire une recherche sur toute la plage de la feuil?? Merci
Commenter la réponse de via55
Messages postés
11134
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
22 septembre 2019
1433
1
Merci
Tu ne réponds pas à ma question
Combien de colonnes ??
Et se suivent elles ?
Fournis un tableau plus complet et proche du réeel si tu veux une réponse éfficace

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 59712 internautes nous ont dit merci ce mois-ci

nonossov
Messages postés
582
Date d'inscription
lundi 29 décembre 2014
Statut
Membre
Dernière intervention
19 septembre 2019
-
Les colonnes de A à H, et dzl pour le tableau je ne l'ai pas mtn merci
Commenter la réponse de via55
Messages postés
11134
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
22 septembre 2019
1433
1
Merci
en 1ere ligne au dessus du tableau de chaque colonne où il y a des Paris tu mets une formule de ce type :
=NB.SI.ENS(C4:C20;"paris";D4:D20;"oui") à adapter
ici on a des Paris en colonne C depuis la ligne 4 à la ligne 20 et donc des oui en D4:D20

Ensuite il ne reste que dans la cellule où tu veux le résultat de faire la somme des nombres en ligne 1

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 59712 internautes nous ont dit merci ce mois-ci

nonossov
Messages postés
582
Date d'inscription
lundi 29 décembre 2014
Statut
Membre
Dernière intervention
19 septembre 2019
-
je pense que la formule ne marche pas en excel 2003? je recois #NOM?
Commenter la réponse de via55
Messages postés
11134
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
22 septembre 2019
1433
1
Merci
Il y a des chances, alors emplace là apr celle-ci :
=SOMMEPROD((C4:C19="paris")*(D4:D19="oui"))

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 59712 internautes nous ont dit merci ce mois-ci

nonossov
Messages postés
582
Date d'inscription
lundi 29 décembre 2014
Statut
Membre
Dernière intervention
19 septembre 2019
-
comment puis je chercher sur colonne C : D et F : G au meme temps??
nonossov
Messages postés
582
Date d'inscription
lundi 29 décembre 2014
Statut
Membre
Dernière intervention
19 septembre 2019
-
cette fonction ne marche pas??

=SOMMEPROD((C4:C19=A1)*(D4:D19="oui")*OU(((F4:F19=A1)*(G4:G19="oui"))))
Commenter la réponse de via55
Messages postés
11134
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
22 septembre 2019
1433
1
Merci
Non

=SOMMEPROD((C4:C19=A1)*(D4:D19="oui") + SOMMEPROD((F4:F19=A1)*(G4:G19="oui")

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 59712 internautes nous ont dit merci ce mois-ci

nonossov
Messages postés
582
Date d'inscription
lundi 29 décembre 2014
Statut
Membre
Dernière intervention
19 septembre 2019
-
non celui la:
=SOMMEPROD((C4:C19=A1)*(D4:D19="oui")+((F4:F19=A1)*(G4:G19="oui")))

Merci infiniment
nonossov
Messages postés
582
Date d'inscription
lundi 29 décembre 2014
Statut
Membre
Dernière intervention
19 septembre 2019
-
Merci bouceaup a votre aide
Commenter la réponse de via55
Messages postés
11134
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
22 septembre 2019
1433
1
Merci
De rien
Passe en résolu (le triangle avec ! tout en haut à droite
Bonne suite

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 59712 internautes nous ont dit merci ce mois-ci

Commenter la réponse de via55