Menu

Si NBVAL Supérieur à 0 Alors 1 [Résolu]

Messages postés
584
Date d'inscription
vendredi 29 avril 2005
Statut
Membre
Dernière intervention
12 avril 2019
-
Bonjour la communauté !
Je tente, en vain, d'écrire une formule me permettant de :
Si le nombre de valeurs (texte) d'une plage est supérieure à 0, alors afficher 1, sinon, 0.
Pour plusieurs plages.
J'ai 4 plages :
- Plage 1 -> A10:AA10
- Plage 2 -> AB10:AU10
- Plage 3 -> AV10:BO10
- Plage 4 -> BP10:CI10

Si le nombre de valeurs de la plage 1 est supérieur à 0, mettre 1, mais
Si le nombre de valeurs de la plage 2 est aussi supérieur à 0, mettre 2,
Etc.
Voir le fichier joint, feuille Prévisionnel colonne CK : https://www.cjoint.com/c/IDmphjTvUn8
L'idée c'est de compter le nombre de "Forfait semaine".
L'enfant est-il venu au cours de la semaine 1 ? Oui, alors un forfait / Non, alors pas de forfait.

Merci beaucoup pour votre aide !

Configuration: Windows 7 (64 bits)
Google Chrome (dernière version)
Intel(R) Core(TM) i7 CPU
2.4GHz
Mémoire 8,00 Go


Bien à vous,
Naï
ps: je surveille tous mes sujets non résolus, si solution vous avez, je la lirais à coup sûr :)
Afficher la suite 

Votre réponse

2 réponses

Meilleure réponse
Messages postés
8884
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
20 avril 2019
1932
1
Merci
Bonjour

Je verrais plutôt quelque chose comme ça (totaliser les forfaits)
=SI(NBVAL(A10:AA10 )>0;1;0)+SI(NBVAL(AB10:AU10 )>0;1;0)+SI(NBVAL(AV10:BO10)>0;0;0)+SI(NBVAL(BP10:CI10)>0;1;0)

Cdlmnt

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 40516 internautes nous ont dit merci ce mois-ci

Nai
Messages postés
584
Date d'inscription
vendredi 29 avril 2005
Statut
Membre
Dernière intervention
12 avril 2019
56 -
Parfait !
J'avais pas pensé au "+" :/
Merci beaucoup !
Commenter la réponse de ccm81
Messages postés
1722
Date d'inscription
jeudi 2 juillet 2015
Statut
Membre
Dernière intervention
19 avril 2019
637
0
Merci
Bonjour,

Vous pouvez essayer avec ca ? :
=Si(OU(NBVAL(A10:AA10 )>0;NBVAL(AB10:AU10 )>0;NBVAL(AV10:BO10)>0;NBVAL(BP10:CI10)>0);1;0)

A Vaincre sans péril, on triomphe sans gloire.
Pierre Corneille, Le Cid 
Commenter la réponse de diablo13800