Menu

Formule complexe excel

Messages postés
4
Date d'inscription
vendredi 15 mars 2019
Dernière intervention
15 mars 2019
- - Dernière réponse : eriiic
Messages postés
22526
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
15 mars 2019
- 15 mars 2019 à 18:16
Bonjour,

N'étant pas une experte sur Excel, je n'arrive pas à rentrer une formule qui me permettrait d'avoir le résultat pour un cas comme celui ci :

Si B1 < D1 alors le résultat = C1 - B1 sinon = 0
Mais si B1< D1 et que C1>D1 alors le résultat = C1 - D1
Mais si B1 < D1, que C1>D1 et que le résultat C1 - D1 est > ou = à 8 alors il sera égale à 8

J'ai fait tout un tas de formules avec SI ET OU CONDITIONS mais j'ai un message d'erreur à chaque fois.

La dernière formule utilisé est la suivante mais ça n'a pas marché (je m'en doutais un peu) :

=SI(B1<D1;(C1-B1);(0);SI(ET(B1>D1;C1>D1;(C1-D1);SI(C1-D1>=8);(8))))

Merci pour vos aides si précieuses car là je ne m'en sorts pas du tout et j'en ai vraiment besoin!!!
Afficher la suite 

Votre réponse

2 réponses

Messages postés
23617
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
15 mars 2019
5676
0
Merci
Bonjour
peut être avec:
=SI(B1<D1;B1-C1;SI(ET(B1>D1;C1>D1);MIN(C1-D1;8))
crdlmnt

Gab27_1979
Messages postés
4
Date d'inscription
vendredi 15 mars 2019
Dernière intervention
15 mars 2019
-
Merci beaucoup Vaucluse pour cette réponse rapide.
Malheureusement le résultat est erroné car il ne prend pas en compte cette partie :
"si le résultat C1 - D1 est > ou = à 8 alors il sera égale à 8 "
Auriez-vous une autre proposition Vaucluse?
Cordialement
yclik
Messages postés
1561
Date d'inscription
vendredi 25 juillet 2014
Dernière intervention
15 mars 2019
422 -
une autre proposition
=SI(ET(B1<D1;C1>D1;C1-D1>=8);8;C1-D1)
Gab27_1979
Messages postés
4
Date d'inscription
vendredi 15 mars 2019
Dernière intervention
15 mars 2019
-
Bonjour yclik,

J'ai voulu faire simple mais peut-être qu'en procédant de la sorte j'ai omis des éléments qui sont peut-être nécessaire dans la formule.

Donc pour être plus précise :

Si B1 < D1 alors le résultat = C1 - B1 sinon = 0
Mais si B1< D1 et que C1> D1 alors le résultat = C1 - D1
Mais si B1< D1 et que C1 < D1 alors le résultat = C1 - B1
Et si B1 < D1, que C1> D1 et que le résultat C1 - D1 est > ou = à 8 alors il sera égale à 8
Mais si B1 < D1, que C1> D1 et que le résultat C1 - D1 est < 8 le résultat sera D1 - B1

Lorsque je rentre votre formule yclik, le résultat obtenu correspond pour faire simple à la formule : C1 - D1

Merci beaucoup pour votre réponse, cependant ayant été un peu plus clair auriez-vous autre chose à me proposer?
Gab27_1979
Messages postés
4
Date d'inscription
vendredi 15 mars 2019
Dernière intervention
15 mars 2019
-
Ou sinon une formule peut être plus simple comportant au moins :
Si B1 < D1 alors le résultat = C1 - B1 sinon = 0
Mais si B1< D1 et que C1> D1 alors le résultat = C1 - D1 sinon = C1 - B1
Commenter la réponse de Vaucluse
Messages postés
22526
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
15 mars 2019
7257
0
Merci
Bonjour,

Mais si B1< D1 et que C1> D1 alors le résultat = C1 - D1
Mais si B1< D1 et que C1 < D1 alors le résultat = C1 - B1

il manque le cas B1= D1
J'ai fait C1>D1, et donc C1 <= D1

=SI(B1>=D1;0;SI(C1>D1;MIN(8;C1-D1);C1-B1)) 

eric
En essayant continuellement, on finit par réussir. 
Donc plus ça rate, plus on a de chances que ça marche.(les Shadoks)
En plus du merci (si si, ça se fait !!!), penser à mettre en résolu. Merci
Commenter la réponse de eriiic