Menu

Formule excel SI à rallonge ...

-
Bonjour,

Je suis novice sur excel et je cherche à faire une formule type "Si Mr DUPONT dans une cellule, ecrire automatiquement 100, SI ROBERT ecrire 222" …. ect et copier cette formule sur environ 50 lignes.

Bref ça me donne une formule du type:
=SI(NB.SI(B3;"*Guillaume");"ami2";SI(NB.SI(B3;"*Guilleux");"ami1,5+mau";SI(NB.SI(B3;"*Baudouin");"ami1+mau";SI(NB.SI(B3;"*Colombel");"ami1,5+mau";SI(NB.SI(B3;"*Gueneve");"ami1+mau";SI(NB.SI(B3;"*Lesenechal");"ami3+1/2";SI(NB.SI(B3;"*Lerouilly");"ami1+1/2";SI(NB.SI(B3;"*Vicquelin");"ami1,5+mau";SI(NB.SI(B3;"*Bagonneau");"ami1+mau";SI(NB.SI(B3;"*Lecouvey");"ami1,5+mau";SI(NB.SI(B3;"*Millot");"ami1,5+mau";"X")))

Mais .. beaucoup plus longue ce qui me donne un message "64 niveaux d'imbrication" et je ne peu pas valider cette formule!!

Quelqu'un à t'il une solution ?

Par avance merci à tous!





Configuration: Windows / Edge 18.17763
Afficher la suite 

Votre réponse

2 réponses

Meilleure réponse
Messages postés
2315
Date d'inscription
samedi 19 avril 2008
Dernière intervention
19 mars 2019
288
1
Merci
Bonjour,

Tu fais un tableau avec d'un coté tes cellules a chercher et de l'autre le texte correspondant, tableau que tu nommes tab

et tu mets dans ta cellule = recherchev(b3;tab;2;0)


Crdlmt

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 49213 internautes nous ont dit merci ce mois-ci

Commenter la réponse de DjiDji59430
Messages postés
23640
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
19 mars 2019
5685
0
Merci
Bonsoir
voyez si ce modèle peut vous aider et revenez si besoin avec plus d'informations sur votre demande et l'organisation de vos données ou alors déposez un modèle avec quelques explications sur vos données sur le site où vous avez trouvé celui ci.
https://mon-partage.fr/f/w1ZwvagM/
crdlmnt

DjiDji59430
Messages postés
2315
Date d'inscription
samedi 19 avril 2008
Dernière intervention
19 mars 2019
288 -
Bonjour Vaucluse,

C'est marrant, moi, je le vois complètement de l'autre sens !
Une colonne avec seulement les noms et un tableau de correspondance phrase/data.
Et pour le même résultat, forcément.
Commenter la réponse de Vaucluse