Menu

Excel Liste déroulante avec choix prédéfinis [Résolu]

Messages postés
4
Date d'inscription
jeudi 31 janvier 2019
Dernière intervention
31 janvier 2019
- - Dernière réponse : T-Mii
Messages postés
4
Date d'inscription
jeudi 31 janvier 2019
Dernière intervention
31 janvier 2019
- 31 janv. 2019 à 14:11
Bonjour


Suite a mon image ci-dessus (exemple),
Dans ma liste déroulante je souhaiterai que selon mon choix il y est sur le côté les sujet qui correspondante a ma liste.

Par exemple si je choisi Animaux, j'aimerai que chien et chat se mette dans les cases de D20 et E20.

Merci d'avance pour votre réponse,

Cordialement,
Afficher la suite 

Votre réponse

2 réponses

Messages postés
23531
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 février 2019
5635
0
Merci
Bonjour
voyez si vous pouvez adapter ce modèle et revenez si difficultés
https://mon-partage.fr/f/akbB1KM4/
crdlmnt
T-Mii
Messages postés
4
Date d'inscription
jeudi 31 janvier 2019
Dernière intervention
31 janvier 2019
-
Merci de votre réponse,
mais je pense que je me suis mal expliqué par exemple lorsque je fais un choix dans la liste déroulante j'aimerai que les réponses se mettent automatiquement dans les cases sur l côté sans les choisir.
(Par exemple mon image) si je choisis la catégorie animaux, Chien et chat se mettent automatiquement sur les cases a droite chien en D20 et Chat en E20
Commenter la réponse de Vaucluse
Messages postés
23531
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 février 2019
5635
0
Merci
alors si vous avez un tableau des références à ressortir comme celui de votre image, soit A1:C3 avec la liste du menu en A:
menu déroulant en A5 (à adapter)
=SIERREUR(RECHERCHEV($A5;$A$1:$C$3;COLONNE(B$1));"")
à tirer sur le nombre de colonnes utiles en fonction du nombre d'info à ressortir
cette formule vous renverra 0 si il n'y a pas de valeur au rang correspondant dans les références, rien si A5 est vide
vous pouvez masquer les 0 via les options Excel
crdlmnt
T-Mii
Messages postés
4
Date d'inscription
jeudi 31 janvier 2019
Dernière intervention
31 janvier 2019
-
Je n'y arrive pas çà m'a l'air compliqué aurais tu un exemple a me fournir ou que tu puisse aire directmeent que je puisse voir les maccros ?
Vaucluse
Messages postés
23531
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 février 2019
5635 -
Voila voila...il n'y a aucune macro
https://mon-partage.fr/f/55ZbCaZf/
si problème, déposez le modèle de ce que vous voulez faire sur le site où vous avez trouvé celui ci, en anonymisant les données si confidentialité
crdlmnt
T-Mii
Messages postés
4
Date d'inscription
jeudi 31 janvier 2019
Dernière intervention
31 janvier 2019
-
Merci c'est exactement ce que je cherche a faire je me débrouillerai pas la suite,
Encore merci !
Commenter la réponse de Vaucluse