Menu

Formule excel

Messages postés
2
Date d'inscription
samedi 5 janvier 2019
Dernière intervention
5 janvier 2019
- - Dernière réponse : Raymond PENTIER
Messages postés
47959
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
19 janvier 2019
- 6 janv. 2019 à 18:13
Bonjour à tous.
Je cherche à modifier un tableau de pointage d'heures que j'ai créé. Dans une colonne, je récupères en B8 le 1er jours du mois via la formule =CNUM(CONCATENER(1;"/";D2;"/";F2)),1=année, D2=janvier, F2=2019, ce qui me donne automatiquement le résultat "mar 01". Puis j'applique la formule =B8+1 pour afficher les autres jours du mois.
Maintenant, je cherche une formule qui me permettrait d'afficher dans une cellule le chiffre 1 (ou autre chose) à chaque dimanches (affichés "dim 06"). Et là je bloque, car le "dim" n'est reconnu dans aucunes conditions que je connaisse. Le but est de récupérer cette information, de l'ajouter à une 2eme condition (un code pour le poste de travail), pour connaitre le nombre de dimanches travaillés.
En espérant avoir été clair dans mes explications.
Merci à vous
Afficher la suite 

Votre réponse

5 réponses

Messages postés
23319
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
19 janvier 2019
5551
0
Merci
Bonsoir

tout d'abord pour la date, au lieu de concaténer et numériser, plus directement:
=DATE(F2;D2;1)

avec en F2 l'année et en D2 le N° du mois
pour avoir votre type d'affichage vous pouvez ensuite formater les cellules en
format / personnalisé / type: mmmm jj pour avoir l'écriture complète du mois ou mmm jj pour avoir l'écriture en abrégé.
(La valeur numérique de la date est conservée)

ensuite pour détecter les dimanches, si votre date est en B8, en C8:
=SI(JOURSEM(B8;2)=7;1;"")


crdlmnt


Commenter la réponse de Vaucluse
Messages postés
2
Date d'inscription
samedi 5 janvier 2019
Dernière intervention
5 janvier 2019
0
Merci
Bonsoir

Votre formule "=SI(JOURSEM(B8;2)=7;1;"")" fonctionne directement sur mon format,sans modification (format jjj jj). Il ne me reste plus qu'a ajouter la condition "ET" si le poste de travail =NW.

Pour ma compréhension, je vois à quoi correspond le 7 (7eme jour de la semaine), mais le 2???

Merci pour votre aide

Cdlt
Commenter la réponse de Belgarion53
Messages postés
47959
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
19 janvier 2019
15486
0
Merci
Excel donne l'explication dans la bulle d'aide à la saisie :

Commenter la réponse de Raymond PENTIER
Messages postés
15611
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
19 janvier 2019
3577
0
Merci
Bonjour à tous

comme indiqué par Raymond, 2 correspond à un départ le lundi (utile pour travaux sue une semaine ouvrée (du Lundi au Vendredi)

on aurait pu écrire pour un départ le dimanche
=Joursem(B8) ou =Joursem(B8,1)

et comme aujourdhui 6/1 nous sommes dimanche, la formule renverrait 1
Commenter la réponse de michel_m
Messages postés
23319
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
19 janvier 2019
5551
0
Merci
Bonjour
(bonjour Michel et bonne année)

petit complément en fonction de ce que vous nous dites:
vous pouvez accéder directement au résultat cherché dans passer par la colonne intermédiaire avec:

=SOMMEPROD((JOURSEM(Champ dates;2)=7)*(champ date>0)*(champ code="NW"))


l'item >0 sert à éliminer la prise en compte d'éventuelle cellules dates vides, qu'Excel considère comme un jour de semaine correspondant au 0 janvier 1900 (va savoir pourquoi?)

vu le poids de la formule, limitez les champs aux nombres de lignes utiles

crdlmnt


Raymond PENTIER
Messages postés
47959
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
19 janvier 2019
15486 -


Bonjour, mon ami Vaucluse, et très Bonne Année 2019 !

N'oublie pas que le calendrier d'Excel démarre le 1er janvier 1900 avec la valeur 1 et le format Date.

Ainsi le nombre 31, affiché au format Date, donne 31 janvier 1900.
Commenter la réponse de Vaucluse