Menu

Formules Excel pour permettre un tri par priorité

Messages postés
125
Date d'inscription
lundi 29 décembre 2014
Dernière intervention
12 décembre 2018
- - Dernière réponse : didibonf
Messages postés
344
Date d'inscription
vendredi 18 juillet 2008
Dernière intervention
13 décembre 2018
- 13 déc. 2018 à 10:14
Bonjour,

Je recherche une formule qui me permettrait de créer des priorités.

A partir d'un fichier excel qui disposera de plusieurs colonnes (NOM + Prénom + date de naissance), je dois réaliser un tri et donner un ordre de priorité comme ci-dessous :

NOM Prénom Date de naissance Priorité
= = = 0
différent différent = 1
différent différent MM/AAAA = 1
= différent MM/AAAA = 2
= différent différent 3
différent = différent 4
différent différent différent 5


Pensez vous qu'il me soit possible à partir d'une formule excel de déterminer ces priorités.

Encore merci à vous, votre aide m'est toujours très utile.

Zara70
Afficher la suite 

Votre réponse

3 réponses

Messages postés
256
Date d'inscription
lundi 2 juillet 2018
Dernière intervention
13 décembre 2018
0
Merci
Bonjour

Un aperçu de ton fichier serait le bienvenu pour plus de compréhension ,avec explications
Pour transmettre un fichier, il faut passer par un site de pièce jointe tel que cjoint.com

Va sur ce site : http://cjoint.com
Clic sur parcourir,
Cherche ton fichier,
clic sur ouvrir,
Clic sur "Créer le lien cjoint",
Copier le lien,
Revenir ici le coller dans une réponse..
Cordialement
zara70
Messages postés
125
Date d'inscription
lundi 29 décembre 2014
Dernière intervention
12 décembre 2018
-
Bonjour JCB40,

Je viens de formaliser ta demande dans le lien ci-dessous
https://www.cjoint.com/c/HLhiKHLCR2h

En espérant que ma requête soit possible.

Bonne journée

Zara70
Commenter la réponse de JCB40
Messages postés
125
Date d'inscription
lundi 29 décembre 2014
Dernière intervention
12 décembre 2018
0
Merci
Bonjour
Je viens vous transmettre le lien pour le fichier demandé, avec mes explications dans le 3ème onglet, en espérant que celles ci soient claires pour vous.
N'hésitez pas à me faire vos remarques....

https://www.cjoint.com/c/HLhiKHLCR2h

Merci beaucoup

Zara70
Commenter la réponse de zara70
Messages postés
344
Date d'inscription
vendredi 18 juillet 2008
Dernière intervention
13 décembre 2018
0
Merci
Bonjour,
Une proposition :
https://www.cjoint.com/c/HLhjh4PfTVd
didibonf
Messages postés
344
Date d'inscription
vendredi 18 juillet 2008
Dernière intervention
13 décembre 2018
-
Bonjour,
La formule fait déjà la conversion mois et année. Il faut maintenant retirer la comparaison des prénom si je comprends bien. La priorité 5 n’existe plus dans ce cas.
https://www.cjoint.com/c/HLmiMKT1Lbd
zara70
Messages postés
125
Date d'inscription
lundi 29 décembre 2014
Dernière intervention
12 décembre 2018
-
encore merci à vous. je vais tester cela de mon côté et vous faire un retour au plus vite.
Sans vouloir vous embéter, dans le fichier j'ai tout de même des dates de naissance avec" //1956" par exemple. Compte tenu du format du fichier, celui que vous m'avez renvoyé, je voulais transformer cette date pour arriver à écrire 00/00/1956 et ainsi faire le rapprochement de la date de naissance 1 et date de naissance 2.
Malheureusement je ne peux en aucun cas exploiter cette donnée. Auriez vous une solution ?
Merci pour votre patience.

Zara70
didibonf
Messages postés
344
Date d'inscription
vendredi 18 juillet 2008
Dernière intervention
13 décembre 2018
-
Vous pouvez utiliser la fonction =sierreur. Si la fonction mois ou annee ne fonctionne pas car la date n’est pas correcte (comme c’est le cas avec //1956), on retourne la valeur FAUX dans la condition.
=SI(ET(A2=C2;B2=D2);0;SI(ET(A2<>C2;SIERREUR(MOIS(B2)=MOIS(D2);FAUX);SIERREUR(ANNEE(D2)=ANNEE(B2);FAUX));1;SI(ET(A2=C2;SIERREUR(MOIS(B2)=MOIS(D2);FAUX);SIERREUR(ANNEE(D2)=ANNEE(B2);FAUX));2;SI(ET(A2=C2;B2<>D2);3;SI(ET(A2<>C2;B2<>D2);4)))))
Bonsoir didibonf,
Malheureusement c est sans succès pour moi. Il m est impossible de comparer l’annee du format date 12/03/2018 par exemple et les 4 derniers chiffres du texte //2016, afin de pouvoir dire si je suis sur la même année ou une année différente.
Je ne veux pas vous embêter d avantage. De mon côté je vais donc creuser.
Encore merci d avoir bien voulu m’aider.
Bonne soirée

Zara70
didibonf
Messages postés
344
Date d'inscription
vendredi 18 juillet 2008
Dernière intervention
13 décembre 2018
-
Dans vos critères vous comparer mois ET année, je ne pensais donc pas nécessaire de comparer les années s’il n’y avait pas de mois identique. Pour pouvoir comparer l’année il faut remplacer
SIERREUR(ANNEE(D2)=ANNEE(B2);FAUX) par :
SIERREUR(ANNEE(D2)=ANNEE(B2);SI(TEXTE(ANNEE(B2);"AAAA")=TEXTE(DROITE(D2;4);"AAAA");VRAI;FAUX))
Commenter la réponse de didibonf