Menu

PROBLEMES changement de couleur cellule par rapport à une date

-
Bonjour,
Merci pour les réponses, je joint donc un fichier avec ce qui me bloque car je n'avance pas. (pardon aussi pour le délais des remerciements soucis de connexion !!!).
Ce que j’essaie toujours d'avoir :
- que ma cellule change de couleur en vert ou rouge suivant si une date que j'ai fixé est dépassé par la date d'aujourd'hui
mon plus gros problème dans cette condition et que soit la couleur est fixe soit elle ne se fait que sur 1 seule cellule !!!
je joins donc le fichier avec quelques demandes supplémentaires !!!
Je vous remercie pour le temps que vous m'accorderez .
Afficher la suite 

Votre réponse

14 réponses

Messages postés
23182
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
16 décembre 2018
0
Merci
Bonjour
"je joins mon fichier"
et on le trouve comment?
à vous lire
crdlmnt
Commenter la réponse de Vaucluse
0
Merci
Bonsoir
Bon comment dire !!
Ne rigolez pas, mais je pensais que le fichier se joignait tout seul au message
bref
je pense avoir compris donc je mets le lien avec les explications dedans
Merci
https://www.cjoint.com/c/HLfumaoJ53f
Commenter la réponse de moitoimoi
Messages postés
543
Date d'inscription
dimanche 15 novembre 2015
Dernière intervention
10 décembre 2018
0
Merci
Bonsoir

Un essai avec ce que j'ai compris

https://mon-partage.fr/f/wop63ruU/

Slts
Commenter la réponse de The_boss_68
0
Merci
Bonsoir the BOSS
Merci pour l’idée du menu déroulant mais je pensais plutôt à une condition si cela est possible pour que ce se fasse dans le style
=SI(RAS;"VERT;INDISPONIBLE"ROUGE") =SI(RAS;"VERT";"INDISPONIBLE"ROUGE")

sinon pour retard et ok cela reste toujours en rouge

merci
Commenter la réponse de moitoimoi
Messages postés
16703
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
17 décembre 2018
0
Merci
Bonsoir,

je n'ai pas tout regardé, mais remplace la formule en J5 par cette formule et incrémente la vers le bas =SI(H5="";"";H5)

en suite sélectionne la plage J5:J9 et efface les deux mises en forme conditionnelle.
laisse la plage J5:J9 sélectionnée et mise en forme conditionnelle/Nouvelle règle/sélectionne Utiliser une formule pour déterminer etc .....
la formule à coller sous Appliquer une mise en forme etc ...
=K5="OK"
format/Remplissage/choisir la couleur verte

tu pourrais en rester la en colorisant ta plage de cellule en rouge

mais si tu peux également gérer par MFC la couleur rouge
recommencer à laisse la plage J5:J9 sélectionnée et mise en forme conditionnelle/Nouvelle règle/sélectionne Utiliser une formule pour déterminer etc .....
la formule à coller sous Appliquer une mise en forme etc ...
=K5="EN RETARD"
format/Remplissage/choisir la couleur rouge

si tu veux que les cellules de la colonne J et K se colorisent
sélectionne la plage J5:K9
dans ce cas la formule est (attention de bien placer le dollar $)
=$K5="OK"
Format/Remplissage etc ...
A+
Mike-31

Je suis responsable de ce que je dis, pas de ce que tu comprends...
Commenter la réponse de Mike-31
0
Merci
bonjour Mike
Merci pour votre réponse
j'ai mis en application votre explication mais je me trouve devant un nouveau problème
si je mets une date dans le contrôle pression, donc le travail a déjà été fait avant la date limite la case J 5 passe quand même ou reste quand même en rouge, elle devrait selon la faisabilité :
soit passer en vert ou si c'est trop difficile en blanc
ma case J5 me sert de repère visuel, la case K5 me sert à compter automatiquement avec le report dans la case C2
mais de colonne J et K peuvent aussi être fusionné avec mon visuel le rouge et le mot retard ou OK pour compter
Bon perso je n'y arrive pas !!
je joint le fichier corrigé avec les éléments
merci
https://www.cjoint.com/c/HLhnOc2VnSf
Commenter la réponse de moitoimoi
Messages postés
16703
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
17 décembre 2018
0
Merci
Re,

C'est en K que ta formule me pose problème, =SI(V5>V7;"EN RETARD";"OK")
d'après ton fichier colonne K tu auras toujours EN RETARD parce que V5 est toujours supérieur à V7

explique quand EN RETARD doit apparaître colonne K
et colonne V comment sont déterminé ces dates
Date de début 01/01/2018
Date de fin 05/12/2018

A+
Mike-31

Je suis responsable de ce que je dis, pas de ce que tu comprends...
Commenter la réponse de Mike-31
0
Merci
Bonsoir
Je pense ne pas avoir été très clair à la fin le tableau aura 20 ou 30 colonne peut être mais + de 500 lignes D’autre part j’ai un peut évolué : COLONE J ET K FONCTIONNENT enfin je pense !!! et je souhaiterais une aide pour ce qui suit à la fin :
Colonne J repère visuel
Colonne K repère écris mais qui aussi me sert à compter avec affichage en C2 c'est-à-dire que je lis retard OK et que le chiffre apparaît en C2
Dans cette colonne je veux couleur et RETARD ou OK ou RIEN si je suis dans la période de date
ENFIN
Date de début 01/01/2018
Date de fin 05/12/2018
Je fixe chaque année les dates ici elles sont à titre d’exemple pour voir si le tableau fonctionne par contre la date de début sera toujours 01/01/2…
je souhaiterais :
1) Peut-on faire une seule colonne avec j et K - fusionner ne fonctionne pas -
2) colonne N toute les lignes : Etat actuel doit rester une case qui se colorie : dans ce cas VERT ROUGE ORANGE l'anomalie colonne O est le code de ce qui est observé
ce que je suis arrivé à faire
colonne N je rentre 3 sortes de codes INDISPONIBLE RAS et du texte (peu importe) - cela se colorie en ROUGE VERT et ORANGE
ce que je n'arrive pas à faire :
colonne N cela se colorie ROUGE VERT ORANGE OU BLANC quand j'ecris ou pas dans la colonne O dans les meme conditions que j'ai expliqué en haut
POUR RESUMER
JE VEUX ECRIRE DANS LA COLONNE O OBSERVATION ET QUE CELA SE COLORIE DANS LA COLONNE N LA C'EST L'INVERSE !!!!!!!!
bonne soirée
je joins le fichier évolué
https://www.cjoint.com/c/HLjs7Dyz2if
Commenter la réponse de moitoimoi
Messages postés
16703
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
17 décembre 2018
0
Merci
Re,

j'ai du mal à suivre ton raisonnement, alors on va traiter un problème à la fois, tu écris "Dans cette colonne je veux couleur et RETARD ou OK ou RIEN" en parlant de la colonne K.
j'en déduis que tu veux que colonne K se colorise en fonction de sont contenu RETARD ou OK et donc colonne J ne sert plus à rien !

j'ai déjà attiré ton attention sur la formule colonne K =SI(V5>V7;"EN RETARD";"OK") qui ne me semble pas bonne parce que quel que soit le cas V5>V7 sera toujours supérieur, il faut que la date en V7 soit sur la ligne exemple en Date du contrôle pression
et dans ce cas en K tu écris =SI(H5>$V$5;"EN RETARD";"OK") et là ta mise en forme conditionnelle fonctionnera et le nombre de EN RETARD sera fonction de chaque ligne
enfin c'est ce que je comprends
https://www.cjoint.com/c/HLkjpDF21ej
Commenter la réponse de Mike-31
0
Merci
Bonjour
Super pour le fichier merci beaucoup
pour ce qui est du =SI(H5>$V$5;"EN RETARD";"OK") j'ai essayé mais je trouve que cela ne marche pas aussi bien POUR CE QUE JE VEUX FAIRE (je suis compliqué dans ma tète peut être)
En effet ce fichier est à disposition de bcp de personnes, mais je fixe seul des limites de dates nous comptons utiliser ce fichier sur 1 an pendant de longues années !!!!! alors je pense que comme ça il peut marcher en tout cas je garde ta formule au cas ou dans le fonctionnement !?!
Bon pour évoluer je souhaite maintenant ce qui risque de rejoindre ce que tu m'a expliqué
Dans la colonne DATE CONTRÔLE PRESSION je rentre une date (celle à laquelle je fais mon contrôle)
Tout en gardant le fonctionnement de la colonne K actuel (VERT/ROUGE) je voudrais lier la colonne H à la colonne K, c'est-à-dire que si ma date de contrôle est < à la date limite que j’ai déterminé en V7 ma colonne K reste en VERT sinon elle suit le processus actuel.

Date contrôle H Retard K Date limite V7 Date du jour V5
Retard(cellule rouge) 06/12/2018 10/12/2018
Ok (VERT) 11/12/2018 10/12/2018
05/12/2018 Ok (VERT) 06/12/2018 10/12/2018

https://www.cjoint.com/c/HLkqFY6cJAf
Commenter la réponse de moitoimoi
Messages postés
16703
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
17 décembre 2018
0
Merci
Re,

je n'ai toujours pas saisi ta logique, regarde si c'est ce que tu cherches

https://www.cjoint.com/c/HLkrYvjjrLj

A+
Mike-31

Je suis responsable de ce que je dis, pas de ce que tu comprends...
Commenter la réponse de Mike-31
0
Merci
bonsoir mike
Merci pour ta réponse
je regardes et je reviens si cela ne va pas je te tiens au courant
en tout cas merci beaucoup
Commenter la réponse de moitoimoi
0
Merci
Bonsoir à tous
Merci pour vos réponses
J"ai adapté certaines d'entre elles pour arriver au résultat escompté
mike tu as compris !!! super tu parles donc ma langue maintenant !!!! j'ai juste enlevé la couleur sur la colonne H le reste PARFAIT !!!!
Mille merci pour votre temps
Bonne continuation à tous à bientôt pour d'autre questions et....
Merci encore !
Commenter la réponse de moitoimoi
Messages postés
16703
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
17 décembre 2018
0
Merci
Re

si tes attentes sont satisfaites, je passe le statut en résolu.

Le langage informatique est un langage à part entière et il est important que chaque utilisateur essaye de ne pas l'adapter à sa sauce pour pouvoir se comprendre, à chacun de faire un effort.
Commenter la réponse de Mike-31