Menu

Problème d'affichage pubs adsense [Résolu]

- 10 sept. 2018 à 00:36 - Dernière réponse :
Messages postés
11
Date d'inscription
mardi 11 septembre 2018
Dernière intervention
24 octobre 2018
- 12 sept. 2018 à 23:01
Bonjour,

Je me permets de poster un message, car je rencontre actuellement un problème avec un de mes sites Internet.

En effet, mon site www.magazine-agathe.fr est bien valide et j'ai pu insérer le code adsense sur celui-ci.

Mais quand je me rends sur mon ordinateur (j'utilise safari et javascript est activé), aucune pub ne s'affiche.

Quand je vais sur mon site web depuis un mobile, la publicité s'affiche.

D'ailleurs, sur mon tableau de bord je peux voir l'activité de mon site et les clics sur les publicités ect...

Ma question est : pourquoi la publicité ne s'affiche pas quand je visualise mon site sur un ordinateur, mais qu'elle s'affiche sur mobile !

Je vous remercie par avance de votre aide (précieuse) !
Afficher la suite 

Votre réponse

11 réponses

Messages postés
4865
Date d'inscription
mercredi 30 octobre 2013
Dernière intervention
20 novembre 2018
Modifié par elgazar le 10/09/2018 à 08:06
0
Merci
Bonjour
tu devrais désactiver ton bloqueur de pub ;-)

A part ça, ta page d'accueil est bien trop lourde pour être performante, essaye d'optimiser tes images avec wp smushit pour la rendre plus rapide

Bonjour,

Merci Elgazar pour ta réponse.

Excuse moi pour la question, mais comment désactive tu le bloqueur de pub ?

Pour WP Smushit, j'ai déjà cette extension en place, et je l'utilise à chaque fois pour comprimer mes images. Pour l'optimisation j'ai également configuré les extensions Better WordPress Minify et WP Super Cache. Il y aurait t-il d'autres extensions d'optimisation à configurer ?

Merci !
Commenter la réponse de elgazar
Messages postés
4865
Date d'inscription
mercredi 30 octobre 2013
Dernière intervention
20 novembre 2018
10 sept. 2018 à 19:48
0
Merci
Les bloqueurs du pubs affichent généralement une petit icône en haut a droite ( mais cela dépends de ton navigateur) par contre si tu as supercache, il se peut que ce soit seulement le cache de ton site que tu vois (si sc a mis les pages en cache avant que tu mettes les pubs) dans ce cas, c'est le cache du plugin qu'il faut désactiver , effacer et remettre
l'optimisation des images dépends toujours du fichier original, si tu as une fichier haute résolution à 15 mo et qu'a près l'avoir optimisé, il ne fait plus que 5 mo, c'est une belle progression du poids mais cela le rend pas léger au sens premier du terme, c'est juste un fichier moins lourd

par exemple l'image parfum de printemps aux agrumes pèse a elle seule 3,16 mo et ce n'est pas la seule qui a du surpoids, tu as au moins 5 autres fichiers qui pèsent tous plus de 1 mo alors que dans l'idéal la plus lourde devrait peser dans les 500 ko voir moins

ps : c'est assez bizarre car tu as très bien nommé tes images pour favoriser le référencement ( de ce coté, rien a dire, c'est parfait) par contre tu as laissé les permaliens par défaut de wordpress(les ?p=25 dans tes urls) qui sont un tue-position d'habitude les débutants font le contraire.
Dépêche toi de les modifier en allant dans le menu réglages=> permaliens et coche "titre de publication" avant que google n'indexe trop tes pages sinon tu perdras quelques jours
Merci Elgazar pour ta réponse et tes conseils.

J'ai modifié les permaliens en indiquant titre de publication, je ne sais pas pourquoi il était configuré comme ça !

Pour l'optimisation des images, j'utilise Smush version gratuite, mais je n'ai pas l'impression que cela soit super comme extension, car je ne vois pas d'amélioration majeure.

J'avoue qu'avec ce site web j'ai essayé d'utiliser un max d'extension pour accélérer la vitesse sans réel succès, je me tire les cheveux !!

J'ai même pensé investir dans WP Rocket, est-ce une bonne extension ?

Merci beaucoup !
Commenter la réponse de elgazar
Messages postés
11
Date d'inscription
mardi 11 septembre 2018
Dernière intervention
24 octobre 2018
Modifié par overcool le 11/09/2018 à 02:29
0
Merci
Je suis d'accord avec elgazar,

Ta page est beaucoup trop lourde 36.7s de chargement. C'est dommage car elle est agréable visuellement, mais un utilisateur attendra très rarement aussi longtemps.

Tu as un score PageSpeed de F à cause de tes images principalement ce qui n'est pas très bon pour le SEO. Tu charges des images de 2800*2800 alors que tu affiches du 380*380.

Tu as aussi d'autres petits axes d'amélioration. Tu utilises des caches expiration de seulement 15 min sur des images ?

https://gtmetrix.com/reports/magazine-agathe.fr/2WCjAFpO

Avec quelques optimisations tu peux facilement monté à 80% mini est une note de B

Merci Overcool pour ta réponse.

Effectivement j'ai bien conscience que mon site est très long à charger, et je lutte depuis des semaines pour arriver à réduire le chargement en vain, d'où mon installation de WP super Cache, de Smush et de Minify.

Pour les images, j'utilise Smush (en version gratuite), mais je n'ai pas vu d'amélioration majeure !

Petite question : pour le redimensionnement des images, dois-je le faire avant le transfert de mes images sous wordpress directement sous le format 380*380 ?

Pour les caches d'expiration, effectivement j'ai configuré WP super Cache avec les données de base. Combien de temps il est préférable d'indiquer pour les images ?

Je gère plusieurs sites web, et je n'ai jamais eu de problème avec le chargement et pourtant ils contiennent beaucoup d'images, mais je dois avouer que je me tire les cheveux avec celui-ci !!

Encore merci pour le rapport gtmetrix cela donne une super vision de ce qui se passe. Et merci pour vos conseils précieux !
Commenter la réponse de overcool
Messages postés
11
Date d'inscription
mardi 11 septembre 2018
Dernière intervention
24 octobre 2018
Modifié par overcool le 12/09/2018 à 00:05
0
Merci
Pour l'expiration généralement avec du contenu static type (image, css, Js) et sur un site en production tu peux mettre 30 jours. Tu peux redimensionné sous wordpress ou en amont peu importe. Tu n'es pas obligé de faire du 380*380 si tu as besoin à certains endroits d'une image un peu plus grande.

A titre de comparaison une image optimisé en 1024x768(jpeg progressive) fait moins de 200Kb.

Normalement quand tu uploads une image wordpress génère plusieurs tailles d'images mais à priori ton thème ou les plugins de ta page d'accueil utilise les images originale ou en tous cas trop grande. Smush optimise les images mais si tu utilises l'image original cela ne sert à rien.

Super j'en prend note.

J'ai pu mettre en place les extensions Imagify pour la compressions d'images et WP Rocket, après vérifications, je suis maintenant passée de 36.7s de chargement à 4 secondes.

Je pense que je ne peux pas faire moins !!!

Merci pour tes conseils !
Commenter la réponse de overcool
Messages postés
11
Date d'inscription
mardi 11 septembre 2018
Dernière intervention
24 octobre 2018
Modifié par overcool le 12/09/2018 à 19:54
0
Merci
C'est mieux en effet mais tu peux encore améliorer de 50% facilement. Tu charges toujours des images beaucoup trop grande pour ton utilisation.

https://gtmetrix.com/reports/magazine-agathe.fr/4wUb3bNX

Les deux premières images de ce rapport (click sur la ligne "Serve scaled images" ) par exemple font près de 2.5Mo cumulé alors que selon la taille que tu utilises ça ne devrait même pas atteindre 100 Ko.

Si tu te soucis d'avoir un bon référencement ce sont des choses à optimisé.
Ok, j'ai installé Imagify et j'ai compressé directement l'ensemble de ma galerie média.

Je pense du coup supprimer les images concernées, les optimiser manuellement à 1024x768, puis en les important de nouveau.

Est-ce qu'une opération de ce type peut avoir des effets positifs sur mon rapport ( et surtout mon référencement !)

Merci à toi !
Commenter la réponse de overcool
Messages postés
11
Date d'inscription
mardi 11 septembre 2018
Dernière intervention
24 octobre 2018
12 sept. 2018 à 23:01
0
Merci
Tout ce que tu feras et qui permettra d'alléger le poids de la page et par conséquent le temps de chargement sera un plus pour ton référencement et accessoirement pour la navigation clients.

Ton probléme est que tu charges des photos non adaptées sur la page d'accueil. Je ne connais pas ce thème elegant-magazine-pro mais je suis aller voir sur le site de l'éditeur (afthemes) et ce probléme n'apparait pas.

Cela veut dire que tu ne l'utilises pas correctement. Soit tu as un réglage quelque part qui te permet de choisir les images à utiliser en page d'accueil, soit l'image est tiré depuis "l'image de mise en avant" de l'article et dans ce cas il faut que tu choisisses le format approprié puisque encore une fois Wordpress génère par défaut plusieurs taille d'image.

Sans avoir accès à ce thème c'est difficile de répondre et j'imagine que la meilleur option est de posé la question chez afthemes.
Commenter la réponse de overcool