Menu

Formule : si une formule contient un nombre, alors [Fermé]

- - Dernière réponse : DjiDji59430
Messages postés
2408
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
24 juin 2019
- 8 févr. 2018 à 14:27
Bonjour à tous,

Mon objectif est de faire apparaître dans un cellule le contenu de la cellule B1si la formule que contient la cellule A1 contient un 108 (la formule peut être soit XX*108 soit XX*45, avec XX une cellule quelconque).
La formule que j'ai testé est la suivante :
=SI(ESTNUM(CHERCHE("108";A1));B1;0)
Malheureusement, j'ai l'impression qu'Excel ne détecte pas le 108 car il est dans une formule et n'apparaît pas dans la cellule directement.

Si quelqu'un a une solution à cette question, ce serait d'une grande aide.

Merci d'avance,

PS : l'étape suivante, mais facultative, serait en réalité de trouver un formule sommant plusieurs cellule de la colonne A en fonction de leur équivalent dans la colonne B (sur le même critère que ci-dessus). Mais le =SI ne fonctionnant pas, le =SOMME.SI n'est pour l'instant pas ma priorité.

Afficher la suite 

1 réponse

Messages postés
2408
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
24 juin 2019
260
0
Merci
Bonjour ,

Joins un fichier-test, (avec TOUTES les explications et les résultats souhaités) ou mieux, si c'est possible, le fichier concerné, c'est plus commode pour les intervenants.

1) Tu vas dans http://cjoint.com/
2) Tu cliques sur [Parcourir] pour sélectionner ton fichier
3) Tu descends en bas de la page pour cliquer sur [Créer le lien Cjoint]
4) Au bout de quelques secondes s'affiche le lien en bleu souligné ; tu le sélectionnes et tu fais "Copier"
5) Tu reviens dans la discussion, et, dans ton message de réponse, tu fais : "Coller".

Cordialement.