Menu

Excel - Calcul - séparer les négatifs des positifs [Résolu]

jocelyne51 23 Messages postés lundi 21 janvier 2008Date d'inscription 19 juin 2018 Dernière intervention - 2 oct. 2017 à 15:36 - Dernière réponse : jocelyne51 23 Messages postés lundi 21 janvier 2008Date d'inscription 19 juin 2018 Dernière intervention
- 3 oct. 2017 à 10:38
Bonjour,

Je cherche dans un tableau d'heures salariés à créer une formule sur une même colonne : une qui ne m'additionnant que les valeurs négatives et la case suivante que les positives. Désolée si ma question parait idiote mais je n'ai pas de formation Excel et là j'avoue que je sèche.
Merci par avance de votre aide dans l'attente vous lire

https://img-19.ccm2.net/3meYu0PBICZZtY56DsX70RwsTek=/c478f0d9335649a280830d98040d4b23/ccm-ugc/EXCEL_-_Comment_ca_marche.jpg
Afficher la suite 

Votre réponse

4 réponses

JvDo 1819 Messages postés mercredi 27 juillet 2005Date d'inscription 11 juillet 2018 Dernière intervention - 2 oct. 2017 à 16:05
0
Merci
Bonjour,

Tu as plusieurs façons de le faire. En voici 3 pour les valeurs positives et la colonne B :
=SOMME((B2:B9>0)*(B2:B9)) ou =SOMME(SI(B2:B9>0;B2:B9;0)) ou =SOMMEPROD((B2:B9>0)*(B2:B9))

Les 2 premières sont matricielles. Il faut donc les valider par CTRL+MAJ+ENTER

Cordialement
jocelyne51 23 Messages postés lundi 21 janvier 2008Date d'inscription 19 juin 2018 Dernière intervention - 3 oct. 2017 à 10:37
Merci de votre réponse
super sympa et rapide
Commenter la réponse de JvDo
0
Merci
Bonjour jocelyne51,

Fichier Excel 2007 : https://mon-partage.fr/f/NQDW0JBA/

Si besoin, tu peux me demander une adaptation.
Merci de me dire si ça te convient.

Cordialement
 
jocelyne51 23 Messages postés lundi 21 janvier 2008Date d'inscription 19 juin 2018 Dernière intervention - 3 oct. 2017 à 10:38
Merci de votre réponse et du partage
super sympa et rapide
Commenter la réponse de willy