Menu

Si cellule contient... [Résolu]

Ludo_du33 - 15 sept. 2017 à 09:51 - Dernière réponse :  Ludo_du33
- 15 sept. 2017 à 10:04
Bonjour à tous,

Je travaille sur un tableur Google Sheets et je ne trouve pas la formule qui correspond a mon besoin..

En gros, je voudrais afficher dans une cellule un résultat en fonction de la cellule d'à côté si cette dernière contient une partie d'un texte, mais ce texte se trouvant aussi dans une autre cellule..

Par exemple : Si A1 contient ENTRE AUTRES A2 Alors A3.

Je ne sais pas si c'est clair.. Je sais le faire avec du texte (en mettant "*valeur*") mais pas avec le contenu d'une autre cellule..il me manque l'équivalent du "*...*" pour les cellules.

N'hésitez pas si vous avez besoin de précisions.

Merci beaucoup!


Afficher la suite 

Votre réponse

3 réponses

Meilleure réponse
Vaucluse 22215 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 17 juin 2018 Dernière intervention - Modifié par Vaucluse le 15/09/2017 à 10:02
1
Merci
Bonjour

remplacez si "*valeur*" par "*"&cell&"*"
cell étant l'adresse de cellule
Mais le code SI ne fonctionne pas avec ce genre d'écriture, il faut passer par NB.SI

=SI(NB.SI(Cell1;"*"&cell2&"*");...

pour info:
"*"&cell&"*" > contient
"*"&cell > se termine par
cell"*" > commence par
crdlmnt



La qualité de la réponse dépend surtout de la clarté de la question, merci!

Merci Vaucluse 1

Avec quelques mots c'est encore mieux Ajouter un commentaire

CCM a aidé 24356 internautes ce mois-ci

Commenter la réponse de Vaucluse
gbinforme 15058 Messages postés lundi 18 octobre 2004Date d'inscriptionContributeurStatut 17 juin 2018 Dernière intervention - 15 sept. 2017 à 10:03
0
Merci
Bonjour,

Avec cette formule tu devrais avoir ton résultat :
=SI(NON(ESTERREUR(TROUVE(A2;A1)));A3;"")
Commenter la réponse de gbinforme
0
Merci
Super merci beaucoup! Oui j'avais effectivement le Si(nb.si(...)..

C'est ce que je recherchais!
Merci beaucoup
Commenter la réponse de Ludo_du33