Menu

Recherche d'une formule sur Excel [Résolu]

samantha - 9 sept. 2017 à 16:11 - Dernière réponse : ccm81 8413 Messages postés lundi 18 octobre 2010Date d'inscription 24 mai 2018 Dernière intervention
- 9 sept. 2017 à 18:17
Bonjour,

Bjr
Alors je vais essayer de vous expliquer ce que je souhaiterais faire.

J'ai un tableau sur excel avec deux colonnes A et B. Dans A il y a 3 niveaux Débutant, Autonome et Expert (les niveaux peuvent se répéter). Dans la colonne B il y a des chiffres qui vont de 1 à 4.

Ce que je voudrais c'est une formule qui me donne le % de tous les Autonome qui ont 3 par ex . Le résultat doit être la somme de tous les autonome qui ont 3.

Merci d'avance
Afficher la suite 

Votre réponse

6 réponses

Aliboron Martin 2354 Messages postés samedi 1 janvier 2011Date d'inscriptionContributeurStatut 24 mai 2018 Dernière intervention - 9 sept. 2017 à 16:28
0
Merci
Deux fonctions permettent d'obtenir ce genre de résultat.

La plus "classique" serait =SOMME((A$2:A$25="Autonome")*(B$2:B$25=3)), à valider en mode matriciel

Dans les dernières versions d'Excel on peut préférer =NB.SI.ENS(A$2:A$25;"=Autonome";B$2:B$25;"=3") qui fait la même chose mais en se passant de la validation matricielle...
Merci pour réponse.
J'ai essayé mais ça ne marche pas pour les deux formules que vous m'avez donné :-(
J'ai réessayer et ça marche :-)
MERCIIIIIII d'avoir pris un peu de votre temps pour me répondre.

Bon week end
Commenter la réponse de Aliboron Martin
ccm81 8413 Messages postés lundi 18 octobre 2010Date d'inscription 24 mai 2018 Dernière intervention - 9 sept. 2017 à 16:42
0
Merci
Bonjour

Je ne sais pas si j'ai bien compris ta demande
http://www.cjoint.com/c/GIjoPTN1SiB

Cdlmnt
oui c'est tout à fait ça ccm81, mais est ce que je suis obligée de faire un tableau à côté?
Je dois intégrer cette formule sur plusieurs cellules... du coup je ne pourrais pas créer un tableau pour chaque cellule sachant que ma matrice est hyper complexe.
Commenter la réponse de ccm81
ccm81 8413 Messages postés lundi 18 octobre 2010Date d'inscription 24 mai 2018 Dernière intervention - Modifié par ccm81 le 9/09/2017 à 18:22
0
Merci
mais est ce que je suis obligée de faire un tableau à côté?
Non, tu as une seule formule en E7,
tu donnes le niveau en E2, le chiffre en E3 le reste n'est là que pour te montrer le détail
et si tu ne veux pas donner le niveau et le chiffre dans des cellules séparées, tu les mets dans la formule à la place de E2 et E3
exemple pour le niveau D et le chiffre 3
=SOMMEPROD(($A$2:$A$31="D")*($B$2:$B$31=3))/NB.SI($A$2:$A$31;"D")

Cdlmnt
Commenter la réponse de ccm81