Fonction RECHERCHEV sur plusieurs feuilles [Résolu/Fermé]

Messages postés
13
Date d'inscription
mercredi 26 avril 2017
Statut
Membre
Dernière intervention
21 juin 2017
- - Dernière réponse : Quinteboy06
Messages postés
13
Date d'inscription
mercredi 26 avril 2017
Statut
Membre
Dernière intervention
21 juin 2017
- 3 mai 2017 à 11:12
Bonjour,
Je poste ce sujet car je suis bloqué sur excel...
J'aimerais trouver une fonction rechercheV qui, en fonction de ce qu'on tape cherche dans 3 tableaux différents sur 3 feuilles différentes. Ces 3 tableaux sont des bases de données vitrages (vitrage monolithique, feuilleté, à couche) je ne peux donc les mélanger. J'ai d'abord essayé avec un recherchev, mais cela ne marche pas, je ne sais pas si c'est parce que les noms des vitrages sont un peu alambiqués ou autre...
Je récapitule donc, lorsque qu'en A5 (lien excel ci-dessous) je tape un nom de vitrage, (exemple "SGG Planitherm 10 mm"), la fonction me sorte toute les caractéristiques du vitrage cherché (Qu'il me sorte la ligne entière quoi).
Voila j'espère avoir été assez clair, n'hesitez à me redemander des explications ou autre.
Lien excel : https://mon-partage.fr/f/sVBoZ04B/
Dans l'attente de vos réponses,
Cordialement.
Afficher la suite 

7 réponses

Meilleure réponse
Messages postés
16952
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
15 octobre 2019
3631
4
Merci
Re,

toujours pas compris, il faut impérativement que Feuil1 en cellule A5 la valeur recherchée soit exactement orthographiée comme dans tes bases
formule à copier dans une cellule de ta Feuil1, à incrémenter vers la droite et à tester
si tu veux incrémenter vers le bas il faudra la modifier

=SIERREUR(RECHERCHEV($A$5;Tableau_Glazing8;COLONNE(B:B);0);SIERREUR(RECHERCHEV($A$5;Tableau_Glazing6;COLONNE(B:B);0);SIERREUR(RECHERCHEV($A$5;Tableau_Glazing7;COLONNE(B:B);0);"")))
A+
Mike-31

Je suis responsable de ce que je dis, pas de ce que tu comprends...

Dire « Merci » 4

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 64120 internautes nous ont dit merci ce mois-ci

Messages postés
13
Date d'inscription
mercredi 26 avril 2017
Statut
Membre
Dernière intervention
21 juin 2017
1
1
Merci
Salut Vaucluse !
Merci pour ta solution ça marche aussi bien que celle de Mike-31:)
Je vous remercie tout les 2 ça me permet de bien avancer dans mon projet.
Du coup Mike tu peux passer la discussion en "Résolu"
Merci de votre rapidité et de vos réponses productives !
Cordialement
Messages postés
16952
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
15 octobre 2019
3631
0
Merci
Bonjour,

Le problème enfin pour ma part je n'ai pas vu SGG Planitherm 10 mm n'existe sur aucune de tes trois feuilles
Messages postés
13
Date d'inscription
mercredi 26 avril 2017
Statut
Membre
Dernière intervention
21 juin 2017
1
0
Merci
Bonjour Mike-31 !
Tout d'abord merci de me répondre rapidement !
Ensuite dans l'exemple de nom de vitrage, pour le planitherm il y a différentes variantes comme le planitherm XN, ONE, ULTRA(désolé j'ai oublié de le préciser c'était un mauvais choix d'exemple ^^') etc...
mais sinon ils y sont bel et bien dans les bases de données "DB feuilletés" et "DB couche". Voila j'espère avoir répondu à ta question :).
Cordialement,
Messages postés
13
Date d'inscription
mercredi 26 avril 2017
Statut
Membre
Dernière intervention
21 juin 2017
1
0
Merci
Re-bonjour !
Grand merci à toi Mike-31 ça marche nickel c'était exactement ce qu'il me fallait ! l'incrémentation vers la droite marche nickel.
Merci à toi de m'avoir répondu si rapidement et de m'avoir apporté ton aide :)
Cordialement !
Messages postés
24596
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
18 octobre 2019
4833
0
Merci
bonjour
en attendant Mike (salut Mike), une solution ici:

voyez les notes en haut de feuille
https://mon-partage.fr/f/KplQCNLn/

crdlmnt
Messages postés
16952
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
15 octobre 2019
3631
0
Merci
Re, Salut l'ami Vaucluse,
et si tu veux le résultat en colonne, colle cette formule et incrémente vers le bas
=SIERREUR(RECHERCHEV($A$5;Tableau_Glazing8;LIGNE(2:2);0);SIERREUR(RECHERCHEV($A$5;Tableau_Glazing6;LIGNE(2:2);0);SIERREUR(RECHERCHEV($A$5;Tableau_Glazing7;LIGNE(2:2);0);"")))

si c'est ce que tu cherchais, je passe le statut de la discussion en résolu

A+
Mike-31

Je suis responsable de ce que je dis, pas de ce que tu comprends...