Comment acceder à l'interface web nagios [Fermé]

- - Dernière réponse : tchaning
Messages postés
4527
Date d'inscription
mardi 15 juillet 2008
Statut
Membre
Dernière intervention
13 juin 2014
- 11 mars 2010 à 16:50
Bonjour,
j'ai 1 probléme avec nagios j ai installer nagios et qd j vais acceder a l'interface web il me demande un nom d'utilisteur + mot de passe qd je les tape j'obtient ceci : [ 401 Authorization Required This server could not verify that you are authorized to access the document requested. Either you supplied the wrong credentials (e.g., bad password), or your browser doesn't understand how to supply the credentials required.
Apache/2.2.14 (Fedora) Server at localhost Port 80 ]
merci d'avoir lu mon msg
Afficher la suite 

1 réponse

Messages postés
4527
Date d'inscription
mardi 15 juillet 2008
Statut
Membre
Dernière intervention
13 juin 2014
227
-1
Merci
Authentification

Modifier le fichier cgi.cfg :

#vi /usr/local/nagios/etc/cgi.cfg

A la ligne 86 il y a écrit :
use_authentication =

Pour utiliser l’authentification il faut juste mettre cette variable différente de 0 (ex : 1).

Pour mettre un login et un mot de passe taper la commande :

#htpasswd –c /usr/local/nagios/etc/htpasswd.users nagiosadmin
New password : ****
Re-type password : ****

Il faut maintenant informer apache:

#vi /etc/apache2/conf.d/nagios.conf

Modifier :

ScriptAlias /nagios/cgi-bin /usr/local/nagios/cgi-bin/
<Directory "/usr/local/nagios/cgi-bin">
Options ExecCGI
AllowOverride None
Order allow,deny
Allow from all
AuthName "Nagios Access"
AuthType Basic
AuthUserFile /usr/local/nagios/etc/htpasswd.users
Require valid-user
</Directory>

Alias /nagios /usr/local/nagios/share/
<Directory "/usr/local/nagios/share">
Options None
AllowOverride None
Order allow,deny
Allow from all
AuthName "Nagios Access"
AuthType Basic
AuthUserFile /usr/local/nagios/etc/htpasswd.users
require valid-user
</Directory>

Relancer apache :

#/etc/init.d/apache2 restart

L’authentification devrait s’afficher quand vous voudriez accéder à votre page web nagios.