Signaler

Excel - Calcul - séparer les négatifs des positifs [Résolu]

Posez votre question jocelyne51 17Messages postés lundi 21 janvier 2008Date d'inscription 3 octobre 2017 Dernière intervention - Dernière réponse le 3 oct. 2017 à 10:38 par jocelyne51
Bonjour,

Je cherche dans un tableau d'heures salariés à créer une formule sur une même colonne : une qui ne m'additionnant que les valeurs négatives et la case suivante que les positives. Désolée si ma question parait idiote mais je n'ai pas de formation Excel et là j'avoue que je sèche.
Merci par avance de votre aide dans l'attente vous lire

http://img-19.ccm2.net/3meYu0PBICZZtY56DsX70RwsTek=/c478f0d9335649a280830d98040d4b23/ccm-ugc/EXCEL_-_Comment_ca_marche.jpg
Utile
+0
plus moins
Bonjour,

Tu as plusieurs façons de le faire. En voici 3 pour les valeurs positives et la colonne B :
=SOMME((B2:B9>0)*(B2:B9)) ou =SOMME(SI(B2:B9>0;B2:B9;0)) ou =SOMMEPROD((B2:B9>0)*(B2:B9))

Les 2 premières sont matricielles. Il faut donc les valider par CTRL+MAJ+ENTER

Cordialement
jocelyne51 17Messages postés lundi 21 janvier 2008Date d'inscription 3 octobre 2017 Dernière intervention - 3 oct. 2017 à 10:37
Merci de votre réponse
super sympa et rapide
Répondre
Donnez votre avis
Utile
+0
plus moins
Bonjour jocelyne51,

Fichier Excel 2007 : https://mon-partage.fr/f/NQDW0JBA/

Si besoin, tu peux me demander une adaptation.
Merci de me dire si ça te convient.

Cordialement
 
jocelyne51 17Messages postés lundi 21 janvier 2008Date d'inscription 3 octobre 2017 Dernière intervention - 3 oct. 2017 à 10:38
Merci de votre réponse et du partage
super sympa et rapide
Répondre
Donnez votre avis

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !