Signaler

Somme de plusieurs colonnes variables [Résolu]

Posez votre question CHARLYJACK 306Messages postés mardi 19 octobre 2010Date d'inscription 28 septembre 2017 Dernière intervention - Dernière réponse le 28 sept. 2017 à 20:53 par CHARLYJACK
Bonjour

je dois réaliser des sommes d'éléments situés sur des colonnes différentes pour regrouper en catégorie ( je ne peux pas déplacer les colonnes pas la même vision).

Chaque en tête de colonne contient un code.

Je souhaite réaliser la somme de la nature 1 pour la fonction A, pour la fonction B ...
puis nature 2.

Chaque fonction contient un ensemble de code. ( Petit tableau)

Je veux donc interroger la ligne 1, si le code de la colonne appartient à la selection du tableau (Fonction 1) l'integrer dans la somme....

J'ai mis un exemple de fichier pour tenter d'expliquer.

Quelle formule excel puis je utiliser pour realiser les sommes ?

Par avance merci de vos reponses.

lien du fichier

http://www.cjoint.com/c/GICmGKxylcK
Utile
+0
plus moins
Bonjour,

En W2 :
=SOMME.SI($B$1:$U$1;"<200";B2:U2)

En X2
=SOMME.SI.ENS(B2:U2;$B$1:$U$1;"<300";$B$1:$U$1;">=200")

En Y2 :
=SOMME.SI.ENS(B2:U2;$B$1:$U$1;"<400";$B$1:$U$1;">=300")

En Z2 :
=SOMME.SI($B$1:$U$1;">=400";B2:U2)

Etirer ensuite les formules vers le bas

Cdlmnt
Via
CHARLYJACK 306Messages postés mardi 19 octobre 2010Date d'inscription 28 septembre 2017 Dernière intervention - 28 sept. 2017 à 17:06
Bonjour

merci de cette reponse mais les codes du fichier sont juste des exemples.
Dans le vrai tableau il y a des codes avec des lettres également.

Désolé j'aurais du précisé
Répondre
via55 8385Messages postés mercredi 16 janvier 2013Date d'inscription 10 octobre 2017 Dernière intervention - 28 sept. 2017 à 17:17
OK

Alors envoie un fichier avec les bons codes qu'on voit s'il y a une logique exploitable
Répondre
CHARLYJACK 306Messages postés mardi 19 octobre 2010Date d'inscription 28 septembre 2017 Dernière intervention - 28 sept. 2017 à 17:49
http://www.cjoint.com/c/GICpWjwTKCK

j'ai mis un echantillon mais il n y a pas de logique

en tout cas je pense
Répondre
Donnez votre avis
Utile
+0
plus moins
Bon alors en passant par une fonction personnalisée :
http://www.cjoint.com/
Explications dans le fichier

Cdlmnt
Via
CHARLYJACK 306Messages postés mardi 19 octobre 2010Date d'inscription 28 septembre 2017 Dernière intervention - 28 sept. 2017 à 19:17
Bonsoir

je n'arrive pas à accéder au fichier
Répondre
via55 8385Messages postés mercredi 16 janvier 2013Date d'inscription 10 octobre 2017 Dernière intervention - 28 sept. 2017 à 19:31
et ici :
https://mon-partage.fr/f/u9P3Oghm/
Répondre
CHARLYJACK 306Messages postés mardi 19 octobre 2010Date d'inscription 28 septembre 2017 Dernière intervention - 28 sept. 2017 à 20:53
Bonsoir

super c'est parfait !

je chercher une solution sans vba mais ça me va très bien.

Un grand merci
Répondre
Donnez votre avis

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !