Somme de plusieurs colonnes variables [Résolu]

CHARLYJACK 306 Messages postés mardi 19 octobre 2010Date d'inscription 28 septembre 2017 Dernière intervention - 28 sept. 2017 à 14:45 - Dernière réponse : CHARLYJACK 306 Messages postés mardi 19 octobre 2010Date d'inscription 28 septembre 2017 Dernière intervention
- 28 sept. 2017 à 20:53
Bonjour

je dois réaliser des sommes d'éléments situés sur des colonnes différentes pour regrouper en catégorie ( je ne peux pas déplacer les colonnes pas la même vision).

Chaque en tête de colonne contient un code.

Je souhaite réaliser la somme de la nature 1 pour la fonction A, pour la fonction B ...
puis nature 2.

Chaque fonction contient un ensemble de code. ( Petit tableau)

Je veux donc interroger la ligne 1, si le code de la colonne appartient à la selection du tableau (Fonction 1) l'integrer dans la somme....

J'ai mis un exemple de fichier pour tenter d'expliquer.

Quelle formule excel puis je utiliser pour realiser les sommes ?

Par avance merci de vos reponses.

lien du fichier

http://www.cjoint.com/c/GICmGKxylcK
Afficher la suite 
306Messages postés mardi 19 octobre 2010Date d'inscription 28 septembre 2017 Dernière intervention

8 réponses

Répondre au sujet
via55 8786 Messages postés mercredi 16 janvier 2013Date d'inscription 11 décembre 2017 Dernière intervention - 28 sept. 2017 à 16:37
0
Utile
3
Bonjour,

En W2 :
=SOMME.SI($B$1:$U$1;"<200";B2:U2)

En X2
=SOMME.SI.ENS(B2:U2;$B$1:$U$1;"<300";$B$1:$U$1;">=200")

En Y2 :
=SOMME.SI.ENS(B2:U2;$B$1:$U$1;"<400";$B$1:$U$1;">=300")

En Z2 :
=SOMME.SI($B$1:$U$1;">=400";B2:U2)

Etirer ensuite les formules vers le bas

Cdlmnt
Via
CHARLYJACK 306 Messages postés mardi 19 octobre 2010Date d'inscription 28 septembre 2017 Dernière intervention - 28 sept. 2017 à 17:06
Bonjour

merci de cette reponse mais les codes du fichier sont juste des exemples.
Dans le vrai tableau il y a des codes avec des lettres également.

Désolé j'aurais du précisé
via55 8786 Messages postés mercredi 16 janvier 2013Date d'inscription 11 décembre 2017 Dernière intervention > CHARLYJACK 306 Messages postés mardi 19 octobre 2010Date d'inscription 28 septembre 2017 Dernière intervention - 28 sept. 2017 à 17:17
OK

Alors envoie un fichier avec les bons codes qu'on voit s'il y a une logique exploitable
CHARLYJACK 306 Messages postés mardi 19 octobre 2010Date d'inscription 28 septembre 2017 Dernière intervention > via55 8786 Messages postés mercredi 16 janvier 2013Date d'inscription 11 décembre 2017 Dernière intervention - 28 sept. 2017 à 17:49
http://www.cjoint.com/c/GICpWjwTKCK

j'ai mis un echantillon mais il n y a pas de logique

en tout cas je pense
Commenter la réponse de via55
via55 8786 Messages postés mercredi 16 janvier 2013Date d'inscription 11 décembre 2017 Dernière intervention - 28 sept. 2017 à 18:31
0
Utile
3
Bon alors en passant par une fonction personnalisée :
http://www.cjoint.com/
Explications dans le fichier

Cdlmnt
Via
CHARLYJACK 306 Messages postés mardi 19 octobre 2010Date d'inscription 28 septembre 2017 Dernière intervention - 28 sept. 2017 à 19:17
Bonsoir

je n'arrive pas à accéder au fichier
via55 8786 Messages postés mercredi 16 janvier 2013Date d'inscription 11 décembre 2017 Dernière intervention > CHARLYJACK 306 Messages postés mardi 19 octobre 2010Date d'inscription 28 septembre 2017 Dernière intervention - 28 sept. 2017 à 19:31
CHARLYJACK 306 Messages postés mardi 19 octobre 2010Date d'inscription 28 septembre 2017 Dernière intervention > via55 8786 Messages postés mercredi 16 janvier 2013Date d'inscription 11 décembre 2017 Dernière intervention - 28 sept. 2017 à 20:53
Bonsoir

super c'est parfait !

je chercher une solution sans vba mais ça me va très bien.

Un grand merci
Commenter la réponse de via55