Signaler

Si cellule contient... [Résolu]

Posez votre question Ludo_du33 - Dernière réponse le 15 sept. 2017 à 10:04 par Ludo_du33
Bonjour à tous,

Je travaille sur un tableur Google Sheets et je ne trouve pas la formule qui correspond a mon besoin..

En gros, je voudrais afficher dans une cellule un résultat en fonction de la cellule d'à côté si cette dernière contient une partie d'un texte, mais ce texte se trouvant aussi dans une autre cellule..

Par exemple : Si A1 contient ENTRE AUTRES A2 Alors A3.

Je ne sais pas si c'est clair.. Je sais le faire avec du texte (en mettant "*valeur*") mais pas avec le contenu d'une autre cellule..il me manque l'équivalent du "*...*" pour les cellules.

N'hésitez pas si vous avez besoin de précisions.

Merci beaucoup!


Utile
+1
plus moins
Bonjour

remplacez si "*valeur*" par "*"&cell&"*"
cell étant l'adresse de cellule
Mais le code SI ne fonctionne pas avec ce genre d'écriture, il faut passer par NB.SI

=SI(NB.SI(Cell1;"*"&cell2&"*");...

pour info:
"*"&cell&"*" > contient
"*"&cell > se termine par
cell"*" > commence par
crdlmnt



Donnez votre avis
Utile
+0
plus moins
Bonjour,

Avec cette formule tu devrais avoir ton résultat :
=SI(NON(ESTERREUR(TROUVE(A2;A1)));A3;"")
Donnez votre avis
Utile
+0
plus moins
Super merci beaucoup! Oui j'avais effectivement le Si(nb.si(...)..

C'est ce que je recherchais!
Merci beaucoup
Donnez votre avis

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !