Signaler

Formule excel

Posez votre question nanou72 - Dernière réponse le 21 avril 2017 à 19:01 par Mike-31
Bonjour,

je vous prie de bien vouloir m'aider svp car je bataille avec une formule qui ne marche pas du tout sur mon fichier :

- colonne A = 1ère date
- Colonne B = 2ème date
- colonne C = 3eme date

je dois vérifier si la 3ème date est comprise entre la 1ère date et la 2ème date si oui alors "Ok" si non alors "Out"

sauf que quand je mets cette formule :
= si(et(C1>=A1;C1<=B1);"ok";"out) ça ne marche pas et me met toujours "out" même si la date est bien comprise entre les 2 premières dates.

J'espère que j'étais claire en vous remerciant infiniment pour votre aide.

nanou72



Afficher la suite 
Utile
+0
plus moins
Salut,

Il faut vérifier plusieurs choses :
  • le format de tes dates. Elles sont normalement rentrées au format
    01/01/1990
    . Pour cela, tu peux regarder si excel a bien pris en compte la date ou non
  • la formule : il manque un " après le out mais excel aurait du te mettre un avertissement
    =SI(ET(C1>=A1;C1<=B1);"OK";"OUT")



Donnez votre avis
Utile
+0
plus moins
Bonsoir,

également à tester si tes valeurs sont mélangées dans les colonnes A et B
=SI(OU(NB.SI($A$2:$A$50;C2)>0;NB.SI($B$2:$B$50;C2)>0)=VRAI;"ok";"out")

et pour tester si colonne C est renseignée et éviter le out si la cellule en C est vide
=SI(C2="";"";SI(OU(NB.SI($A$2:$A$50;C2)>0;NB.SI($B$2:$B$50;C2)>0)=VRAI;"ok";"out"))
A+
Mike-31

Pas savoir n'est pas un échec, l'échec est le refus d'apprendre.
Donnez votre avis

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !